Lock manager not adding users

I just installed a Yale YRD256-ZW2 lock and installed Lock Code Manager. However, I can't add any users/codes with LCM. When I add a user, these are the log entries I get for LCM:

app:1062021-03-10 12:23:41.575 infogetNameUsage- result:[]

app:1062021-03-10 12:23:41.564 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:41.562 tracegetLockCodesFromDevices- device:Front door lock

app:1062021-03-10 12:23:41.560 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:41.558 tracegetLockCodesFromDevices- device:Front door lock

app:1062021-03-10 12:23:34.362 infogetNameUsage- result:[]

app:1062021-03-10 12:23:34.345 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:34.344 tracegetLockCodesFromDevices- device:Front door lock

app:1062021-03-10 12:23:25.206 infogetNameUsage- result:[]

app:1062021-03-10 12:23:25.187 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:25.185 tracegetLockCodesFromDevices- device:Front door lock

app:1062021-03-10 12:23:17.213 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:17.211 tracegetLockCodesFromDevices- device:Front door lock

app:1062021-03-10 12:23:14.984 infogetLockCodesFromDevices- complete

app:1062021-03-10 12:23:14.981 tracegetLockCodesFromDevices- device:Front door lock

I just installed the Yale YRD256 Zigbee version yesterday and I was able to use Lock Manager to configure 5 different user codes. I didn't have any issues. From the Hubitat interface if you go to "devices" for your Yale lock do you see anything looks like user codes displayed?

I can configure them if I go to the device and add users. And then in Lock Manager, it shows those users and their codes. But if I select Add New User and put the information in, nothing happens. No message is sent to the lock, according to the logs.

Is your Yale using a Zigbee or Z-Wave module?


Since I'm using Zigbee, maybe that's why mine worked without any issues. I suggest you try removing the Yale lock from your hub (exclusion) following these directions:

How to remove a Z-Wave device - Hubitat Documentation

Then you'll need to remove the device by setting the Yale lock into exclusion mode,

Enter Master code Pin into panel and press gear icon
Press 7 key and the then gear icon
Press 3 key and then gear icon

Next add your Yale lock back into your hub by putting the lock into inclusion mode,

Enter Master code Pin into panel and press gear icon
Press 7 key and the then gear icon
Press 1 key and then gear icon

Then, add device back into the hub,

Discovering your Devices - Hubitat Documentation

Then you'll need to re-add the lock into the Lock Manager app and try setting the codes again. I noticed that when I tried to add codes using Lock Manager it actually took a few minutes for the app to send the code to the lock and have it accept it. Also, if the code failed to send I needed to try a second time. But eventually, all the codes sent were set in the lock.

Good luck!

No, that didn't work. I excluded and included, removed Lock Manager, added LM again, and it knew the codes that I had previously put in the lock, but didn't know that names, so I added the names and that worked fine. But I still cannot add a user from the LM....If I add the user from the device screen, it works, and then it shows up in LM.

I don't have that many users, so I'll live with it.
Thanks for helping.

And I just installed the YRD216 Zigbee edition and no issues with this either.

This is what I get in the log:
app:1252021-03-29 15:05:03.832 warnactions: User test, code 123 --will be added to [Front door]

There are no setLockCode commands to actually add that user.

Can you add that code directly from the driver ui?

I have the exact same lock (Z-Wave version, but that actually doesn't matter).

I just added my dog and it's working. Maybe you're forgetting a step?


yes it works from the device ui....and what step would I be missing? There's really nothing to it, supposedly.

Selection of the lock in LCM? Yes, it is very straight forward. I tried with my lock (as I mentioned is identical to yours) and Iā€™m able to add codes with the username, to slots in the lock using LCM without issue.

i have had issues with lock code manager if the locks were already populated ie not new (such as coming from smartthings)

it is not very robust..

I was able to use the lock device panels to remove and add codes in the same location ie 2,3 etc.
for all locks.\

Then when adding/removing/enabling/disabling lock code manager works fine.. It is just if one lock already has codes in the wrong position or a different name or code it barfs!

1 Like

What does your log say when you add a new user?

This is a good point. I had forgotten because it's been a few years, that I didn't add any codes via the lock (except for the master code as required). All were added to an empty lock via LCM.

@dnewell73 If you only have a few codes in the lock, factory reset and start fresh by entering all the codes from LCM will be much faster that trying to figure out why it's not working right with codes already in the lock.

I tried to do a factory reset on the lock yesterday to no avail. Open it up, take the batteries out, press the reset button and hold it down while putting the batteries back in, and still no reset. I called Yale support, but they couldn't tell me why I wasn't able to reset it.

But the real problem is in the log. It doesn't try to send any setLockCode messages to the lock. If I add a user in the device page, it sends the code to the lock and it works.

What is your version number?

When my Yale locks were Z-wave I had similar problems to what your having with LCM even after switching the modules over to zigbee I still had problems with a few of my locks and LCM until I deleted the codes using LCM with Zigbee, think I had to use the device page to delete them with Zwave. Also part of my problem was user error, not paying attention to the prompts in LCM :crazy_face: When you make the changes to codes give the jobs time to work especially with Zwave. You might want to start over with LCM and delete it. You probably know all this since you've been working with this problem for a while.