Link to Hub

I am in the process of transitioning from SmartThings to HE. Using 2 hubs I should be able to use both US and AUS Z-wave frequencies. This will allow me to use the US hub for all the things I have been using with ST, as well as some AU frequency ones I had bought to use with WigWag. Already by getting the AU hub I have been able to add in 6 x Oomi Plug (rebadged Aeotec Smart Switch 6 plugs), which I am currently using the Dome On Off Plug DTH, and once I get a chance to look around here a little more, if I can confirm there is a driver for the Aeotec Micro Double Smart Switch (similar but slightly different to this), I will get an electrician in and add 2 of them to my system as well. Just by paying an extra $150 for the 2nd hub, I now have the ability to use about $600-$800 in devices I had here that I hadn't been able to use up until now.

OT, but would it be worthwhile adding the Oomi Plug/Aeotec Smart Switch 6 plugs to the compatible list - with a note to use the Dome On Off Plug device handler?

I have a hue light strip on my slave hub and I’ve used link to hub to shave this with the master hub. I’ve selected the hue device in the link to hub settings for color temp bulbs, rgb bulbs, rgbw bulbs, switches, and dimmers. However, on my master hub it intially just came up as a linked switch. I tried changing it to linked rgbw bulb, but I still can’t change the color or the color temp. I can only control on and off.

I’ve tried deleting it and then reading from the other hub several times.

Sounds like a possible bug. I will investigate.

1 Like

Just FYI, I'm seeing the same behavior with a linked dimmer. it defaults to "linked switch" device type when it is created and if I change the device type to "linked dimmer", then I can turn it on and off, but I can't change the level.

I cannot reproduce this problem. I just setup a new hub, running I put Hub Link on it, and I put Link to Hub on my main home hub. I set up an RGBW color strip that I have on my main hub into Link to Hub.

Doing that created a Linked RGBW Light on the new hub running Hub Link. I can control the real light on my main hub from that Linked light, and vice versa. So, I added a dimmer to my Link to Hub. That gave me a Linked Dimmer on the other hub, and it also controls the real thing.

In this setup, my main hub is the "slave hub", as you call it. It's the hub running Link To Hub. The new hub is running Hub Link.

Are you running hub platform version on both hubs?

I did find an issue with the Linked Dimmer driver pertaining to Lutron dimmers, to be fixed in next release. I'm investigating an issue with Linked RGBW Light pertaining to setting Hue and Saturation. More to follow on that one.

But with respect to your problem of the wrong device being created by Hub Link, not seeing it.

No idea. Both hubs are running

I just deleted the device from my hub with hub link and then opened the link to hub app on the other hub and hit done. Device was recreated, but again it’s being created as a switch and not a dimmer.

Show a screenshot of the Link to Hub setup page.

First of all, don't select the same device more than once. You have BiFrost selected several times. Select each device only once. For an RGBW device, select it as RGBW. In whatever section you select a device, that is the capability it's counterpart will have on the other hub. If you want a dimmer to have dimmer functionality, select it as dimmer, not as switch, etc.

1 Like

Rule 1: assume your users are morons. :upside_down_face:

That seems to have fixed it. I guess it just took the first device type on the list.


How am I supposed to respond to this? Agreement? Disagreement? hmmm :sunglasses:


Ok, so it populates with the correct device type now, but I can’t change change color temp, color, or dim an RGBW light and I have another dimmer that is behaving very strangely.

When I change the dimmer on the hub link hub, nothing happens on the link to hub hub - until I turn the light on or off. Then it changes to the correct dimmer setting briefly, before returning to its previous state.

I have something weird going on and I don’t know what. I’m using all stock apps. The only thing thats a bit out of the ordinary is I am using two hubs, but no one else seems to be having these problems.

I’m having incredible reliability issues with my rules. For example the rule one up top had its PB flipped to false and it would not reset to true. I even created a rule just to flip it to true. Rule 2 flipped to true, but rule 1 wouldn’t change. I ended up recreating the rule and at least it is now true. Not sure what will happen after everything runs today.

Then this morning my bedroom lighting rule had its PB flipped to true at 5:03:10 for no reason that I can’t figure out any reason that would happen. That should only happen at 4:52 if my wife gets up with me, or if a virtual switch is flipped by alexa. My wife did not get up with me and no one issued alexa a command. Unhappy wife when all the lights turned on.

I am now unable to flip the PB of the bedroom lighting rule to false. I had to pause the rule, which seems to be working for now.

Any ideas what is happening here? Do I have a corrupted database or something? I’ve got a ghost in the machine and rules that won’t change their truth value.

Addendum: Rule 1/2 refers to this thread:

Also, on further reflection my second hub (link to hub) has had some weird behavior too. I had several motion lighting rules stop working shortly after I connected the two hubs together and I had to delete and recreate them. They’ve worked pretty well since then.

Of note, I just replaced my main hub (and had to recreate all my rules) after my first hub stopped working. I think my old hub was delivered back to you yesterday.


I also have two hubs, also with Link to Hub. I actually have it in both directions... each hub is running both Link to Hub and Hub Link. The difference however is I'm not doing that much with the 2nd hub. It's got all of my Zigbee experiment on it (3 devices) and I don't use it much.

However, my reason for jumping in is to mark a data point that indicates there's no systemic problem with Link to Hub going on. Nothing on my primary (all ZWave) hub is affected. All of the second hub's zigbee devices are in Rules running on the primary via virtuals, as expected.

1 Like

Most things seem to be working currently, however I still don’t have control of my RGBW light on my secondary hub from my master hub.

When I try to change the color temp on the master hub, it changes the status (only on the master hub) and the logs indicate that it sends the command to the secondary hub. The logs on the secondary hub don’t show anything when this happens however, and the light certainly doesn’t change.

When I turn it on and off it looks pretty much exactly the same in the logs on the master hub, but the “vs_” switch pops up in the logs on the secondary hub. And the light actually turns on and off.

When trying to set the color temp, the “vs_” switch doesn’t log anything.

A vs_ switch is for a switch, not for an RGBW bulb. When you select the device as an RGBW bulb, it will create a vr_ device. So it sounds as though you have it selected as a switch, not as a bulb.

There we go. That was a remnant from when I had it selected as multiple devices previously. I deleted it and it recreated a VR device and I now have control.


Just tried and virtual devices are not selectable to link to hub. Is this by design ?

I use MQTT extensively on my second hub and often by creating virtual devices that reflect the state of remote (MQTT) devices. However I can't select these to synch them back into my master hub. That means I have to create any devices again in the master which is TBH messy and creates really two distinct devices.

I think HubLInk was written before virtual devices were inbuilt - could it be updated to include them ?

I have virtual devices showing in the list of selectable devices.


All 6 of those circled are virtual switches.