Link to Hub

First of all, don't select the same device more than once. You have BiFrost selected several times. Select each device only once. For an RGBW device, select it as RGBW. In whatever section you select a device, that is the capability it's counterpart will have on the other hub. If you want a dimmer to have dimmer functionality, select it as dimmer, not as switch, etc.

1 Like

Rule 1: assume your users are morons. :upside_down_face:

That seems to have fixed it. I guess it just took the first device type on the list.

Thanks

How am I supposed to respond to this? Agreement? Disagreement? hmmm :sunglasses:

4 Likes

Ok, so it populates with the correct device type now, but I can’t change change color temp, color, or dim an RGBW light and I have another dimmer that is behaving very strangely.

When I change the dimmer on the hub link hub, nothing happens on the link to hub hub - until I turn the light on or off. Then it changes to the correct dimmer setting briefly, before returning to its previous state.

I have something weird going on and I don’t know what. I’m using all stock apps. The only thing thats a bit out of the ordinary is I am using two hubs, but no one else seems to be having these problems.

I’m having incredible reliability issues with my rules. For example the rule one up top had its PB flipped to false and it would not reset to true. I even created a rule just to flip it to true. Rule 2 flipped to true, but rule 1 wouldn’t change. I ended up recreating the rule and at least it is now true. Not sure what will happen after everything runs today.

Then this morning my bedroom lighting rule had its PB flipped to true at 5:03:10 for no reason that I can’t figure out any reason that would happen. That should only happen at 4:52 if my wife gets up with me, or if a virtual switch is flipped by alexa. My wife did not get up with me and no one issued alexa a command. Unhappy wife when all the lights turned on.

I am now unable to flip the PB of the bedroom lighting rule to false. I had to pause the rule, which seems to be working for now.

Any ideas what is happening here? Do I have a corrupted database or something? I’ve got a ghost in the machine and rules that won’t change their truth value.

Addendum: Rule 1/2 refers to this thread:

Also, on further reflection my second hub (link to hub) has had some weird behavior too. I had several motion lighting rules stop working shortly after I connected the two hubs together and I had to delete and recreate them. They’ve worked pretty well since then.

Of note, I just replaced my main hub (and had to recreate all my rules) after my first hub stopped working. I think my old hub was delivered back to you yesterday.

Thanks

I also have two hubs, also with Link to Hub. I actually have it in both directions... each hub is running both Link to Hub and Hub Link. The difference however is I'm not doing that much with the 2nd hub. It's got all of my Zigbee experiment on it (3 devices) and I don't use it much.

However, my reason for jumping in is to mark a data point that indicates there's no systemic problem with Link to Hub going on. Nothing on my primary (all ZWave) hub is affected. All of the second hub's zigbee devices are in Rules running on the primary via virtuals, as expected.

1 Like

Most things seem to be working currently, however I still don’t have control of my RGBW light on my secondary hub from my master hub.

When I try to change the color temp on the master hub, it changes the status (only on the master hub) and the logs indicate that it sends the command to the secondary hub. The logs on the secondary hub don’t show anything when this happens however, and the light certainly doesn’t change.

When I turn it on and off it looks pretty much exactly the same in the logs on the master hub, but the “vs_” switch pops up in the logs on the secondary hub. And the light actually turns on and off.

When trying to set the color temp, the “vs_” switch doesn’t log anything.

A vs_ switch is for a switch, not for an RGBW bulb. When you select the device as an RGBW bulb, it will create a vr_ device. So it sounds as though you have it selected as a switch, not as a bulb.

There we go. That was a remnant from when I had it selected as multiple devices previously. I deleted it and it recreated a VR device and I now have control.

Thanks!

Just tried and virtual devices are not selectable to link to hub. Is this by design ?

I use MQTT extensively on my second hub and often by creating virtual devices that reflect the state of remote (MQTT) devices. However I can't select these to synch them back into my master hub. That means I have to create any devices again in the master which is TBH messy and creates really two distinct devices.

I think HubLInk was written before virtual devices were inbuilt - could it be updated to include them ?

I have virtual devices showing in the list of selectable devices.

05%20PM

All 6 of those circled are virtual switches.

Are you referring to virtual switches or dimmers? These can certainly be selected in Link to Hub. Or, is it some other type of virtual device?

A reboot fixed this. Of me not the Hub.

I was looking for a specific device name and had the two hubs roles reversed. Duh. All works as expected

What do you do to link a siren? All of my rules are built in the Master Hub and I have a siren connected in the remote hub as the buildings are disconnected and its too far for z-wave to carry the signal.

I don't have a siren to test but it may be a type that does not pass over Link to Hub. Are you able to virtualize it? --> have an event on the Master Hub, turn on/off a virtual switch? Then allow Link to Hub to the Second hub. A Rule there tests the virtual switch and turns on the siren.

@csteele That's kinda what I figured I would do. But wanted to make sure there wasn't something I was missing.

Thanks!

Can I rename those virtual devices? Like adding a special character to make all of them go to the end of the list. By the way, it would be great to have a device view where I can only see real devices, virtual devices or all, instead of all only

Thanks

1 Like

You should be able to change the LABEL field of any device without impacting anything negatively. If the Label field is defined, it is used for all display purposes, including sorting by name on the Devices page.

I was worried of messing something because it's already modified by the hub