Light shows off but light is on

i keep having this issue. my z-wave kitch light keeps showing "off" but it is clearly on

is the an issue with the hubitat, the switch, the network?

this is not the only light this happens too but it happens to this light a lot

clicking "refresh" does not update the status.

clicking "off" does turn off the light.

can you post your z-wave details? since you said it happens to other devices, it could very well be a mesh issue

1 Like


witch part? here is the kitch light swich

i will say the light never fails to turn on or respond to other automations, its only the off function that is causing an issue.

is it a Z-Wave Plus switch, or an older/legacy non-Plus z-wave switch?


Zwave plus Jasco PN: 26932
with biult in motion

here is the reports form the motion sensor, and me hitting refresh

and here is the automation running and turning off the light, but its reporting at "not on"

I have had some trouble with the automation not turning on light but fixed with "turn on even if already on"

The plus/non-plus would have potentially been a polling issue, but that's not applicable here.

I apologize I'm not familiar with that particular motion switch... Do you have a rule you set up to control it, or is it all done from w/in the device's own setup? Either way, can you post the relevant setup details -- that may help someone smarter than me catch a potential gotcha.

1 Like


the motion is set as manual and controlled with rules (there is another motion on the ciealing in here too)

I’ve seen this happen quite a bit when I have had Z-Wave mesh issues, especially when I had “ghost” devices - devices that didn’t connect properly and that the mesh tried to use unsuccessfully.

When this happened, the message to turn off the switch was sent and I assume that it registered it as off when it was actually still on. “Optimization” can be setup in some of the rules to avoid sending another “off” command - this might be what is happening here.

Two things I would check:

  1. Do you have any ghosts in your Z-Wave network? If you post your full Z-Wave mesh details, there are some community members that are pretty good at finding issues.
  2. Are you using optimization in those rules? If so, it could be disabled
  3. Do you have the latest Z-Wave firmware installed? The new firmwares have resolved a lot of the issues that I use to see.
1 Like

i have 3 devices that refuse to delete
2. o do not think i turned on any optimization in any rules (unless its a wierd settings?)
3. i did update the firmware a while back but havn't checked in a while

Edit: i guess there is new Z-waze firmware - updating now

1 Like

z-wave update completed will monitor (the light that has issues is not on a lot lol)

1 Like

@v6turbo You have 4 ghosts that need getting rid of. They will wreak havoc with your mesh and status' You need to power down the devices that created them so you can remove them from hubitat or use a z-wave stick paired as a secondary controller to remove them. Either way your mesh is toast right now

1 Like

i have tried to do this a while back. however it was to far above my skills to tackle it. I had hoped Hubitat would release an update to do this

and at that time it was only one device.......... now it is 4? I have been very carful to delete device from the interface but i guess that does not work still

if i backup and factory default

my hub and then restore will that clear them out?

edit none of these devices are online they are all powered off......... and if they are online I have no idea where to look for it because because the name is gone.

It is hard (for us) to tell which is supposed to be there or not, but typically (but not always) the working device is right below the ghost. In your case, there are some similar devices, but unless you tried and failed pairing, moved to a completely different device, and then went back to the original failed device, they are in sorta a random order.

Assuming these are devices that are supposed to be there, I would try to do a full shutdown from the Settings menu, pull the plug at the wall (NOT the hub) and wait about 1 minute before powering up. See if powering down the Z-wave radio brings those devices back.

far as i know they only 2 broken things are the old garage door opener and one LOCK that is in the garage and might have an issues bcause the opener is now down

the other 2 devices have been there a while and they should not be on the network

so im 99% sure those 4 devices are not needed :frowning:


This isn't a hubitat issue, it is a SiLabs issue caused by their SDK.

No. Though you could simply reset your z-wave radio and re pair everything.

The device(s) that created them are powered up. Likle the door lock. Power down the door lock (remove battery). Shut down hubitat from the settings menu. Unplug power to the hub for 2 mins (at the wall not the hub) and power back up. Click refresh on 0x1b until the remove button appears. Click remove. Wait.


that is the issue, i didn't know this was happening. I have no idea what devices might have caused this to happen. so i basically need to power off every zwave devices i have and follow your directions to get rid of them ?

1 Like

Only the 5 or so devices below the problematic ones. The ones on top are going to be okay.

At one time, I had some ghost issues and I ended-up turning off the main breaker to ensure all mains powered devices were off (my Hubitat hub and network equipment are on a UPS). I also removed the batteries from all devices. That was likely an overkill though…

ill try this over the weekend however WAF/KAF are very low lol might be easier to switch everything to zigbee :slight_smile: at least until wife sees the CC bill

1 Like

I have a mix of both Zigbee and Z-Wave, though it took me a few tries to get good stable meshes for both. Repeaters are key to a healthy mesh. I have quite a few Inovelli Red switches as Z-Wave Repeaters and a mix of Sinopé Thermostats and Inovelli Blue (2-1) as Zigbee repeaters. I also have some of the Sonoff repeaters for Zigbee and Ring Z-Wave repeaters in some areas that had spotty coverage.

If you can stick with it, z-wave is a great option to have in addition to zigbee. Most of us here happily run both.

But ZW does indeed require more care & feeding / nurturing / attention, especially when you are building out your mesh... As you now well know, it's not as forgiving as zigbee when it comes to adding / removing devices -- it can be pretty darn punishing if you miss a step or aren't deliberate in your approach.

But once you (finally!) get a good & healthy ZW mesh in place, it's then much easier to maintain and it opens up another world of devices to play with. Well wishes whichever way you go!