Light keeps turning itself off


#1

Not sure what I did. Was messing with settings trying to figure out child devices for an inovelli switch. I've never had an auto off and still don't. It's shutting off seconds after it turns on. Here are the logs

I excluded and re-added the device. Didn't create child devices this time. It doesn't belong to any rule or app and it's still shutting itself off. This goes for two devices. Both inovelli dimmers. None of that solved the issue.

The only scenario where it doesn't shut itself off is if it's completely excluded and I don't include it back to the hub


#2

Can you show the device edit page?


#3


#4

That's not the full page. Trying to see if there are any other automations assigned to the light that could be causing it. :slight_smile:


#5

None of those have changed since this issue started


#6

And you're 100% sure than none of these is triggering to turn the light off? Have you tried disabling them and seeing if the problem persists?

Have you looked at the Events Page in the device settings?


#7

The event page just says on and off. I'm sure, they're tied to Alexa routines and presence routines. If any of those were causing this then other lights would be turning off as well.


#8

Is the device above a scene enabled inovelli? If so it looks like you have the wrong driver loaded.


#9

It's not scene enabled. It's the correct driver.


#10

Try putting values in the default zwave and local parameters then save, I have mine both set at 99 even though I do use the child devices to set as well. I'm just not sure if having them blank would screw anything up.


#11

Just tried that and it's still doing it. I'm at a complete loss here. I think I'm going to try excluding them both. Idk what else to do


#12

Well that didn't work either. Excluded and re-added again. Didn't add child devices this time. It's still shutting itself off. Doesn't belong to any rule or app at all. @ericm


#13

It's possible you have a faulty device as well. Try turning on the switch by press and hold the on possible for a couple seconds. If it's staying on after release then it's a bad switch.
You can try power cycle the device with the circuit breaker and see if that helped.


#14

Perhaps not. I had the same problem with a particular zigbee ThirdRealty switch. I began to suspect that it was the delayed off command in a another motion lighting rule. But that ML also managed other switches and they weren't a problem. I double-checked those MLs and could see nothing wrong with the logic. Somewhere here in the forums, I ran across a mention that RM might carry an unseen legacy commands. That particular ML had been one of my first rules and had been subject to a lot of novice editing. I don't know if it had a legacy issue, but when I nuked it the one problem switch was fixed.


#15

I don't really understand what you mean here

Either way I've removed them from all rules.


#16

Did you power cycle the switch?


#17

Yes I just did that after my last reply. Still shutting off. The only scenario that it will stay on is after excluding it and not pairing it back


#18

Sorry, I meant to say "Try turning on the switch by press and hold the ON position for a couple seconds physically. If it's staying ON after release then it's a bad switch."


#19

I don't get why that would mean a bad switch. All my switches are staying on when I test that way


#20

It's a circuitry problem that caused the switch to switch back off. Most likely faulty stay ON hold circuit. By holding the ON button long enough. You are helping this circuit. It's happening with Jasco, Dragontech and Homeseer switches.
This of course is just a possibility.