Latest firmware bricked C4, No device page. Blue light

Latest firmware bricked my C4. Have not updated in several months, but never had a problem in the 4 years I've had it. Feels like a planned obsolescence.

Blue Light is on.
Initially Find Hub(s) on local network found my hub but device page and port 8081 = no response
Now I can find only by MAC in Advanced Discover, but still nothing on the device pages.

Yeah, well that didn't happen.

Did you have a DHCP reservation in your router, because it sounds like the IP address changed. Either that, or the ethernet port on your hub died, or the ethernet cable failed.

FWIW, the blue LED on a C-4 indicates that the hub platform is loaded and running.


Find by MAC reports the IP address I've been looking at. IP address did not change. If the port were dead, couldn't be found by MAC. Happened immediately upon firmware update.

If you ping that IP do you get a response? If not it could be a cached MAC…


Could be cached data.

@thebearmay beat me to it.

Anyway, try it from an incognito browser.


PIng = unreachable, incognito = can't be reached

Also not reachable from other browsers, and from automation interfaces (Amazon/Google) (how I initially found the problem)
Thanks for the suggestions - was trying to get it functional so it worked for my family before I am out for a few days, but not going to happen. I won't be able to test anything in the mean-time.

So 2 possibilities:

  1. Hub has changed IPs
  2. Bad ethernet cable

If it’s just changed IPs sometimes rebooting the router will put the hub back on its DHCP reservation.

Finding by MAC reports the same IP address from browsers that have not ever accessed Hubitat.
I don't have time to switch out the cable but I suppose it is possible that the when my firmware was updated, the wire became corrupted. I have hundreds of devices on my network and many servers. All working normally.

Can you try an arp -a

1 Like

We don't do that.

A bad network cable could be the issue, an Ethernet port going bad could be another.

The first thing is to get the hub back on the network. Try giving it a full power cycle. As much as I cringe at the idea of unplugging it without shutting down, it's not an option right now, so please go ahead and unplug, wait ~30 seconds, and plug it back in. Check the router's "connected device" page to see if it connects. Once the hub is connected, we can troubleshoot further.


I'm back in town. I know the advise given is sincere, but the firmware update bricked the C4.
I've been doing network analysis for 30 years and have trouble-shot thousands of soft and hard problems. I've seen bricking happen several times. It has been power cycled many times during trouble shooting. But has been powered on for the past 8 days while I've been out. It bricked the moment I updated firmware. It is not a cable or network issue. The cable is fine. the port is fine.
All of the devices in question (Hubitat, switches, and PC's involved in this troubleshooting are on one segment (I have many segments)
I unhooked a working computer from another switch on the same IP range that the bricked C4 Hubitat is on - plugging the hubitat into that cable. Hubitat Portal still cannot find the hubitat, Searching the network for that MAC address returns nothing.
While the cable was disconnected the donor device reported no network, when put back in it saw the network - the network and cables are working correctly.
There is only one Shenzhen Shiningworth Technology (C4:4E:AC OUI) MAC Address active on that network segment - which is the OUI matching the MAC identified on the unit) and it is not the Hubitat MAC. That MAC isn't reporting anywhere on the network - It isn't hanging out on a new IP address. I'm happy to set up a new network with just the Hubitat, a PC, and a dedicated internet service not in use by anything else - if that is what it will take to convince it is not my network, cable, or switch.
If I buy a new hubitat and plug it in to the same network on the same cable and it works correctly - What will be the next advise for my firmware bricked device? May as well try that now, as a new non-firmware-bricked device will work on that cable.

I still have my c4 running much of my automations. It is on platform What version do you feel bricked your c4?

I have a C-4 Running and make firmware updates as soon as they are released typically, no issues with any recent updates to report.

1 Like

Sudden C4 death seems to be a thing.. It happened to me a while ago with one of my 2 C4 hubs - Similar experience happened on a reboot. Ended up getting rid of the other hub as a precaution. Replaced them with a C5 I had on hand and a C7 which had just come out..

1 Like

A sudden power demand is frequent point of failure for electronic devices. And there certainly is an increase in power demand during booting.

1 Like

I was also wondering if it wasn't an internal storage failure.

1 Like

That was my thought too. Nothing to do with the firmware itself but the reboot coupled with setting up the new firmware caused old components to fail.

1 Like

I have also updated firmware many times without issue. Thanks for real input, and acknowledgement that it actually may be a hardware problem, not a network problem.
It is not worth my time if it can't be reset. I exported configuration last thing before firmware update, so the pain is slightly mitigated - but I expected that if I had to restore that config, it would be after doing a factory reset - not so with this Hubitat.
If the process of updating firmware bricked it - doesn't really matter where in the process it happened if there is no way to reset. The unit did not protect itself, or provide a fail-safe, restorable state - something that is common with other hardware.

For those who asked about the firmware version that I was attempting at the time - It was the version promoted as current on Oct 2, 2022, unfortunately I can't tell you what that version was.

1 Like

Literally found your post after I updated the same firmware on my C4... It's now a ghost...can't be found. Tried different ports cables the whole 9 only found by MAC and nowhere seen in my router. Odd.