Kwikset 910 Zwave Lock Pairing

First..... I know, this seems to be an ongoing issue and I spent the last few hours trying to get it to pair.

Every time it says it pairs, I get a secure pairing but I get zero statuses and control. I can see the lock light up a red light when I make a command but no change in the lock.

Kind of at a loss here.

Turn on Debugs and watch the Logs for any Lock messages.

On the Device Info page for each device, there's a debug toggle. Turn it on. Usually drivers will automatically turn them off after 30 mins.

Right click on the Logs menu item and choose open in new Tab. This is "live logging", the page starts out blank, with: --- Live Log Started, waiting for events --- the only words on the page.

Then, back on the device into page, click Lock or Unlock and watch the logs. I don't have a Kwikset but here's an example log for my Yale, which uses the same Generic Zwave Lock driver.

It's not so much that I expect you to interpret the results, but simply that you have results :smiley: The LED lighting sounds good to me, unless it's supposed to light green :slight_smile:

I am getting results, I see it locking and unlocking and getting a refresh after an update but still no status updates or physical response..

" dev:392021-12-25 01:24:19.793 am debugrefresh()

dev:392021-12-25 01:24:09.708 am debugunlock()

dev:392021-12-25 01:24:00.288 am debuglock()"

Not getting any of the stuff in between indicates the Lock isn't actually able to converse with the hub. You're not getting the reply to say the door is locked or unlocked.

Locks are in a special category called "Barrier Devices" and over the years, have a variety of security related "assistance" layered on. It's likely your lock is FLiRS aware and you will need to have a repeater near that works as a "Beaming" device.

FLiRS and Beaming are pretty much the same thing... the Lock uses a lot of battery with each lock/unlock to drive the motor. Thus conserving battery is paramount. Battery devices go to sleep by turning off the radios and then waking periodically and ask the Hub if there's a message. The hub responds no, and the device goes back to sleep. That's fine for a Door or Window sensor because it knows when the magnet moves and thus when to wakeup outside of the sleep cycle. Locks aren't like that. They must respond to commands from the Hub and thus the way they sleep is quite different.

A Lock will wake but for an ultra short time period to conserve battery which is FLiRS. The Hub is probably doing something else in the short time the Lock wakes and thus by the time it gets around to saying it has a message, the lock is asleep again. That's where a Beaming Repeater comes in. The Hub nominates a repeater to be the communications watchdog. Then, when the Lock wakes and asks if the hub has anything, the beaming repeater answers YES. Then the Lock stays awake longer and actually converses with the hub.

So while you're joining the Lock, it doesn't sleep, and thus the communications is excellent. But once it goes into deep sleep, there has to be a beaming repeater that will facilitate the conversation.

Obviously I can't say THIS is the problem, but it's one of the top 5 problems we read about here in the Community related to locks. Your symptoms indicate nothing is 'heard" by the lock, and therefore, it doesn't respond.

1 Like

What device driver (Device Type) do you have associated with the lock - many times the Kwikset will initially try to use the Schlage driver; should be the generic Zwave (assuming Zwave as most of these are). After changing drivers (and many times when you create the device) you’ll need to hit Configure to get things initialized properly.

1 Like

I've had quite a bit of experience with Kwikset z-wave locks. If you purchased and added the z-wave module separately, it could be a hardware incompatibility issue. Your results are similar to what I experienced with my locks. The best option is to purchase a z-wave lock up front, like the 914.

Here is what I found - looking inside the battery compartment with the battery removed you'll see a round either transistor or capacitor (circled in red). One pic has the z-wave module installed (towards the bottom of the pic), the other is with it removed (you can see the plug).

If the cap is in the middle, then the lock should work with the z-wave module. If it is toward the right side, I have not been able to get it to work. I've tried both secure and non-secure pairing with no luck.

You can often find kwikset lock parts on e-bay and hit or miss, get the right motor that is compatible.

Incompatible motor module:

Compatible motor module:

This is also probably part of the reason Kwikset doesn't formally support purchasing the modules separately, however you can find them readily available on Amazon.

There are also different versions of modules available, these results are using the newer z-wave+ modules.

I have an aeotec 6 repeater 5 feet to it setup to go inbetween in the mesh network. I also tried doing it within 6 inches of the HE.

The HE is about 2 feet from the router but for z wave I didn't think that would be an issue.

I also changed the batteries. It was working previously on the Vivint system.

It never joins right either I never once get a good status response. It is always blank. Refreshing and config do nothing.

The lock Z-Wave button physically illuminates when making a command from the devices menu but that's as far as it goes.

It is configed as a generic Z Wave lock. I tried switching back and fort to force config still nothing.

Great information @demillerusn. I did check I have the center cap one as picture.

@loca5790 Dumb question, do you have any ghosts in your mesh?

@rlithgow1 not sure what you mean by ghosts as in a switch that goes to nothing, but no. I just setup the network and there shouldn't be any z-wave not included.

Additionally I have osme sensors in my mesh network pinging through the lock and working.

post a screenshot of your z-wave details page


posted here because... still not good at loading pictures

No the details page not the grid...

NM see the details page now

Now go to the details page of the lock itself. Post a screen shot of the DATA section at the bottom, and what driver are you using?

It is using generic z-wave lock. I tried switching to a schlage and back and forcing configs both times to no avail.

Hmm, I assume you've hit configure. Has it tripped even once? will it trip if you bring the hub closer to it?

Nope hasn't tripped even once. I factory reset it and took the ENTIRE lock out of the door thinking maybe it needed the keypad and brought it to literally on the shelf above the HE.... wihtin 6 inches. It didn't change the way it included/excluded or acts.

1 Like