Just received c8 hub; won't connect to wifi

I just received my new c8 hub to replace my c7 hub, mostly for wifi so I can put the Hubitat in a central location that doesn't have a wired connection. The hub won't connect to the wifi connection that is my main network. The router is a Netgear Orbi (or rather, 3 of them; main router and two satellites), and every other device in my house connects to it just fine. Not the c8 though.

Since there is apparently no tech support from Hubitat, I thought I would throw the issue out here before I return the c8 for a refund. The SSID on the router is hidden, but I enabled it and rebooted the Hubitat, so that is not the problem. Funny part is, the Hubitat will connect to the guest network on the same router. Just not to my production network.

Any suggestions? Or should I send it back?

Thank you in advance

Update: I just disconnected the wired network when the wireless was connected to my guest network (rebooted), and now I cannot find the Hubitat. So apparently either the connection to the guest network isn't working, or I cannot access it because I'm not on the guest network.


Suggestion #1: Knowing that the C-8 is set by default to grab an IP from the router using DHCP, have you double-checked the router config to be sure it has available addresses in the DHCP pool?? (Later, once connection achieved, I'd recommend reserving an IP if possible using the router config.)

This is probably not much help to you, but I have the Netgear Orbi and my C8 has connected fine to the Wifi.

1 Like

There is plenty of tech support from Hubitat. @bobbyD

1 Like

Thanks, but yes, there are plenty of addresses available in the DHCP range I have reserved. And I do reserve addresses; the Hubitat has a set IP address reserved. Funny thing is, the wired connection connects to the reserved address, but when I use the guest network, the wireless pulls a DHCP address and not the reserved address.

1 Like

Ok, how do you contact tech support? I have used Hubitat for a few years but it was a secondary HA, not my main system, so I never paid much attention to it. Never needed tech support before, and I could not find any here.

So far, what you've described is normal/expected behavior (LAN port and WiFi have different MACs, hence will normally grab different IPs). Up to you to swap them as necessary, and be sure you are trying to log into the correct portal.


What steps are you taking to connect? Are you connecting to ethernet first then using the UI? Or are you using the setup access point? I would try connecting to ethernet temporarily. Then go into the normal UI and in Settings > Network Setup try to connect to the Wifi from there.
I believe you can manually connect to a hidden SSID from there, if not unhide it to connect then you should be able to hide it again.

Also, what frequencies is your production network SSID supporting (2.4/5Ghz)? The hub is 2.4Ghz only I believe but can connect to a shared SSID.

Support monitors the forum and especially this "Get Help" section. Despite not being able to call someone, I think you get better support here than with large companies that will direct you to inexperienced script readers, or reply to your emails with a bot.


I did try to connect via the GUI (Settings -> Network). I did not know there was another way to setup the wifi. I am shocked that in this day and age a brand new device is 2.4 GHz only. I will check my router settings but I'm pretty sure I have both 2.4 and 5 GHz enabled. I would hope it works on a split network. If not, Hubitat needs some new engineers (and I was an engineer for an Ethernet semiconductor company for years...).

1 Like

It does, I connected it to mine briefly for testing. I am using an AX68U which is a Wifi 6 router. I am using their "Smart Connect" feature which has both frequencies on the same SSID. It connected right up no problems.

You could also try doing a network reset using the button under the hub, hold for 10 seconds and let go, the hub light will flash then reboot.

If you go through this quick setup guide, step 4 has a link to the Wifi only instructions using the built in AP mode, you could try that also: http://go.hubitat.com/

Ok, I think you nailed it. Something with the split router seems to be the issue. I switched the connection to an access point I have primarily for my security cameras, and the Hubitat seems to be connected now (I'm pretty sure the AP is 2.4 GHz only, but since I haven't had any need to play with it for several YEARS now, I could be mistaken).

I will continue to monitor the Hubitat and see if everything works ok on this AP.

Thanks for the help.


Out of curiosity by "split router" do you mean an AP with separate SSIDs for 2.4ghz and 5ghz?

1 Like

I tagged @bobbyD who works with Hubitat Support he should be along.


I called it a split SSID up above, probably more like shared. Where the same SSID is used for both frequencies. Some devices will get confused by this if they are 2.4Ghz and refuse to connect but it is very rare. I am sure I had my hub connected to my shared SSID at some point and it worked.


Per LinkSys, just FYI:
What is a dual-band router? Dual-band routers are routers which are capable of transmitting and receiving data using both 2.4 GHz and 5 GHz frequencies, either simultaneously or one at a time.

That just means it does both bands, not specifically with the same SSID. Any router can be configured to have the same SSID for both bands but not all handle the clients very well.

For warranty claims the quickest way to submit a case is by visiting support.hubitat.com. For all things Hubitat, tagging @support_team is the surest way to get our attention. But in general we are screening the community and you don't even need to tag anyone.


OK yeah. Like you I successfully connected my hub to wireless and all of my APs are single (common) SSID for 2.4ghz and 5ghz.

1 Like

Yes, shared is probably the more correct terminology. In any case, we were both referring to routers that use a single SSID for both 2.4 and 5 GHz radios. If there is no need for 2.4 GHz on your network, then turning off the 2.4 GHz radio may improve performance and security, so some people turn off the 2.4 GHz. I still have some old devices on my network, so I have both 2.4 and 5 turned on. But to get the Hubitat to work I had to move it to a 2.4 GHz AP.

A brand new design like the c8 should work with a high-end router like the Orbi without issues.

1 Like

Yeah I have a lot of devices that are 2.4ghz so I keep both running for the SSID associated with my IoT VLAN but the SSID associated with my user VLAN is 5ghz only. Most networks are present on all APs so I get the benefit of forcing 5ghz for user devices while still maintaining compatibility with older IoT devices.

1 Like