Just received c8 hub; won't connect to wifi

Most IOT devices utilize the 2.4GHz as they don't need the higher speed of the 5GHz.

7 Likes

2.4GHz also has a longer range the the 5GHz band.

6 Likes

Apparently you missed this...

I worked with consumer electronic appliances and Wi-Fi and other networking issues for years and there was never any device that I've seen that's always worked perfectly with Wi-Fi. Ethernet, 99.9% reliable. Wi-Fi, not so much! :slightly_smiling_face:

Clearly from above the hub does work with the Orbi, there apparently is just something with your home layout and\or configuration that is causing problems with the hub connecting. Pretty common experience, we'd receive devices back from customers who said it was impossible connect. We'd set up the exact same hardware at work and at home and be completely unable to replicate their problems with Wi-Fi connectivity. There's more than a little voodoo mixed up in Wi-Fi...

4 Likes

Simply tag support team..

2 Likes

Same problem for me

  • Trying to connect to my Orbi (running both 2.4 & 5 on the same SSID) failed at least 10 times.
  • Wired was fine.
  • My C-7 could connect to same Wifi just fine.

FIX FOR ME:

  1. I connected Hubitat wireless to another network that was 2.4 only (my cell phone hotspot)
  2. I tried again with my Orbi Wifi right after #1 above and this time Hubitat connected just fine.
2 Likes

c7 has no internal wifi? so not sure how you can say it connected fine.. maybe you were using a wifi dongle but that would be a totally different device.

2 Likes

Yes, was using WiFi dongle. Understand it is not the same.

Just a data point that the WiFi network did work with Hubitat, but it just had problems with the C-8 initially.

1 Like

With some 2.4 only devices I've seen it have problems with a shared SSID. It's one of the reasons I recommend to keep 2.4 and 5/6 on separate SSID's.

2 Likes

Many of the new routers don't give you the option if you want to run both frequencies.

3 Likes

Ugh... I mean I don't touch residential stuff much anymore. But last I looked for both comcast routers and Fios routers they allow separation. I certainly don't know about newer stuff from ASUS and Eero and whatnot. That really blows though.

Oh, it's a real PIA at times with some of the IOT stuff that insists on a pure 2.4 signal. (Just another reason to avoid WiFi devices :slight_smile:)

2 Likes

While that is true, it is a very common practice and first thing support of 2.4 GHz device manufacturer would say. I received that response from Kasa, Amazon (Ring) and Google in the past.

I just received my new C8 and went to go.hubitat.com on my Windows computer and followed the instructions.

I never connected it to Ethernet and opted for WIFI. It asked me to use a tablet or phone. I connected to the wifi network labeled (Yournewhubitat) or whatever hubitat name it was. When my phone connected to it, I had to enter the the WIFI password, then I clicked next on the Windows computer as it looked for my new hubitat. It appeared to not find it.

I simply clicked over to the previous tab ( findmyhub.hubitat.com ) and the new HUB appeared.

From there I was able to set it up just fine.

I am using the wifi signal off of an ORBI RBS760 satellite.

1 Like

I'm having the same problem as the OP. New C8 out of the box. Connected via ethernet cable and it did a firmware update on bootup. The first and only thing I did was to try to connect via WIFI. Every attempt yields "Cannot join network ". I turned off the 5GHz band on my APs - no success. I tried a different network/hotspot - no success. I tried following directions here at (blocked from including URL) Registration and Setup

I removed the Ethernet cable and power cycled the C8; it never starts broadcasting a MyHubitat SSID.

I'm trying to migrate from Ezlo/Vera and this failure on a very basic step is giving me pause.

press the network reset button on the bottom of the hub for 7 seconds (the only round hole out of all the square ones. use a toothpick or paperclip) That should initiate broadcasting

1 Like

Thanks very much for the advice rlithgow1. MyHubitat SSID only showed up for a couple of seconds, not long enough to connect to, but maybe that was normal because I still had my ethernet cable connected. Whatever the case, I was then able to join the WiFi network via the GUI. Your help is much appreciated.

1 Like

After it reboots. Although mine does not work either and they never figured out why. Mine will only come up for a few seconds and then it disappears (even with ethernet unplugged). If I connect via ethernet and configure Wifi that way it works fine though.

Yes if ethernet is connected it does not broadcast the setup SSID, just like how many other embedded devices work. Once they connect they stop looking for someone to set them up.