Issues with drivers - many duplicate entries

There seems to be an issue with duplicate output from the Zooz Central Scene (built in) driver.
I have a switch, which is on the latest firmware, a Zen26.
When I turn on debug, I get the following output: (after turning it on, digitally):


I believe that I am on the latest firmware, and using the built-in driver:


This is probably not what you want to hear. However, in my experience, duplicate entries like the ones you've shown result from a weak z-wave mesh.

Might be time for a z-wave repair. And I'll bet if you use a zniffer (or ZWT) you'll see why this is happening.

I just did a zwave repair within the last 2 hours.

Question: Since I know that you have a number of Zooz devices, have you put on the debug flag and issued some commands to that switch? Does it act the same way? Are you using the built in driver, or the community one?

Good question. I will get back to you in 5 minutes.

Seems to be normal. Here's the debug output for turn on, set level to 50, and turn off. This is using the built-in driver. I will repeat this using @bcopeland's driver.

Screen Shot 2020-07-02 at 8.33.06 AM

Here's what happens with @bcopeland's driver:

Screen Shot 2020-07-02 at 8.37.16 AM

So neither driver shows repeated commands

My experience was that once I had updated the Zooz firmware, the built in drivers no longer worked correctly. I got lots of errors, and also some weird behavior when trying to change settings. I used Bryan's community drivers, and all my issues went away.

@bcopeland could you look at the built in drivers? Maybe there needs to be a couple versions of the built in drivers for old vs new Zooz firmware?

As a matter of fact, everything was working OK with Bryan's old drivers (i.e. the community drivers).
I had just switched to the built in ones, and then all this stuff happened.
I'm not 100% sure, but I think I'm on the current firmware.

SHould mention that I don't have any Zen26 dimmers. I have Zen22 dimmers and Zen30 dimmer/relay switches.

So, I changed the driver from the system built-in driver to the Community, Zen 26 Central Scene Switch. The following is the debug result:


So, I think it's a problem with the System, built-in driver!

1 Like

Yep.

The built in driver worked fine on older firmware. I don't know at what firmware revision things changed enough to cause the built in driver to break. With my Zen 22-23-24 switches, I jumped many firmware versions at one time, so I never got to test how each reacted to drivers.

After updating my Zen21 to the latest firmware, the built in driver stopped working for me too and after switching to the community driver it was fine. I let Zooz support know about it.

I'm missing something here, I see three binary switch reports in a row less than 150 ms apart, I don't care who's driver is being used, that is an issue, that looks like a mesh issue, or possibly a firmware issue, but it's not a driver issue...

@mike.maxwell
Fortunately, I have a UZB, and I'm going to get the software up and running to try and Zniffer around that switch.
However, since you said "looks like a mesh issue", can you give me some hints as to what I should be looking for?
Do you think it's a route that isn't working, so it goes around in alternative paths?
Do you think it's a device that is stuttering, and repeating stuff?
Any other quick guesses?
I'm going to start monitoring the zwave traffic around that switch, and see what it tells me. But any hints that you can give me as to what to look for, would be greatly appreciated.

Well, for my first step, I plugged in a Zooz Stick that I happen to have lying around, and started to use the infamous PC Controller program.
The goal: eliminate any dead nodes from my Hubitat mesh.
Approach: from the Hubitat settings, get a list of all nodes, by node id. Get the same list from PC Controller. Eliminate (as failed), any node that shows up in the list in PC Controller, that is not in Hubitat.
Results: 6 Nodes in PC Controller that are not in Hubitat.
The standard approach is to mark such a node "as failed", and click on the "remove failed" in PC Controller.
However, such an approach only worked for 2 (out of 6) nodes.
Why wouldn't it work for the other 4 nodes?
I'm not 100% sure, but my following actions point to an issue with the Hubitat Zwave Mesh.
I had a feeling that one of those nodes that couldn't be removed via PC Controller was a GE Zwave (not plus) wall switch that I did a force remove on. (I did a force remove because the switch was probably blocked, and couldn't reach the Hub.) After moving the Hubitat to within a few feet of the wall switch, I was able to do a zwave exclude on that wall switch.
In other words, even though I did a force remove on a zwave wall switch, Hubitat didn't really exclude it from it's mesh. The Force remove was done over a month ago, and it still hadn't been really removed from the Hubitat mesh.
Where is the daily zwave cleanup routine? Doesn't it work?
P.S. I think that the other nodes that couldn't be removed via PC Controller are also old zwave wall switches that I had difficulty removing from Hubitat.