Issue with LG smart tv

Also, anyway to get media controls working for example Play, Pause, Stop?

here's a workaround for Live TV

in the external input box try typing

Hey @stevkevdyl. Thanks for the suggestion. I just tried this but it didn't work for me.

Sorry I messed up. I've edited my original post with the correct entry. Give it another try with that

NICE ONE. That Works!

I've had this integration working for a long time until a couple months ago it suddenly stopped. I have it installed through HPM so everything should be up to date (I've even uninstalled and reinstalled it). It finds the TV and creates the device, but it doesn't include the pairing key. I tried using the key from my original install but I always see the same error message in the logs:
dev:23472023-11-26 09:06:58.277 AMerrorjava.lang.NullPointerException: Cannot invoke method multiply() on null object on line 389 (method webSocketStatus)

dev:23472023-11-26 09:06:58.082 AMinfoLG WebOS TV - initialize() - Connecting websocket to: ws://

I've looked at line 389, but I'm not sure what I'm looking at. Anyone have an idea?

The HPM is out of date (technically), if you look above, you can copy and paste the driver code and after a while it started working for me and at least 2 others I've seen in this thread

Thanks Biggsboi! I'm not sure why I didn't do that, but it worked! This one integration is used in many different rules for me.
So we're up to at least 4 of us this has worked for now.

1 Like