Is there a problem with Thermostat Scheduler v2?

I have been struggling to get Thermostat Scheduler to reliably control my Thermostat. In a separate thread I documented my efforts to try various Hubitat versions and have concluded that there is a problem with versions above In exploring the issue, I loaded, confirmed the problem, and then reverted to, only to discover that I am no longer able to invoke the Thermostat Scheduler -- it just spins and spins. I tried rebooting (and also powering down) the hub, and ultimately deleted the Thermostat Scheduler app. I apparently shot myself in the foot as I am now unable to reload it -- just spins and spins. Is the app corrupted? How can I get a good version? Would attempting to restore from a backup be advisable, or might this cause other problems? Help!

1 Like

There are not any known problems with it. It would seem that you have some kind of database corruption going on. I would suggest you update to, and see if you can open Thermostat Schedule. If you can't open an existing instance, see if you can create a new instance. We will go from there.

@wfoley could you PM me the hub ID that is having this problem?

1 Like

Bruce, as suggested, I upgraded to and re-installed the Thermostat Scheduler and entered the data as shown below:

As you see, I am currently in the Leave time period where I want the Heat temperature to be set to 55 degrees. I have selected the Set Scheduled Temperatures and Update several times, followed by Done, but don't see the Heat setting up at the top being changed from the 66 shown (from the earlier time period) to the desired 55 degrees. I recall seeing some disussion about this screen needing to be refreshed after the actions, and have done so, still no 55 degrees.

Additional suggestions?

I should probably share that I have a rule that attempts to update the desired thermostat temperature when the Furnace disabled button turns off or the mode changes. This seemed to work reliably with versions prior to, but doesn't cause any change now.

Picture 7

I am obviously missing something pretty basic with Thermostat Scheduler.

Can't tell anything about what is happening without logs.

It doesn't do anything for periods except when that period starts. That's why it has the button to Set Scheduled Temperatures. Did you do that?

Yes, I've done the Set Scheduled Temperatures, followed by Update and Done multiple times.

Here is the Events log from the Thermostat. Note that it doesn't reflect any Thermostat response to the Thermostat Scheduler request at 6:00 when period changes, at 6:06 when mode changes to night, or when I hit the Set Scheduled Temperatures button at 8:37.

Here are the logs for the period change as well as the mode change.

Picture 9

It looks like the Thermostat Scheduler took action, but it didn't change the temp to 65 as seen below.

For lack of a better idea, I reverted once again to in hopes of getting back to a version that worked. Unfortunately, I am now back to the continually spinning wait for the Thermostat Scheduler to load:

Picture 11

Must certainly have something corrupted. Will restoring from yesterday's back do any good? Will explore further in the morning....

I noticed in your screenshots that you've got Thermostat Scheduler set to control your thermostat directly. Are you using Thermostat Controller, either to enhance the capabilities of your actual thermostat or to take advantage of multiple temperature sensors in your space? If you're using Thermostat Controller, you have to set the Scheduler to control the Controller instance rather than the thermostat device directly. I had to learn that the hard way a few months ago when I first started.

Thanks for the feedback. I am NOT using the Thermostat Controller, just the Thermostat Scheduler to set my daily temperatures of my one thermostat. So, as you describe it, I guess that I am using it directly.

Well, here is what the new day brings....

Before going to bed last night, as reported, I reverted back to and encountered the spinning symbol when attempting to view the Thermostat Scheduler app. It was still spinning this morning when I attempted to see what had happened to the Thermostat Scheduler temperature schedule when viewing the Hubitat as a device on my WiFi network. However, I discovered that if I accessed my Hubitat via the Remote Access, I could select the Thermostat Scheduler app and get it to display without any spinning symbol -- very strange -- maybe something caused by reverting to a previous version when the scheduler had been updated? I went for my morning walk and returned to the house after 6:00 and find the house warming to 66 degrees, as desired. The Thermostat Events log shows:

Notice that, in contrast to what is observed when using (above), the Thermostat actually responds to the 6:00 period change request and resets the setpoints to 66 degrees. The logs reflect this action as well:

Picture 13

Note the response to the period change at 6:00 and the response to the sunrise mode change at 6:01. My takeaway from this is that the Thermostat Scheduler and the Thermostat work in harmony in but NOT in (or the versions in between as previously reported in separage thread)!

Is there something else I might capture to illustrate or assist in debugging?

If you are suspicious about the interaction between TS and your thermostat, one thing you try is to :

  • create a new virtual device with "Virtual Thermostat" as the driver
  • set up a new instance of TS that is configured identically to your existing instance (use Clone? the UI will ask for a replacement device to your current thermostat) but that controls the virtual thermostat instead
  • look at them go side-by-side

You need to post screenshots of logs, showing the entire log entry. What you've shown is not usable for diagnosis. You have to apply filters on the logs to get just the app, or app plus thermostat. Like this:

It is not possible to tell what is logging the way you are doing it.

Also, why are you showing anything about modes? Your TS setup uses time periods. In the logs you posted, you can see TS setting the heat to 66 at 6:00 AM. I'd say forget about showing anything from past versions, as that doesn't really have anything to do with what is happening on

You are flipping around so much in what you are posting that I can't keep up with you. Are we trying to deal with the problem that the thermostat is not responding as it should to commands from TS? That's how this started. Has something changed? If the thermostat doesn't respond as you expect with, then Thermostat Scheduler has nothing to do with it, and we need to focus on the thermostat. But you keep bringing up Thermostat Scheduler, so it's really hard to tell what is going on.

If it appears to be the thermostat itself that is not responding, what happens when you command the thermostat directly from its device page? What happens when you command it from the Manual Settings portion of Thermostat Scheduler? It would help if you'd reduce the sheer volume of your posts, as in order to diagnose the problem, we first have to isolate just what it is. Just post screenshots of the logs, not the device events, for now.

Deleted Thermostat Scheduler app, upgraded to and reloaded/configured the Thermostat Scheduler again. Now waiting for transition to Return period at 6:00 PM. Will capture logs then.

5 posts were split to a new topic: Thermostat Controller help