Is the Aeotec Heavy Duty Smart Switch supported?

I am thinking about getting the Aeotec Heavy Duty Smart Switch for the energy monitoring feature to connect my dryer to. I wanted to make sure it was supported on Hubitat and searched these forums to find very mixed results. There also seems to be multiple community created drivers, and it's not listed in the documentation as a supported device.

So is it supported, and if so, what is the best driver to use?

I went ahead and got one anyone and am using @syepes's community driver. However, my switch is reporting 0W when the heating element for the dryer is not on, and that obviously can't be right because turning the drum obviously uses power. However, it only pulls power from a single leg, so it runs off 110v instead of 220v.

I opened up a support ticket with Aeotec. My first assumption was that the switch will only take measurements if there is power on both legs, but the Aeotec tech said this is not the case. He wants me to check specific parameters and make some tweaks, but I don't know how to do this.

I know this is an old thread, but I wanted to follow up because I hate searching for questions only to find someone with the same question but no answer, or worse, they reply with "nevermind I figured it out" and don't post the answer.

Aeotec support was not able to help, but I figured out the problem on my own. When wiring something to 220V, you don't have a neutral (well, if you've got 3 wire plugs like I doi); You've got two live wires, one from each leg that carries 110v, and a ground. When the heat is running, current runs through both L1 and L2. However, the motor that spins the drum is only pulling from one of them. Which one specfiically? I don't know. I probably could have figured it out with my meter but I didn't feel like it.

My point is that the switch, when monitoring a device that is only pulling from one leg, only monitors one leg and not both. So I just had to switch the L1 and L2 wire on the live (not load) side of the switch and instead of dropping to 0W it drops down to the correct wattage now when the heat turns off.


I use @syepes's driver found here. It's also in HPM.

The energy monitoring works fine for me. I use it on my dryer.

1 Like

I misunderstood your issue.. though you had power issues all the time (not only when you were on a single leg. I deleted my radical comment

I've tried that driver and it still doesn't work for me. I got this unit when it was first released (8 or 9 years ago?) and I'm starting to think my firmware is different.

1 Like

You likely have the older z-wave version. @waterboysh must have the newer z-wave+ version.

If you post a picture of the clamps we can tell you which one you have.

1 Like

I think they're talking about the 40 heavy duty switch instead of the power meter.

1 Like