Is my "New-One" brand switch DOA?

I have been playing with home automation for a while...I had x-10 switches that could be controlled from a web browser since way back when.

I used Wink until they disabled my hub, then switched to Samsung and never upgraded it because i was using old interfaces. I'm moving, and decided that Hubitat would be a better choice for my new place. My first device was a First Alert smoke and CO detector. It paired without issue once I read the instructions, reset it and put it in pairing mode.

Then I bought a "New One" model N4012 dimmer plug. I can't get it to pair. Repeated attempts to exclude and include the plug result in the include failing. I have factory reset the plug multiple times. Range is not the issue, the hubitat is under a foot from the plug. I have also tried it 20 feet from the plug in case there was an oddity with range being too short. I can put it in pairing mode (5 quick clicks, blue flashing led) or factory reset it but it does not help. I have tried it as a plug from the menu and as a generic device. I have watched videos that talk about mesh issues, but I don't have a mesh, just the two devices.

Am i missing something or is the plug probably DOA? Is there something else I should try? I'm at wit's end with this, but if there is something I don't get i don't want to return a working item because I'm dumb.

Sorry, this is the hub info:

Platform Version

Hardware Version

Rev C-8

I did an update as part of the install a couple days ago. Checked and it said no updates available.

is it the right region?

I would contact "New One". They show the correct frequency and even specifically mention Hubitat. There line on compatibility makes me chuckle:

SmartThings, Hubitat, Vera, Wink and so on.

1 Like

I had never heard of this brand before. This plug looks extremely similar to the Zooz Zen04, Minoston MP31ZD, and Eva LogicZW39M plugs, and is probably a rebrand of those. Or they share a common manufacturer. Pretty sure those all work fine with Hubitat.

Are you sure that you have a Z-wave plug? New One show an identical looking Wifi plug on their site. Eva Logic also sells this plug in Wifi just like New One does.

This is a pic of the plug. It has the Z Wave logo. I have ordered another plug. If that one works, this one gets returned.

1 Like

I have no reason to believe it is not. The plug's slightly out of focus picture is in a different reply, but it has an FCC id, which makes me think it is supposed to be a US plug.

1 Like

I know you just started but can you post your z-wave details page in it's entirety? (use windows snip)

1 Like

Is this the first Z-wave device you have tried to add, or have you successfully added Z-wave before?

I mentioned in my original post that I had added the First Alert Z-Wave smoke/co detector, and I can still see messages from it, so i believe that the radio in the hub is fine.

I don't use windows to talk to the hub, I use Chrome on my phone. I don't think that matters, I get my laptop out once in a blue moon, like I did the other day to burn a raspian image. Boy have they made that crap easy. I am trying to make a raspberry pi emulate a USB keyboard. But that is neither here nor there.

This is a screenshot of the relevant parts of my hub.

<< removed by admin as it included personal hub details >>

@user6252 You should delete that image. It has private things about your hub on it.

I think @rlithgow1 was asking for your Z-wave details. (Settings tab, Z-wave Details)

If you cannot upload screenshots, it is likely because you haven't joined the Owner group, which you can do it at the following link. Hubitat

You might also take the opportunity to change your username so it is more individualized:


You're actually better off using a pc browser to work on things. That said I want your settings))z-wave details page

1 Like

Rule 1: try to exclude it. If the hub says something has been excluded, then try to add it again.

Just a quick status note. A different brand plug came in that looked remarkably similar and the pamphlet was printed in the same almost unreadable light brown ink, although this plug had some energy monitor stuff i wanted to play with.

I was able to add it with minimal fumbling. I'm going to try another reset on the first plug, then I'm giving up and returning it

1 Like

Dooh! Push the button on the side of the dimmer five times. The LED blinks brightly. You think you are in programming mode. You are not. Unplug it. Factory reset it. Careful. Two pushes and hold the third. If you push it too many times before you hold the button it does not really reset although the lights blink. Now push the button three times. The blue LED barely blinks. I had to do this in a darkened room to see the blinking at all. Then you can add it to your network.

Yes, I know I should have followed the instructions exactly...but...three clicks for programming mode, five clicks for some undocumented mode is not good human factors. I just clicked until I saw the light blink. Sigh. Sorry to bother everyone with a false alarm. BTW, the energy reporting plug programmed just fine with my click-until-it-blinks method.


Glad you got it figured out. Sometimes manufacturers over complicate things.

1 Like

A dimmer plug with energy reporting. Hmmm.
I've never had a dimmer plug.
Sounds interesting.

Lutron makes one that's also a repeater. Good for dumb bulb table lamps. I use smart bulbs with Picos though.

I only have a couple of dimmers, and they are built in. The snappy noise of the relays clicking is comforting to me. :slight_smile:

I could see myself getting into the dimmer scene more though.

That would drive me nuts. Caseta=silent on dimmers or switches.