Iris V3 Keypad Issues

Installed my 2nd IRIS V3 Keypad a few times now, cannot get it to register anything but battery and temperature.

Any ideas?

I mirrored the setup of my other working one, so I feel pretty good that it's not user error, but I've been wrong before.

Which driver is selected further down that page?

IRIS V3 Keypad

I have the same model but I don't see the in and out clusters listed, was that introduced in Hubitat firmware 2.6 or 2.7?

Oh boy, you too. I have been going crazy with this keypad too. I discovered it's very odd, and it's due to its pairing as "device". I have 3 and they never pair as Iris keypad 3, even tho driver is built in.
The trick to getting all attributes, is to keep switching the driver back & forth and waiting.
Get the centralitex driver from this thread:

Factory reset the keypad, once it pairs change driver to centralitex one,save device, set motion reset time to 20 seconds, hit configure, then save device.
Change driver to iris keypad2, hit configure, save preferences, save device, then set driver to iris v3, hit save, hit configure, hit save again.
I had to repeatedly change drivers between these 3 drivers until motion and tamper and all attributes appear. It helped to let the keypad sit for 20-30 mins between driver switching&saving.Motion, initially when it shows, will tend to get stuck as active constantly, keep switching drivers. The keypad will eventually look like the below. It's a real PITA, but does eventually work. My method is not scientific but what eventually worked for me.

@mike.maxwell will hopefully update the fingerprint for this great keypad

There is no tamper switch on the V3. It's a dummy attribute and can be ignored at least on my V3 there isn't any.

V3 should have all the right fingerprints -- Did you happen to catch yours when it paired ?

absolutely, it looks like the below, but always pairs as device. And you are correct, I took apart a V3 keypad and nothing contacts the "tamper" switch, so no way could it detect anything, it's not connected to anything on the circuit board. It's just pressing air.
I have 3 of the V3 keypads, on 2 I was able to get the attributes to all work, but the last one I can't get motion to work properly with my "crazy switching drivers" routine.

and the text pasted from device(one that works correctly)

  • endpointId: 01
  • application: 00
  • softwareBuild:
  • inClusters: 0000,0001,0003,0020,0402,0405,0500,0501,0B05,FC01,FC02
  • outClusters: 0003,0019,0501
  • model: 1112-S
  • manufacturer: iMagic by GreatStar
fingerprint profileId:"0104", inClusters:"0000,0001,0003,0020,0402,0405,0500,0501,0B05,FC01,FC02", outClusters:"0003,0019,0501", model:"1112-S", manufacturer:"iMagic by GreatStar", deviceJoinName: "Iris V3 Keypad"

Right fingerprint -- I worked on the driver with Mike and it works for me.

I am assuming you did the standard reset -- take 1 battery out for at least 10 seconds then put it back in and pair it ? Make sure it's been removed by checking the zigbee status in settings.

Yes, i reset multiple times, battery out , wait 10 seconds, hold side reset button, insert battery, wait till blue blink.
If the fingerprint matches why are all my 3 joining as device? comm error?

Strange.. I will have to investigate this

My V3 that Mike just sent back to me does the same thing. When I rejoined it to my system, it paired as device. I had to manually change the driver and works just fine.

Could it be different firmware? Mike Maxwell had mine for a while to investigate why my keypad would not respond to the Beep command. I believe he thought there was some other firmware version out there.

You are correct. I just tested mine as well and it joins as a device... I wonder why because the fingerprint matches. In any case changing the driver works.

As for the beeping I think it's because of the FW not being the latest. Mine doesn't beep manually either but it does beep when I have a delay set.

are you guys getting the motion sensor functionality? all 3 of mine never work with motion untill I do the crazy driver change dance. I got 2 of my V3 keypads properly registering motion by repeatedly changing the driver, and then switching to the v3 driver after all attributes showed up

Mine works.. Mike didn't want to include my code fixes for this problem. I'll ask him again.

1 Like

I'm giving up on these Iris V3 keypads, got them working, but once the alarm is in pending mode, or is going off; the buttons don't really respond.

The other half is annoyed and wants to go back to Vivint since their system, although basic, just worked.

Have experienced similar issues with this device on both ST and HE. In my case on ST, the Iris V3 won't terminate an inprogress pending exit delay, bcause the keypad seems locked. Have to wait for arming to complete, then the pin + OFF button works again.

Not seeing this on my end.

Yes different firmware, the older one lacks the custom cluster for the chime.
This driver is updated in 2.1.8, with the older fingerprint as well as a different command for the beep command.

1 Like

Are the iris keypads available to purchase somewhere? I've been wanting to install a keypad, but not sure where to get one. Seems there are very limited options for keypads!