IP Address and Hub connectivity

I have 4 Hubs, which were purchased about 2 years ago. When I was initially setting up the first hub it would always drop from the network. Work on the connection/problem for about 6 weeks and finally gave up. I'm back trying to setup the hubs. I have two hubs that consistently connect and maintain connection to my LAN. The other two hubs refuse to maintain an IP connection.

Previous router - Synology
Current Router - ASUS Zen WiFi Pro ET12

I have tried all configurations of static IP assignments (through the HUB and through the DHCP on the router)

I have tried different wires and different ethernet ports and still no luck

Most recently I have a "main floor" hub that wants to float between IP addresses
192.168.1. 178 or 181 or 183
I have assigned a static IP address (clear on the router). The hub refuses to go this address.
When the hub picks a address 178/181/183 - it refuses to log in after a few attempts.

The router also does not pick up the device when I do have it connected.0

Basement and Garage hubs seem to be working flawlessly. I can easily find these two devices on my router - via MAC or IP address.

The Great Room and Main Floor hubs are completely lost on the system. I cannot access either (even using http://IP address:8081). Rebooting the router will not gain access. If the power is removed from the HUB, I can gain access for a few moments.

The main floor hub is not listed on the router -
Currently, I can connect to the HUB. This connection will drop within hours. I have assigned static IP addresses (as in the above post) - the HUB refuses to acknowledge the static IP address and the router still does not indicate that the device is even present.

The basement HUB is on (DHCP assigned) and has been since it was installed (almost two weeks). As you can see, the great room hub is not listed (IP...251) and this hub is not currently accessible. I will have to remove power from the device in order to regain temporary access.

Any suggestions/help would be greatly appreciated

Ok, a bit unclear. Are you setting a static on the hub and a DHCP reservation or just a reservation on the router? You only have one router right?

Only one router

I have set the static IP on the HUB - it did not work.
I Switched back to DHCP
Then I used the router to assign the IP to the MAC address of the HUB

I have tried this on both of the hubs - Main floor and Great Room.
Neither will connect consistently

Ok, shrink your DHCP pool let's say 75-250.

Set static on the hubs under .75, make sure you remove any reservations for those mac's.

Make sure on the hub that you set the dns to, . It may look like it's already populated but it's not. Once all that is set go to my.hubitat.com and see if they're there under registered hubs. If they are good. If not, check your static settings again.

I want you to get these out from under the dhcp range is all. That way we eliminate interference. Also make sure that network speed on all hubs is set for Auto and that Jumbo frames is turned off (Jumbo frames will screw up hubitat's network interface)

TURN OFF JUMBO FRAMES (not the same unit but should be similar)

I set the DNS to, on the network setting page and then set the IP to

I am having trouble finding the Jumbo frames on the router.

there is no jumbo frame option under the switch control.

Is there a functional reason to do this, rather than using my local DNS (such as Pi-Hole + Unbound)?

No I was trying to simplify for him. Any valid DNS works. The issue is you have to put it in. It may seem prepopulated but it isn't and then the hub can't get anywhere.

1 Like

So digging a bit deeper (spending 40 mins on a video of the internal workings of your particular router) your router doesn't support Jumbo Frames so you're clear on that. Try the other stuff and see how it goes. :slight_smile:

1 Like

Fingers crossed. It seems to be working. I have been able to access both the great room and main floor hubs. Now all I have to do is figure out how to get the presence sensor to work consistently. :crossed_fingers::crossed_fingers:

Which presence sensor? Also have you updated your z-wave stack and are all your hubs on the latest platform?

I have not updated all of my z waves... Doing that as I type.

I'm using my cell phone as a presence sensor. The first time I used my cell phone, I had actually changed my cell phone name to something that made more sense. I was reading in the forums that this may have been a problem. I reverted back to the cell phone name that habitat assigned it. It still seems to be spotty at best when picking up my cell phone as a presence sensor.

I don't have a prob with what my phone is named in hubitat (dad's iphone). About the only advice I can give is on the app under settings>>advanced set for high accuracy presence. Or if you have any appletv/homepod/homepod minis use homekit's presence. It seems as if it's pretty bullet proof and just use it to trip a virtual switch on hubitat.

Well...I spoke too soon. Dropped two hubs over night. Dropped the basement hub (on ...247 which was DHCP assigned) and the great room hub (static on ...11). This is truly frustrating.

I thought you set them as static outside of the DHCP pool?

I set the great room and main floor hub as static, because the basement and garage hubs had been working flawlessly for over a week. Now I have change them all to static. They are in sequence. Starting at

This is definitely a network issue... Are there any firmware updates for your router?

No, I've updated the router. Right now I'm trying to change my DHCP reservations. I am going to limit the DHCP table to 50-254. So that the router doesn't assign anything from 2-49.


Have you by any chance tried auto-reconnect? I think it will only work if the hub is set for DHCP. I've always had very stable ethernet connections and I don't use it but it might help in your case.

The other thing you might try just for grins is to power off the two hubs and ping their IP addresses - if you get a reply you've got something else on the network with the same IP. Long shot but it might explain your issues.

1 Like

I have set up a static IP address on all 4 hubs and reserved the IP address on the router. Hoping that improves the connection. I did try the auto reconnect while I was in DHCP - that didn't seem to have any impact.

1 Like