iOS notifications no longer working with Hubitat app

I have a z wave water sensor for a sump pump. The alert shows up within the Hubitat app under tools/notifications, but the notification does not show up as a notification. I do have notifications enabled for the Hubitat app. This used to work, but it’s no longer generating a notification outside of tools/notifications. Thanks for any help. Should I use another method than the Hubitat app for reliable notifications?

If you use Apple Home and add the sensor via the Homekit app, it will definitely get your attention when it becomes wet. It's a very nice feature of Apple Home. Other than that, make sure you are allowing the Hubitat app to run in the background.

Open the Hubitat app on your phone and log in. The notifications should start working again.


Appreciate the responses so far. Not using Apple HomeKit, as I do not have a HomeKit server. I also tried logging out and logging in on the Habitat app with fingers crossed, still no notifications. Notifications are being faithfully logged in tools/notifications on the Habitat app. Even the Test Device notifications are logged, just no true notification on the iPhone.

Android here, but Pushover has been good for me.

Strange. When it happened to me I opened the app and logged out. When I log in it sees the two devices (my iPhone, wife’s iPhone) and asks me to select my device. Once selected that was it, notifications started coming through again. Do you have multiple hubs or logins? Another issue I had like this was after I migrated hub - I was logging into an account that had the old hub but not the new one in

1 Like

All you need is a Homepod mini or Apple TV. Hubitat’s built-in Homekit app handles to connection.

Go to the main iPhone settings gear app.
Scroll on the left side to the bottom section, with all the user installed apps listed, Find Hubitat
Tap Notification section
Make sure notifications are enabled and set how you want them to appear.

1 Like

I’m experiencing the same issue with the Hubitat iPhone app on iOS 17.2.1 on an iPhone 13 mini.

I’ve relogged into the Hubitat app, made sure to select the phone, and the Hub notifications are set up on.

Hubitat notifications are set up properly in phone settings that I am aware of.

I only see notifications if I go into the Hubitat app and go to Tools > Notifications.

I turned debugging in the app but nothing shows up.

I can’t remember the last time it actually worked.

What app version/build is it? (Settings > About)
I am running 1.3.1 (160).

I would actually try just deleting the app and reinstalling it. There is really nothing that will get lost, you just need to log in again and select the same "Device" on the hub.

Oh... one other thing I thought of. I have two hubs so I have an android Tablet logged into the 2nd hub just so I can use Smart Start. I have noticed that I get some stuff from the main hub in there sometimes (not showing up right now of course). So possibly the notifications history is account wide, but the actual pushed pop ups are only for a specific device?

Anyway... make 100% sure the device you selected when logging into the hub is the same one you have the notifications being sent to in your rules.

My Hubitat app is 1.3.1 (160).

Reinstalling the app was next on my troubleshooting list.

Side note, possibly unrelated, my phone is a device on my “device hub” shared to my “coordinator hub” via Hub Mesh.
I log into the coordinator hub on my phone cause it has the dashboards, HSM, and notifications app running on it.

Notifications used to be working great, but I only had some critical HSM related ones that shouldn’t fire often so never noticed it stopped working.

You could try creating a new device on the coordinator hub when you log in, and then send it some test notifications from the device page. See if that makes a difference.

Yep, thanks, was going to test that after a reinstall attempt.

I believe, but can’t be certain that I already attempted it on the current “device hub”.
Regardless of which hub it’s coming from, it should show notifications on the phone in the app as the notifications are under Tools > Notifications.

It’s just not triggering the iPhone notifications functions it seems, which is why I kinda dismissed it being a hub or Mesh Hub issue.

I'm also having notification issues with the IOS app, posted here: IOS App Questions - VLAN

I have a separate vlan for IoT but I don’t think that’s directly my or your issue or the OP’s issue. I have had my hubs on a very restricted vlan for years without issue.

Uninstalled and reinstalled the app, works now for me. Not OP.

Thanks to all for your posts. Uninstalling/Reinstalling worked. I also tried Pushover, which was easy to set up and I may switch to that. It seems like the Notifications in the Habitat app aren't reliable based on others' experiences. Again, thank you all!

1 Like

@jtp10181 @JerryY @spartysh32

I did a bunch of testing and documented it, but for sake of time right now I’ll post the main findings at least for me:

  1. It appears trying to share a iPhone Mobile App Device on a “device hub” using Hub Mesh won’t work, once it’s shared Notifications stop working completely
  2. The solution (for me) was to remove/delete the iPhone Mobile App Device from the device hub and create a new one either on the device hub or coordinator hub, either one will work, but as soon as I tried to share it via Hub Mesh it stopped working as expected
  3. I didn’t have to uninstall the Hubitat app

My situation is a bit different from the others, but it seems like once the iPhone Mobile App Device is kaput, removing and readding gets it right, uninstalling the actually Hubitat app essentially does the same thing.

The hub(s) or mobile app logs have nothing worthwhile (at least I don’t see anything).

1 Like