iOS App dashboard doesn't refresh


#1

Hi, I've been a long time Smart Things user and am now trying to slowly migrate over to hubitat.

One of the hiccups I'm running into is the dashboard refresh in the iOS app. I've seen a few threads very similar to my problem but there seems to be no solution by the end of the threads.

I'll try to describe what I'm doing to help re-create the issue for anyone else. I'm on an iphone XS Max with the latest ios (12.4) and the latest Hubitat app. When first opening the app and going into the dashboard all the tiles are refreshed and mirror the hubitat's current states. When I use the dashboard in my browser (safari) on my mac and turn things on and off, the changes are reflected in the ios app relatively quickly. After closing the ios app and then going back into it a minute or so later the refreshing stops working. Changes made on my desktop browser no longer refreshes on the ios app. Also, the green and red icons at the top right will blink back and forth between each every second. It doesn't make a difference if I'm in cloud or local mode. Only after I drag down the screen to initiate the refresh will it start giving the correct states of the hubitat. Any ideas?

Thank you!


#2

Is it only after changing the state of that specific tile in dashboard? Do other tiles update?

There are some changes that will address iOS and events happening while the app is in the background coming in the next update.

Hopefully that will address several iOS / Safari interference with JavaScript.


#3

None of the tiles in the app seem to update. I just tried a number of my switches and one motion sensor. The only thing that changes is the flashing red/green icon.

I did try a home screen bookmarked dashboard and that too does not refresh reliably either. That's a little worse since there seems to be no way to quickly refresh the page.

I look forward to the update!


#4

@patrick I just tried using the dashboards for the first time via a cloud link. I think the problem seems to occur when there are two connections to the same dashboard from two devices ... I get the red/green icon flashing on one of the two devices. Closing down the dashboard on both waiting a few mins and only opening on one device resolves the problem. Two iPhones ... running latest iOS...

Dan


#5

@patrick apologies, what I said isn’t the case...

What’s actually happening is if I bookmark the cloud url for a particular dashboard after a couple of uses it starts to exhibit the problem(flashing red green and not responding). Going back to the dashboard menu and reopening the cloud link for the actual dashboard then restores things... presumably I should be able to bookmark the link to an actual dashboard ? And not have to go via the dashboard menu ?

Bit more info ... it seems to be that when you save a link to the home screen it looks like it’s opening a cached version of the page each time ...