Invalid Token When Navigating To Dashboard

When I navigate to my dashboards I keep getting invalid_token and a blank white page. I just got my Hubitat up and running today. I haven't set up much except that I've added 3 Z-Wave switches so far and those work.

Anybody have any idea what is going on?

Are you using the dashboard's local or lan link? Have you set up the dashboard yet (layout)?

I've set up one dashboard and when I try to navigate to Local LAN Links for the dashboard I created I see the following error:

null invalid_token

There was so xml in my last message that got stripped.

The URL it attempts to navigate to when I click the Local LAN Link is:


Should access_token be null?

Ugh, it stripped xml in my last message too. My local hub address is between the http:// and /apps...

Don't worry about that. Can you post a screenshot of your dashboard setup page? It should look like this:

And you do have to click done for it to save and then go back in and get the link. I don't think it assigns a token till it's saved.

It's saying I can't put images in posts.

Okay. Did you follow the tutorial on creating a dashboard?™_Dashboard

Yes. I just made a basic mobile dashboard in portrait and checked to add all my devices to it.

I would contact support then, since you can't upload pics yet. Or you can go over the link I provided again and make sure you absolutely did everything you have to. Because dashboards work pretty well.

Yeah, I've tried a few ways where I check all the devices or the toggle to add all devices and the token is always null. Is there any other setup I need to do to the Hubitat for dashboards to work? Like adding users or anything?

Did you change anything in advanced options? Like turning off cloud and lan access? All i can say is that you have to follow all the steps on the page I linked to. You have to do all of the steps.

Something with the install of dashboard went bad, since you are just getting started try removing dashboard and start again by adding dashboard app.

1 Like

Uninstalling and reinstalling the dashboard application worked patrick. Thanks!


Adding a link to my dashboard doesn't work for me. I get a "nullinvalid_token" error, no matter what I try.

I want try this option (delete and reinstall the Dashboard app), but does it keep all my dashboards in tact? or do I have to build them from scratch?

Got it, Dashboard > Gear > Advanced > Layout/CSS. Copy the JSON and CSS text.

How to clone a dashbord

Getting something very similar - but I'm not a new user, my dashboards were fine for years until now....

Dashboards links are still working fine via browser URL (on PC and phone).
But Hubitat android app is giving the oauth "invalid _token" error - It doesnt even show the list of dashboards.
I dont see anywhere in the andoid app where I can tell it the access token.
I guess I could try reinstalling smart app on phone.
But any other suggestions ?

Can you connect to the HE hub via the mobile app?

Yep, and dashboards work fine that way - since its just a browser
Its only the dashboard tab in the mobile app that doesnt work

I was meaning can you connect to the hub by clicking on the connect to hub option in the Tools tab, is that what you were also referring to? The reason I ask is that you have to be on a registered device to access the hub, so was wondering if a similar method of authenticating the access was being used.

Download the Hubitat app