Inovelli blue switches unpairing

I installed 60 or so inovelli blue switches about 1 month ago. All paired well. Used button rules to set up on/off and dimming. About 4 days ago all switches became unpaired and defaulted back to on/off. I was able to easily pair them again. Figured just a glitch. Button rules worked fine again. Today same issue where all switches became unpaired and back to default. Please assist.

Do you have other zigbee devices too -- if so, have they been acting OK?

Any chance your wifi or any other ZB controllers (like a Hue bridge) are interfering with your HE ZB?

All else working well. Three hue bridges. One bridge near H8. Other 2 on different levels of house. One Lutron bridge not near H8.

Also wifi router close to H8.

What channels are your Hubitat, Hue bridges and 2.4 wifi using? How close (distance) are your router and one Hue bridge to your Hubitat?

Zigbee channel is 8. Hubs are 2 feet apart. Hue to Hubitat. Wifi router about the same. Other hubs over 40 feet.

Hue bridge near Hubitat is channel 11

What channels are your Hues on and what channel is your 2.4 wifi on? These answers will help confirm if channel interference is a potential factor.

Go to Logs and the Hub Events tab. Do you have any zigbeeStatus “Zigbee radio is offline” events around the time you think these devices unpaired? My hub has lost pairing to devices when this happens.

1 Like

Other 2 hue bridges are 11 also and 25. Where can I find 2.4 wifi channel. Not sure.

Only instance I saw.

I'm not familiar with running multiple Hue bridges, so I have no idea if those can share the same channel or not, but I suspect you have wifi/ZB channel conflicts that are messing with your zigbee mesh. I'd also recommend more than 2' separation between your Hue, router and HE.

Your router's own settings may confirm what your 2.4 channel is, or you could use a wifi sniffer app to find it.

Zigbee 2.4 wifi Interference info

Thank you. I’ll try your suggestions and check the wifi channel in the am.

Rule of thumb is keep your wifi on channel 6 or below and Zigbee on 20 and above. That said, this is a really strange failure, especially with inovelli and so many at once. I would put in a support ticket at or tag @bobbyd or @support_team so they can look at your engineering logs.

This sounds like a combination of driver/device issue (forgetting the settings) and an overloaded radio that can't handle events and drops offline. These switches report power and energy by default, and if all 60 generate power reports, frequently, then the mesh could collapse. Make sure to disable the power/energy and also, you may want to reach out to Inovelli to see why the parameters may have been auto-reset.

Currently, the latest Blue firmware available is 2.15 and the latest available Hubitat driver version is 2023-07-01.

The early 2.0x firmwares had severe connection issues, so if you aren't on at least 2.14, I'd update. The 2.15 firmware is available within Hubitat to update.

The Blue's Hubitat driver is available in Hubitat Package Manager (HPM) -- it can be found as "Inovelli Drivers (Gen 2)"

1 Like

Thanks. I will check all.


Things I’ve tried but failed.

Moved Hubitat hub to new location far from wifi and other hubs

Re paired switched with settings 18 and 20 to zero. (Energy monitoring)

Used the Hubitat Program Manager to update my inovelli driver.

Again. All re pair with no issue but by next day all unpaired again.

Also put in support ticket with inovelli. Provided same info as to Hubitat community but no suggestions for fix yet.

What (Inovelli) firmware are the Blues on?

Sorry but I’ve looked around. Can you tell me where to check on that.

Ahh found this.

That's for the driver, but the firmware is not managed via HPM. On each individual Blue's own Device page, the current firmware should be in the State Variables section:

If not on 2.15, you can update each switch by clicking its Update Firmware button -- but before clicking that, open a Live Logs page in a new tab -- then you can watch the firmware update progress as soon as you hit the button.