[INCIDENT] Notifications and presence stop working after migrating to the new mobile apps

Our engineers have identified an issue with the mobile devices used for the push notifications and presence sensing.

If a user migrates the old mobile device to the new Mobile app, then logs back into the old Mobile app, the device may no longer receive updates or new push notifications.

A fix is expected in the next update, which will need to be installed on both the old and the new app.

To prevent this issue, we recommend uninstalling the old app before installing the new one. If you need to revert to the old app, please be aware that you will have to wait for the next release to start using the old mobile device with the new Mobile app, again.

Thank you for your patience and understanding.

9 Likes

Ok so I didn't read this before installing the new app. I had deleted the old one moments before. Logged into the new app. Selected my hub and so on. Basically I followed the prompts. Now my Hub appears to be located about half a mile from its true location. I went into Hub details on the web interface and fixed the latitude and longitude, but every time I open the new Mobile app on my iPhone and enable Geofencing, it keeps stating that I'm "Out of zone". So even though I have updated the latitude and longitude in my Hub, the Mobile app still has the wrong lat/long, old info that doesn't update. How do I fix this?

Delete the app, reboot the hub, then reinstall the app.

You can also manually move the red pin anywhere you want (its hard to grab).

1 Like

Yeah, that pin grab wasn't working for me. But reinstalling the app did pick up the correct lat/long from the Hub. Thanks for the help.

I wasn't using presence/geofencing on the old app. Installed the new app today - had a similar issue with geofence showing me about a mile away. Grabbed the pin to fix that. Then created a couple of basic leave/arrive rules to switch my Ecobee thermostat into Away/Home mode accordingly.

I tested today, with mixed results. The "leave" trigger worked just fine - a few minutes after I exited the geofence it triggered the mode change on my thermostat. I opened the HE App and it all looked correct. Upon returning home, however, nothing happened. I opened the HE App, and the home page showed "Outside Geofence" but when I clicked on that and the map opened, it showed I was inside the geofence. The label below the map even showed "Inside Geofence." But when I exited the map, it still showed "Outside Geofence" on the home page. Tried that several times - nothing changed. Then tried shutting down the app and re-starting - no success. I then decided to switch hubs (I have a second home on HE), and switch back, and that seemed to trigger recognition of being back inside the geofence. However, that didn't trigger my rule, so my thermostat remained in Away mode.

While I wasn't using geofencing on the prior HE App, and I've deleted the old app, I will still try the process recommended above and delete the app, reboot my hub and reinstall the app.

I'm having similar issues with notifications not being delivered. I deleted both the old and the new apps from my iPhone, rebooted the router, and installed the new app on my iPhone, but I still have problems with non-delivered notifications even though they show up in the logs. Any advice?

Check your app notification settings on your phone. That sounds like permissions to send notifications have been disallowed.

Notification settings "on". It seems this is more complicated then I realized. This all started recently. My other mobile user Is getting notifications that I'm not getting and at one point was getting notifications that they weren't even supposed to. I have two iPhone devices both with the same Device Name "iPhone". They each have different Device Labels That the notifications are tied to. This has all been working for quite some time so I'm not sure what happened and where to go next. Any thoughts

I would create new devices to test that notifications work as expected. Then, if they do, use Swap Devices App to replace the old devices in rules with new devices. I wouldn't name both of them iphone, as that is easy to get them mixed up.

Actually I don't believe I made them iphone as this is the "Device Name *" Provided through hubitat. The device labels are indeed different. Wasn't sure if I could change the "Device Name" . What new devices would you create that are mobile?

Do you mean Create some new device Notifications from something that doesn't normally get them. Like a light switch

Have you tried tapping the hub name on main page, then Switch to Another hub, select your same hub again to reconnect it. It may or may not ask to select a device.

You can confirm the device it is connected to by tapping the More button at bottom then app settings. Check device name is correct.

Yes you can rename the device from within HE once the app creates it.

If reselecting the hub does not work you can try this (click link for full instructions)

Update: I now have notifications on my iPhone on some apps and not others. My front door notifies me when it's locked and unlocked, as it should. On the other hand, a button app that I have does not send notifications even though the logs and event details say it did.

If it all goes through the same virtual mobile device on he hub, and all show in logs/events, there is no reason some apps notifications would work and others would not. There is a chance some notifications do not make it to the mobile app for whatever reason, but it should not have anything to do with the app the notifications originated from.

When you say the notifications show in the events, this is the events tab on the mobile device page?

Yes, the events details are on the mobile device. I'm not sure why this happened after the platform update, but it seems as though it is the case. I tried one other thing I put a Pushover Notification in the app and it worked. I tried turning on and off the iphone notification and it still would not work even though it works in other apps.

Another thing I tried was changing the "device name" from iphone to something different. I did not change the device label.
Interestingly, when I went into my app, two iPhones with the same "Device Label" were available to pick. I picked what appeared to be the new one, but the app still did not notify me. When I went back into the app, there was now only one iPhone to choose, which again did not work. So, right now, all I can get in this app is a Pushover notification to work.

So are you saying for notifications sent from HE via the HE mobile app (virtual device in hub), none are working? The only thing that works is if you send it via Pushover?

The way you toss around the word "app" makes it very unlcear because you have apps on the Hub and you have apps on your phone.

I would try following these instructions (click link to open):

Once complete make sure all duplicate "Mobile App Device" 's are deleted from the hub, keep only the new one created by the mobile app.

I already tried this once and couldn't force the hubitat iPhone app To ask to pick a new device or create a new one. I'll give it a go again.

I'm sorry about not being specific about apps. Everything I am doing is on the computer using the Hubitate-built apps. The exception is when I'm being specifically asked to use the iPhone, such as above.

It works if you follow my instructions. I have tested it myself.

Thanks @bobbyD for flagging this. It explains why I can't get notifications working on my new hubs, because I didn't remove the old app first. Am I just stuck until you release an update or is there a workaround? Also, I'm a little confused about the comment that the fix is needed on the old and new app since the old app is gone. Does that mean I should add the old app back and then patch it along with the patch to the new app? I installed Pushover for now and use it for my critical notices, but I have too many apps that use the builtin to slog through and move all of them over (unless the patch isn't coming soon).

[EDIT] I used the fix proposed by @jtp10181 and it worked - thanks man!

1 Like

I having similar issues with the new app it keeps telling me I am outside the area, I have to fix this somehow, I have deleted and reloaded the new app will that work or now do we need to wait for an updated version. That does not sound like a solution.

Appreciate any advice.

Thanks