I want to love my hubitat but

So I bought my Hubitat with every intention of replacing Smartthings. I read the reviews, I was looking forward to the advantages of local routines vs. Cloud and rushed out to buy a C8.

I'm a 30+ year software engineer and I'm incredibly discouraged by how painful everything had been so far. I've only set up 2 z-wave devices to start testing the waters and can't get the most basic 'basic rule' to work.

Flipping through pages, Google searching and I'm at a loss to understand how to troubleshoot. I created a rule to turn off an outdoor light at 1am and no dice.

Please point me to the right direction to the right log, or setting thats going to help me understand why something so basic doesn't work.

Post screen shots of the rules you've created.

Logs are under, well, Logs, in the menu on the left side of the screen. :slightly_smiling_face:

1 Like

Expand Developer Tools to see Logs and other goodies.


Welcome to the Hubitat community, sorry you are having a rough start.

Do the devices work fine when activated from the Device settings page?

Do the States in the upper right corner of each device's settings page follow the actual state of the device? In other words, if a switch is on, do states say "ON", and similarly if you dim the light does it follow correctly in states?

What app are you using to build your rules? Screenshots, like @danabw says can be very helpful to us to help solve your issues.

If you can't post screenshots, you likely don't have forum permissions yet. You can get permission by joining the Owner Group in the following link: Hubitat

I would also direct you to the https://docs2.hubitat.com if you haven't yet seen it, there is a lot of good info in there. There also is the Hubitat Youtube channel which walks through many scenarios and can help to get you started. https://www.youtube.com/c/Hubitat


Logs are always present on the left menu regardless if Developer tools items are collapsed or not. :wink:

1 Like

Don't get discouraged. Something is amiss with your hub or devices. For a simple case like you described, it really shouldn't be difficult to get started. The basic troubleshooting steps would be to confirm if the devices involved work as expected from Device Details page (select Devices on the left menu, then click on each device involved and validate that is working by selecting on/off, for example). If they work, then next would be to analyze your rule. Assuming you used Basic Rules app that comes pre-installed, it should look like this:

If that's what you have, and is not working, then you may want to check to make sure your devices report their actual state back to the hub. Older Z-Wave devices may not report their state after you manually turn them on, so the app doesn't see the lights being on, therefore it's nothing to turn off at 1AM.

For more ideas on how to troubleshoot apps and devices, please check out this document: How to Troubleshoot Apps or Devices | Hubitat Documentation


Wow, first off so many helpful responses :slight_smile: , things are looking up and I can see I'm sure I'll get the hang of this.

Device function - check, manual on/off works no problem
Device status - check, current on or off status is correctly reported

App - check, used Basic Rule App and config matches

Logs - check, looks like past Logs and Scheduled jobs contain useful info and I have a suspect... time zone?

Scheduled jobs says next run is 2023-12-14 01:00:00 GMT

If I'm correct it would explain an earlier mystery, the light mysteriously switched off at 8pm - I had assumed I fat fingered something while setting up and dismissed it as user error but 8pm eastern happens to be 1am GMT.

So off trying to figure out where to find the time zone setting for my device or start setting my times in GMT. Wish me luck!

That said, is it just me? During basic rule creation I had to hit "erase time" before I could proceed to define the action... took me a minute to overcome my reluctance to hit the only button present despite what it said.

Also noticed editing the time on the existing basic app did update the scheduled job description, but not the scheduled job time - maybe I'm just not being patient enough :slight_smile:

1 Like

Are you using z-wave devices? If you had any failed pairings you may have ghosts which you will also want to remove. Also since you're new, take a gander at this post. It should help you avoid some gotcha moments...

Time zone is in "Settings", "Hub Details".

1 Like

You are correct!

Your luck found you, Settings >> Hub Details (top option under Admin Settings). After making changes there don't forget to click "Save settings" button. Then head back to Settings and Reboot your hub for good measure.

That is not expected behavior.. It sounds like a browser issue. What browser are you using? We recommend Chrome for best experience. Also, what operating system you use, may influence how the user interface is displayed.

Updated, deleted and recreated the basic rule - scheduled job next run time is now correct. Thanks!


I was just using from the inapp browser through the hubitat android app, which I'm pretty sure is chrome under the hood. I'll try Chrome itself next time.

1 Like

Ah, yes, rendering of in app browser doesn't always work well. You'd have a much better experience using the browser directly, especially when building rules.


You can use a desktop or laptop browser instead of your phone if you wanted to. I really like that with Hubitat you aren't forced to use a tiny screen to access the hub like you are with some hubs. I find it a lot easier when I am building rules and setting up the hub to use a full size monitor, keyboard, and mouse.