I am stuck on Room Lighting. Can't get this room to work. need help

have ben tryingto get a room lighting instance in my office set up for a while and I just cant eem to get it to work. @jtp10181 has been great trying to help, but we never seem to get it to work. I tried just going to a basic motion rule, but @bravnel suggested I go back to Room Lighting. So here I am again.
What I am looking for ?
Office lights on a zone motion sensor , turn on with motion, off 7 minutes after motion stops. EXCEPTION Mon- Fri I need the light on at 75% between 0700 and 1530. That's it. and I cant get it to work.
Here is my Rule:

Here are logs (im siting in the dark as I write this. The motion sensor above my head behind me will pick up motion my just turning my head).

What am I doing wrong? Please help!!

Did you make changes after getting those logs? There are logs showing motion sensors that are not even in the screenshot of the RL app.

What is the problem exactly?

Office 1 and Office 2 make the office zone. To streamline things I took them out individually, I can add them back, I just thought it seemed redundant to include them individually.
Nothing works. Doesn’t activate with motion any time, and doesn’t stay on with working hours. This is based on the example we have been working in together recently.

Edit; I have about 4 rules I need to rework, but I’m just using this one as a base. All of these were previously in event engine. This particular rule was also in RM, but it took me 4 roles to make it work.

here are the logs since midnight until a minute ago. The lights have stayed off the whole time, including while I write this right after I walked in.

What happens when you click the activate button?

The switch setting on that time period you posted above is off, so "activating" is turning the switch off. So it looks like it is working as programmed.

This means Activation to status "Off" (current status off)


Ahhh. ok I think I thought that meant what the NORMAL state was in that period. So this would need to be changed to on for all periods?

I vpn'd in earlier and changed that to "on" Here are the logs since:


Yes, you want switch ON and then set your level to what it should be turned on at. If you want to control the level manually, you can change it type switch and then it will turn on at whatever level it was at last.

You will also need to remove this time restriction I am showing below, since it will apply to all days. Unchecking "off" during the Working Hours M-F should prevent it from shutting it off during that time already. Also the Limit with the motion sensor is sort of redundant and not doing anything, I would remove that too.


1 Like

Remove both?? or just the between times?

For sure the between two times, the limit to not turn off when there is active motion is redundant because you only have one means to turn off trigger, which is inactive motion.

If you had some other means to turn off but wanted it to be blocked during active motion, then it would be doing something useful.


1 Like

So far, so good. Since I made those changes this afternoon motion activation seems to be working correctly. Now to see if working hours and after hours during the week works as intended.

EDIT 2230: Well it WAS working, now it isn't. Not sure what is up now. No logs being generated by RL, but I am getting logs that the individual motion sensors are picking up the motion, but the light isn't turning on.

-2233: The Office Motion zone consists of Office Motion Sensors 1 and 2. Previously I had removed these individual sensors since they were part of the zone. That Zone was not generating logs, but motion sensor 1 was, so I went back and added the individual sensors in addition to the zones and it started working again. So, does that mean the Zones are kind of pointless?

Seems like the motion activation is working, for weekend non working anyway. While I wait for Working hours and weekday non working periods to come around so I can verify them, I feel fairly confident I have this on figure out.

Next I have a patio light tied to a motion sensor that I cant seem to get working. Im looking for Motion Activation between 30 mintues before sunset to 45 minutes after sunrise. Nothing is happening, even though the motion sensor is picking up the motion. Here is the rule:

Logs from the motion sensor:

Logs from the Switch:

But no logs from Room Lighting and the lights not being activated.

Any thoughts?

Your time periods don't match this?

Should be exactly this then have the activate on the 30 mins before sunset.

Since you want the same restriction every day of the week, this one I would actually get rid of the time periods and just set an activation Only between restriction of the time you want it to activate. Its a little less complicated that way.


The don't activate if turned off manually is optional, it is a way to disable the motion sensor if needed. You can sun sunrise/sunset with offsets instead of exact times.

One question. In the table "State" keeps going to X. My gut tells me thats not right. If I click on it, it changes to either a red circle or green filled circle, momentarily, then goes back to X. Is my gut right or is this normal?

I means the app is not seeing a change in state from the device when it is commanding it.
Open up the device page as well, see if the state changes. Also might need to turn on some logging and check the logs.

Here are the logs for the actual devices since yesterday afternoon (note the devices used in the rule are Hub Meshed from my devices hub denoted by the lock Icon. these logs are pulled directly from the device hub, not the server hub that handles the processing):

Switch logs

Motion Sensor Logs

And here are the logs from the rule. Note that I have don some tweaking on the rule this morning which may be reflected

This is what you need to see from the app, these debug entries (if debug is enabled).
This is the app saying it has seen the event from the switch.
Out of that huge log, I only see it this one time.
Are you sure the device is syncing properly with the mesh?
You should open the device entry on the same hub as the RL app, and see if the switch status is updating properly. Possibly it is just delayed longer than RL waits for a response.

This is the logging I have enabled. Do I need to do it some where else? I dont see any other options.

The Rule for reference (as it is now):

App Logs

Switch logs (from the App hub)

Motion Sensor Logs (From the App hub)