Hubitat+ZWave - constant reliability issues

I need help. Almost daily I have a switch or a dimmer that does come on or go off when it should. It's not related to brand or type of device, and doesn't appear to be related to devices with lower signal strength.

Here is what happened this week:
Monday: 0x2E did not turn on. (RM InsideDusk)
Tuesday: 0x31 did not turn off. (RM GoodNight)
Wednesday: 0x2B did not turn on. (RM OutsideDusk)

I'm starting to think it's not the mesh and there is something wrong with my hubitat. I have located it to 3 different places over the course of several weeks and the reliability never changes. I'm signed up with Hub Protect so I'm wondering if maybe getting a loaner would verify that it's not the hub that's at fault.

Many of your devices have a large number of route changes. How many days has your hub been up and running?

By way of comparison, my hub's current uptime is 15.5 days. I have 57 z-wave devices. Here are the top 10 z-wave route changes. Everything else is under 4 route changes.

The high number of route changes for some of your devices may be meaningless if your hub's uptime is very high - like one month. But if that is not the case, it suggests that repeaters in your mesh could be placed in better locations.

1 Like

Last time I moved the hubitat (shutdown) to try another location was this past weekend, So 5 days ago. I also have a repeater that never repeats anything (beyond the 1st 24 hours). But the failures I'm getting are all over the house so I really don't know where a repeater will help if at all.

ZWave issues can be tricky and frustrating... but there is hope! @aaiyar has some great suggestions. Couple questions...

Do the devices in question work reliably when triggered from the devices tab? Or are they problematic there as well? If they are, definitely sounds like a mesh issue. If they are not, that is to say, they perform flawlessly from the devices tab but not from the rules, the answer may lie elsewhere.

How are you activating/deactivating these lights?


I've never seen a failure by turning devices on or off or dimming from the devices page. I have seen (less frequent) failures from using buttons to turn multiple devices on/off/dim.
The most frequent failures come from RMs that trigger on time of day.

There is an option to meter in groups, that fixed some of my issues when turning everything off or lots of devices on. The antenna mod helped as well. I have had devices lock up as well and bog zwave down.


When I have mesh issues they usually appear regardless of the method of activation. Though I do think the number of reroutes that @aaiyar noticed is something to consider, I am kinda with you that it doesn't sound like a mesh issue... at least not exclusively.

Have you turned logging on for the various devices and rules and watched the flow? If the rule triggers the device and the device thinks it has turned on, it might still be a mesh issue. But if there's a gap there somewhere, maybe something else is happening. When you turn them on or off do you do it with scenes or groups? And as @bpspiller points out, do you have metering enabled?


Moving the controller around after establishing a mesh is the worst thing you can do, as the radio needs to figure out new routes. The best practice with Z-Wave in particular, is building a strong mesh, methodically as described in this document:

I am not saying that you should never move your hub, but you have to account for the risks you may encounter by doing that.

This is a big clue that maybe some devices are choking the radio when you try to send commands to multiple devices at once. I found that with Z-Wave is best to break groups in smaller number of devices. If you are trying to turn off many devices at once, try metering, or group devices by room/floors (that's what I do).

Last but not least, if you'd like us to make sure you are not dealing with a hardware malfunction, you could send me a PM with your hub's MAC address and we could take a look at the engineering logs to make sure your hub is in good shape.


Tried this with various metering from 100 to 500ms and made no difference.

Did you update your z-wave firmware?


I would like to try an move my RMs that turn on lots of devices to scenes. Except some of them use IF-THEN-ELSE which, correct me if I'm wrong, you can't have IF-THEN-ELSE inside a scene or group.

Also tried metering inside an RM. Maybe I'm ignorant on how this works. But I was able to add metering on the first few devices in line 1, but seems I can only use this once in a rule as the metering GUI goes away on the next set of devices.

I will check this later on this evening as several RMs are triggered then. also updated the radio a few weeks ago.

You need to just let your mesh settle.. No more moving the hub or devices.. Give it a few days to calm down the re-routing..


@bcopeland What do you know about the later version of the Z-Wave firmware (7.17.2 or later)?

While things are generally more responsive with 7.17.1, I still have some issues with the hub seeming to get locked up for a bit. Better than before--but there is still some room for improvement.

I heard somewhere that the .2 version made some additional changes to help with "large" networks??



I read that also, but cannot remember where. If you can find the original post/community, I’d appreciate it!

P.S. I thought it was zwavejs2mqtt but can’t find it there.

@Tony posted this..


Thanks! I knew I’d seen this - just could not remember where.

1 Like

I finally fixed all my reliability issues. It wasn't log spamming, metering, bad device, ghosting or anything else. It was just crappy reception.

Here's where I got the parts: