Hubitat Suddenly doesn't communicate with Zigbee Devices anymore?

I came home and noticed my lights weren't turned on (via a zigbee switch) and the front room lights (controlled by a zigbee plug) weren't turned on.

little background but I use Homebrew to control automations from Apple HomeKit.

I tried restarting both the habitat, and hoobs and that didn't work. I tried controlling the zigbee devices directly from the habitat dashboard I created but that doesn't work either. I am able to control my hue light bulbs but not anything zigbee specific.

Any ideas besides having to rejoin all my devices?

1 Like

Shut down instead of reboot. See if that works. If it does not, shut down for 30 min and try again.


Also check the system messages and see if it has zigbee radio down



In addition to the above, what model of hub are you using? What I'm really asking is whether you have a newer hub (model C-5) with an internal Z-Wave and Zigbee radio or a slightly older hub (model C-3 or C-4) with USB radios. If yours has the USB stick, it can't hurt to unplug it and plug it back in--maybe try the other USB port while you're at it. If you're using a C5 (and if you're not sure, you probably are, especially if you bought it recently), then nevermind. :slight_smile: You'd probably see the message suggested (not shown because his is functioning properly) in the above post, but still worth a shot.

I assume this goes without saying, but I'm guessing you also didn't try anything drastic recently, like changing your Zigbee channel in Settings on the Hubitat hub (don't unless you need to; this was just an example of something that should work for most devices but could cause problems if it didn't work and you did in fact do this).

1 Like

I'll give this a shot in the morning. Thanks for the suggestion, I'll respond if it works!

Oh good call. I think I may have checked them when I updated it. It only had 1 message that said there was an update but I'll double check.

I am 99% sure it's a C5 since I bought it in December 2019 so it's only 3 months old. But I'll double check!

But yea I don't have any USB z wave or zigbee devices plugged into it.

Oh and yea I hadn't made any changes to the hubitat in probably a month. It just randomly stopped working. Really odd.

My zigbee network went down today aswell..mine is a c5 I have no custom apps or rules..I didn't do anything to it to cause this..zigbee network was perfectly fine before not working at all.

Edit: shutdown worked but restart did nothing to help. Hopefully this doesn't happen alot..

1 Like

Same problem. Had to reinstall every damn device. Not happy.

Sounds like a misbehaving device may have crashed the Zigbee network. There’s a tool available. Not the most accurate, but it’s something and I have to admit that if I’m going to keep recommending it I should figure out how to use it myself. I have an Xbee for such things.

Anyway, you can get an idea of how well or poorly a device’s Zigbee routing is working with this. Bottom of this doc has the basic instruction of how to get to it. I know I’ve seen posts on here and others can point you to that and know how to use it

If Lutrons new Caseta motion sensor is updated to include state changes over telnet I’m ripping out all my zigbee stuff and selling.

Here’s for hoping! :crossed_fingers:

1 Like

Shutting down, unplugging and replugging my hubitat back in didn't change anything. Still can't control the zigbee devices.

Just for the fun of it, do you have a new Zigbee device you could try pairing? You could also just reset and try to re-pair one of your existing Zigbee devices if not (don't delete it from Hubitat first; Zigbee is nice because it will remember the device's MAC and put it right back into place in your database). The idea in either case would be to see whether you can get Zigbee to respond on your hub at all. If not, you may want to contact Support to see if they can help. If so, you might still want to let them know to see if they can figure anything out, but at least there's a workaround that isn't too demanding (compared to, say, Z-Wave, where you'd have to set up all your automations again because it would make a new device on Hubitat).

1 Like

Another thing to try is to go into settings -> zigbee.
Then disable the zigbee radio, wait 1 minute and then enable the zigbee radio.
May help, may not, but worth a try.
Good luck.

1 Like

I'll try repairing a device now and see if that works.

gave it shot. no dice. im just kinda baffled why it suddenly stopped working. trying to repair a device now

Does it show yours Zigbee Network State as Online if you go into the Zigbee details?

yes it shows as online.

When I tried the previous suggestion, I disabled it, waited for it to say offline. then reenabled it. no luck in being able to control the devices.

I currently can t get the stupid peanut plugs to repair. the sengled light strip requires I turn it off/on 10 times from a light switch to reset it, of which I don't have mine plugged into. And the other zigbee devices I use are third realty light switches which I haven't figured out how to reset.

So im pretty much over it at this point and im thinking about just removing everything and adding it all back. pretty pissed about it

I have literally 9 devices that are zigbee. and a total of maybe 15 devices. at a loss for words for this happening