Hubitat or Home assistant?

After a disastrous attempt to install a Ring security keypad (which Hubitat has provided a half hearted attempt of a driver for which was so bad the community seen a need to improve but sadly is still not up the the job of pushing the capabilities of this well built Ring product) I am now seriously considering Home assistant. My main gripe is Hubitat lied by claiming the Ring Keypad is approved, it should never have been. My thoughts moving forward am I just going to have to fight all the time or should I start to jump ship? Is it possible for both systems to co exist so I can have an activation on one platform activate a virtual switch on another and so on? Has anyone had an experience on Home assistant that has pushed them to the HE platform?

Have you read this topic?


Have you reached out to support? Both versions are compatible and should work.

1 Like

Do you mind elaborating in what way do you feel that Hubitat lied to you?


Both versions have proved to be ridiculously buggy. I have spent endless hours (probably more hours than a software engineer needs to make the original driver work) Trying this, that and the next thing, removing it, factory resetting it and repeat again and again. At one point a ALMOST had a useful install that did not hang after a short period. I did not think lightly regarding this migration. Regarding "support" a quick search of the Ring keypad will reveal supports attitude to this product. So many people have had so many issues.

Hi Bobby, thanks for reaching out. Having purchased a device with three functions (disable, home enabled and away enabled) and a 0-9 numeric keypad. You would think that these features would be installed into the working driver to send a change of condition from keypad to HE and vice versa. I have experienced some of the features, some of the time and in some cases software hanging but I have never experienced all the above features all of the time so in my opinion that would not be fit for purpose. Would you not agree?

These features are provided by the device. If they sometimes work and sometimes don't, the issue is unlikely to be with the driver itself, but something else. It is hard to know what that may be, without additional details.

If you'd like us, our engineers, or other users to help you get a better experience out of your device, you might want to check the following document to learn more about troubleshooting Z-Wave devices and to get some ideas of the kind of details you may want to provide so that others could further assist you:


Agree, if it's paired, then it's working. As long as the cluster are interpreted properly. Have you tested with the keypad closer to your hub? What does your z-wave details page look like. There can be a multitude of issues why it doesn't work. I would also point out that a lot of people here have this device working fine.


Further to Bobby's suggestion, I have checked for ghost concurrency's and there are several. I have opened Zwave settings and I have no delete key or refresh key. After opening to the same result several times I checked for updates/ repair software to find the zwave device firmware updater has an unexpected error. I am wondering if a backup and re-install might be best.

Can you please post your z-wave details page in it's entirety? (Use windows snip)

1 Like

Sorry but I'm not going to even bother to search this. If support's attitude is that if it's joined then it's working then I'm going to side with them. Couple of things you need to understand about their stance toward vendor devices.

  1. They work hard to test devices and if they join and all the functions they intend to work, do indeed work, then their job is over. They're not going to support the quirks of every device out there. An open source community has that luxary because there are so many contributors and they can keep plugging away at a specific device to solve every last problem and fix every quirk if possible becuase there's no business to run.

  2. Having problems with a Z-Wave device is what having Z-Wave is like. I have some Z-Wave devices, and when they work I think they're fine, but not great. My choice is Zigbee. Too bad Ring didn't decide to use Zigbee for their second version of this device. :person_shrugging:

  3. The dev that created the driver is very good at what he does. I worked with him to test version 1 of the Ring Keypad. Everything worked. Sorry, but I never owned or tested a Ring Keypad version 2. Maybe that's what you're trying to get working, but you never mentioned which version of the Keypad you have.

No one stopping you from using HA to join the keypad and then trying methods to integrate that back to Hubiitat via HADB. Just don't personally feel that the inability for a particular Z-Wave or Zigbee device to work perfectly in every environment is a lie by anyone at Hubitat. If you think you found a bug, why don't you share the bug fix with Bobby in a private message. I'm sure they'd like to investigate and correct any driver issues if they exist.



What version Ring keypad are you trying to get working? And with which hub? C-5 or C-7?

I suspect it is the Ring v2. And that you have a C-5 hub. That combo will not work. The C-5 doesn’t support S2, and the Ring V2 will not work without S2.


I wholeheartedly agree with that in essence. Where I deviate is the additional cost manufacturers pay to the Zigbee alliance and Zwave accreditation. You only need to look at Tuya device prices to see how much design and manufacture costs compared to retail prices of approved devices.
At it's worst Zigbee and Zwave licence has stifled growth and kept smart home as a tinkerers hobby. The other problem is manufacturers wishing to use their own protocol and own hub to protect investment and future profits. The collapse of Aura in Europe who manufactured quality products and Samsung washing their hands of the "things" hub are cases in point. There should never be a need for any hub manufacturer to have to guess, interrogate or wait for a community to publish product info, this should be available to Zigbee / zwave approved hub manufacturers from the get go.

Hi, I have a C7 Hub and a G2" keypad. I have cleared a bunch of ghost drivers and have now managed to get "disarm" and "away & Alarmed" to work from the keypad with backlight and voice confirmation. The keypad retains the previous status.
From the keypad I can initiate "disarm" and "away & arm" When I select "home & armed" it seems the HSM status changes to "night armed" BUT the keypad did not confirm this by voice or backlight.
From The keypad devices page I can achieve "disarm" and "away & armed" and "home & armed"
From the Dashboard HSM shows as "disarmed" when disarmed, "Armed Night" when I select home and armed on the keypad and "away & armed" when away & armed.

It seems that no matter what I do, when I select home with a partial armed for sheds, garage etc this does not confirm activation on the keypad when the other modes do. (when arming from the keypad, if I arm any mode from an HMI screen interface the keypad works a charm.

Can you post your z-wave details page as well?