Hubitat not reporting Philips Hue bulbs last state

I noticed for the last day or 2, hubitat doesn't update the hue state when I changed settings using Hue app/dimmer or Smartthings app, even after clicking refresh on device edit page, ST does update when I hit refresh but HE doesn't
I tried polling interval of 10 seconds and 1 min and still nothing.
I know Hue released a new firmware update yesterday or so, can it be related to that?
Anybody else having the same issues?

Anybody else having similar issues? Can anyone try to replicate the same thing?

Same for me as well. HE and Hue bridge not syncing.

Edit : I went into the HE hue app and click done. It's working again. Just remember the refresh button on the hue device is disable. You can set the sync timer in the HE hue bridge apps under options.

tried that but didn't do much, they still don't sync. I'm not sure what's wrong. I hate to uninstall the whole app and start all over, will need to reenter a lot in rule machine/lighting app

what does that mean? you mean disabled in the device edit page om Hubitat?

When you press the refresh button on the device. It doesn't do anything because Hubitat disable this function. They refresh all the hue bridge bulbs inside the hue bridge smartapp.
The default is set to 1 mins. So it could take that long to see the state change when you use the hue app and turn on/off the bulb. You can try set it to 10 secs and test it.

I tried every single combination, I even removed the Hue integration app and reinstalled it
something is definitely broken, earlier I noticed some groups had their last event 3 days ago or so, now I just turned on some bulbs, changed color, level, and the state is the same for 50 minutes
only lights that update are the one involved in hubitat automation
are we the only one who have Hue bulbs,?! it can't be possible

A lot of us have Hue bulbs but I guess there no one is seeing your issue. I can't be of much help testing because I have polling disabled...I only change my bulbs state through HE so I dont need it.

Are you able to control any of your bulbs through the HE device page?
And does your Hue hub have a statically assigned IP address?
HE requires static ip addresses to pretty much any device it communicates with.

  • I can control lights using HE device page
  • Hue hub doesn't have static ip. Never heard that it's necessary. In that case we need to assign static ip for every single device that is integrated with HE. I can try that and see how it goes. I did that but only for hubitat to keep same ip address and when editing hubitat

Probably don't NEED it for EVERY device but it's a good habit in general for HA devices. Over the years I've seen strange things occur when they don't so it just became my rule of thumb.

If removing the Hue app and reinstalling didn't fix your issue, verify that the light devices it creates get deleted when the app is deleted. If not, you may need to manually delete all the devices and have them recreated when you setup the Hue integration again.

when I deleted the app, all devices were gone from the list, reinstalling the device did not fix the issue
After assigning static ip to Hue bridge, now it's syncing well, my guess that was the fix
that should be a sticky thread, I wonder why I never heard of it

You have to refresh on the Hub device. Refreshing the individual bulbs does nothing. Go into the edit device page for the hub and try to click refresh.

it started working after assigning static ip to the hue bridge, at least that's what I think did the trick
thx all for your assistance

1 Like

I have had issues with Hubitat device page and dashboards not displaying hue bulb state changes when changed via the Hue app, regardless of polling setting tried waiting minutes and changing to 10 secs. So searching found this but unfortunately my Hue Hub has had a static IP since before my Hubitat arrived and was installed on Feb 11th. I have had this problem from day one at first I thought it was a compromise using Hubitat but after some reading forums I gather it should sync every minute.

So after reading here I decided to remove and Hue Hub Integration and all its devices and setup fresh see if bulb state syncing would work.

  1. Removed Hue Hub Integration and confirmed all hue devices gone from device list

  2. Rebooted Hubitat to make sure things were fresh.

  3. Re-Installed Hue Hub Integration. At the point of pressing button to confirm link between Hubitat and Hue Hub I get Success message, but clicking the done button at that point brings up an error that also pops up every time I try to open Hue Hub Integration app from list.

I removed and reinstalled twice more , not only did I not get bulb state sync restored but now my lighting is broken lol, son was not impressed this morning when his bedroom lights were not working lol

As a very new user and Hubitat being my first HA Hub I have used besides Hue Hub itself I could be doing many thing wrong as I am learning on the fly, here are some screen grabs of error and logs if anyone knows what I have done here. I really don't know all the data in the "Hue Hub Integration Status" page and didn't screen grab original before removal but it looks different, something not working, was hoping to learn some rule machine this weekend so I need to get Hue integration solved first now :smiley:

I just tried changing one of my lights in the Hue app and the change showed up instantly in HE.

The first thing I noticed in the second screenshot is that the bulbs value is empty. I can't remember the exact screens during setup, but after the hub is discovered, there should be an option to select the bulbs you want to integrate with HE. These would need to be selected and should then populated the bulbs field. Go back into the integration app and verify that the bulbs are selected. If they are....deselect them...complete the app setup...go back in and deselect them....complete app setup.

Yes that is a problem because I can't load the integration app to add bulbs or scan for groups / bulbs.

When I click on it app to add bulbs since re integration I get the above pictured "unexpected error" screen above instead of Hue Integration App controls.

I have rebooted Hue Hub, I have removed and re installed Hubitat Hue Integration app 4 times now I have rebooted Hubitat all in different orders lol. Stumped on what wen't wrong. I wouldn't think simply removing and re installing Hue Hub Integration would break it...

Can you post a screenshot of the page you see just before you get the error?

Worst case. Restore your backup before the break. Well unless you broke the backup as well... :face_with_head_bandage:

This is the screen I would see before error, clicking next would bring it up as well as every time I clicked the "Hue Integration App" from the Hubitat built in app list. Tried twice last night, twice this morning and twice now.... second time now grabbing screen grab (6th try in 12+hour) and it magically worked... didn't go through process differently and no settings or rules changed on hub. Still stumped but seems to be back.

Still not syncing changes done in Hue app to Hubitat's "Current States" display in corresponding device page or on dashboards. Changing bulb state in Hubitat device page updates in hue app within a second so it only syncs in one direction still.

Still need to solve this this Hue Integration syncing issue that started this whole mess but at least I can control lights through Hubitat again. Alternative is banning use of the Hue app throughout the household I guess :confused: