Hubitat losing network connection

I have been having to reboot my hub frequently because when trying to connect with my phone to turn on a switch or check a status I cannot connect. I know the hub is still operating normally as I have some rules that respond when certain conditions are met and the rules still work. I have a wifi switch on the hub now that I use to reboot the hub because this happens so often. Anyone know of anything I can check to troubleshoot short of replacing the hub? I cannot access the hub with app or via the ip in a browser - including the diagnostic page.

Hubitat Rev C-4

Do you have a reserved or fixed IP for your hub or is it on random DHCP allocation?


Ok that was the only thing I could think of. Presumably the rest of your network is working reliably?

By static, do you mean that you have the hub set to a static IP or that you have a DHCP reservation on the router for your hub? If the latter, you may be losing connection to the DHCP and the DHCP Auto-reconnect under Network Settings may help you. The other thing that I’ve seen happen is that the DNS server (default is Google at will become unavailable and the hub will spend some time (my longest has been ~5 minutes or so) trying to reestablish this connection (web page will time out multiple times and then suddenly connect) - rebooting the router on a regular basis seems to help this (also not a bad idea from a security standpoint).

I have a reservation on my DHCP server for the hub, but I'm willing to give it a try doing it the other how do I do that?
I found this how to... but I cannot seem to find the Network Setup page?

In regards to the DNS being unreachable... do you mean the DNS on the router or are you saying that the hub itself has it's own DNS lookup?

On the C3 and C4 hubs, the network configuration page is not available. The only way to ensure the same IP address is used is via a DHCP reservation on your router.

Good catch missed that this was a C4.


Did you try a new, known good, network cable?

Did you try a different location on your network, or a different port on your router to rule out a bad port on the router?

What brand and model is your router? Anything like security, flood control, or anything similar in the router software that could be blocking the hub? Any error logs on the router?

Is your IP reservation for the hub outside of the DHCP range for your router? Have you scanned your network when this occurs to ensure that you aren't possibly getting an IP conflict?

Copying Victor (@gopher.ny) in case there may be info in engineering logs for your hub that he could look at (if he has time to respond he'll ask you to PM him your hub's UID) to help w/diagnosing this.

1 Like

Haven't tried either of these, but certainly can do so fairly easy. I haven't changed anything in my network setup (physically or settings-wise) in a while, so haven't really suspected these things.

I have a TP-Link TS-R605 which is a prosumer VPN router. I don't see any log entries related to specific clients.

No, it's not outside the DHCP range. I have not actively looked for IP conflicts, but I haven't received any messages about conflicts either. It would also be a major fail of a DHCP client to assign an IP to a device that was reserved for another device...

I am not familiar at all with that router, or its settings. But there is a firmware update from about a two months ago listed on the TP Link site, did it get updated and change settings?

It also looks like there is Flood Defense settings, and Packet Anomaly Defense settings. I don't know enough about this router, or routers in general to suggest what settings are good here, but my consumer grade TP Link didn't like having flood control on with Hubitat, Lutron, and other devices. So maybe this would be something to check out on your device.

1 Like

In cases like this I always like to dot all the i's and cross all the t's just in case. Only takes a minute or two to run a scanner or look at your IP assignments... :slight_smile:

1 Like

Slightly off topic - but wanted to post about a trouble I'd found - certain Comcast routers will always re-enable DHCP on power fail.
The environment I was called in for used a NAT with a Netgear router/firewall inside it. Internally, DHCP was handled by a Windows Advanced Server. On power fail, the DHCP of the comcast unit would re-enable and boot much faster than the server, and as we all know, DHCP server on windows will not run if another DHCP server is detected on the network.
It was a beast of a problem to identify - The bug was reported to Comcast, (who 3rd parties the modem/routers) but nothing ever was done. Recovery from this (prior to finally just removing and replacing the comcast device) was to disable DHCP at the comcast device, then enable it on the Windows server AND forcing a reboot of the windows server.
Detecting multiple DHCP servers is possible - using 3rd party tools to locate and find them.

Flood control and packet anomaly, imho, should be discerned at the switch, not at the router. Using a smart switch(s) as a center point of a wired network will give SNMP data for every port, which is a huge benefit to monitoring even devices such as HE wish don't provide load/traffic info, all while keeping the spanning tree management intact at the right layer.

1 Like

when you have these issues, scan your network with "Network Analyzer by Jiri Techet" it will save the LAN scan , displaying which devices are attached by IP address. See if you can find any clues there.

It's extremely useful, tons of functions

My C7 hub dropping off network. I just installed it a week ago. I am using DHCP reservation on a Netgear Orbi. When it drops, can't find it, but advanced discover can find it by MAC address even if the network cable is unplugged. I still can't ping it or connect to the UI. I hate to have to power cycle the hub.

The strange thing is Alexa can still control devices, which requires IP connectivity, as proven by unplugging the Ethernet cable on the hub.

I've switched to static IP, hoping that will resolve the problem.

@Snow_Yogi -I am having the same issue with my C7 and Netgear Orbi. I also tried switching the static IP but this didn't solve my issue. This instability seems to have started when I upgraded to 2.3.3.x. I'm currently on I have power cycled and that hasn't solved it either.

@support - I'm at a loss! My hub details say last check-in was yesterday: 10/03/2022 - 08:06:22

Are you currently on a static IP or is the IP address assigned by DHCP? Also, is network speed negotiation configured to be 100 mbps or auto-negotiated?

Can you try:

  1. Leaving it on DHCP
  2. Setting the speed to auto-negotiated

And then reboot?

Let's see if the hub stays online. Oh yeah, one more thing. What are you using for the DNS setting? Can you try (the Cloudflare DNS)?


After switching to static IP, I had a case where the hub lost DNS and none of the services would work. I've switched back to DHCP with a pinned address and that has been working for a few days. Something is definitely strange with the IP stack on the hub. I've just switched from an Netgear Orbi RBK50 to RBK750 since it looked like they weren't patching the 50 anymore.

If DNS is flaky with DHCP, try going to Settings - Network and overriding default DNS with a collection of well known public DNS service providers. This screenshot is from