Hubitat hub - Excessive calls to NTP services

I have already contacted support on this but wanted to put the issue out there for everyone.

Using my router I have been watching what services the Hubitat hub connects to. What sticks out is the high amount requests the hub is making to NTP services. Over 16MB in twenty four hours is ridiculously high. Looking at it in real time it appears the hub is calling NTP every few seconds. The hub time is correct and otherwise functioning normally. I am wondering if anyone else is experiencing this, and is there s solution to stopping this data chatter?

FWIW: My ISP does screw around with blocking/limiting calls for NTP services.

That does seem a bit excessive...:thinking:

FWIW - It appears you're using an Asus router, correct? If so, you may want to consider running the AsusWRT Merlin firmware. In thelatest release (384.11) Merlin has added a local NTP time server. He also added the ability to trap and redirect all NTP traffic to the local NTP server. I just set this up this morning on my RT-AC86U router, as I would prefer my devices get their time from my local system. This would allow for my Hubitat hubs to boot properly and get their time sync'd, even if the internet is down for some reason.


Thank you for posting this. I noticed the flashing yellow exclamation point indicating an upgrade but haven’t looked into it yet. Worth the time now.

Here are my stats and no I am not experiencing this with either of my HE hubs.

After posting above, I decided I should probably test it to make sure rebooting my Hubitat Hub still got the time sync'd properly. All appears fine with my Dev Hub, and my router does not show any NTP WAN traffic for this device, so I am guessing the local NTP server did the trick.

I just turned on the Traffic Analyzer feature of my router, based on the OP's image above. I usually keep that feature off, but I may run it for a few days as it seems to provide some interesting insight into what devices are up to. Thanks @an39511.

What model are your hubs? @an39511 - how about the model number of your hub? I wonder if there might be a difference between a C3/C4 versus the newer C5? Just a guess...

My prod is a C4, stats screen shot above and dev is C3. Neither have excessive NTP traffic.

Could be. I have a shiny new C5 in a box for my mother’s upcoming birthday. I will know in a few weeks.

I just turned off the "Intercept NTP traffic" feature in my router. I have a C3, a C4, and a C5 hub. So, I will let them all run and see if there is a noticeable difference in how chatty they are with their NTP requests...

1 Like

Hubitat Elevation™ Platform Version

Hardware Version Rev C-5

Just to clarify, my ISP does severely limit/block access to NTP so that may have something to do with my issue. Not sure why ISPs are doing this because it is an important service.

It's probably because of the increased risk of DDoS attacks.


Never knew that. Learned something new today. Thanks

1 Like

Does the discrepancy between upload (calls) and downloads (responses) indicate that the NTP calls are not being answered?

I took your suggestion and changed the firmware in the router. I really like the idea having built in NTP server. Now all the devices can use the router instead of calling to the outside. After enabling the NTP on the router the Hubitat hub stopped with it's constant NTP requests. I then turned the router NTP server back off and the Hubitat remained satisfied for about 15 minutes but then started right back up with constant NTP calls. This I think is a bug. Why after getting a time update would the hub need to call for another update so soon?

So what I think is going on is when the hub boots up it tries to set the time via NTP, and when it fails it just keeps trying every second or so until it gets a response. IMO it shouldn't do that. For all I know the ISP is seeing the constant calls and blocking the port. I know they don't block it 24/7 because the computers on my network do update their times. I see in the PC logs there are many NTP failures but eventually the port opens and they can set their time.

1 Like

Please make sure you send an email to support so @bobbyD can look into it.

1 Like

Since this morning, when I disabled the Asus Router "Intercept NTP traffic", I have been watching my C3 and C5 hub's NTP traffic after rebooting both of them. The C5 hub definitely seems to be generating more NTP traffic compared to the C3.

Model                            Up             Down          Total
C3 Hub   Network Time Protocol   836.00 Bytes   760.00 Bytes   1.56 KB
C5 Hub   Network Time Protocol   39.75 KB       39.74 KB      79.49 KB
1 Like

Happens to me too, here's my post on it. Also on a C5: Request: Provide option to specify NTP Server to use, stop hard-wiring it to

My router shows this for my hub. THis is 1 week.

So how do I switch my devices to use my router's NTP time? Seems like a good idea to have everything sync to my router's time.

I suggest creating a support ticket. The more they see related to this issue the higher the chance it will be resolved in the near(ish) term.

1 Like

Since switching over to an internal NTP using Asus-Merlin the hub has calmed down substantially. There is definitely a problem with the hub when the ISP is blocking NTP services. I opened a support ticket earlier this morning.

1 Like

You’ll need AsusWRT Merlin 384.11_2 firmware on your router.

1 Like