Hubitat hub - Excessive calls to NTP services

I've never manually added a firmware file to my ASUS router, do you just copy and paste the link to the zip file?

Using a hard wired computer, download the firmware, unzip the contents, then go into the admin section of Asus webUI, go to the Firmware Upgrade tab, select the firmware from your hard drive, and tell it to update.

Just be aware that you really should perform a factory reset after upgrading the first time to the Merlin firmware. This will wipe out all of your router settings. Make sure to have everything written down beforehand. Also, make sure to backup your current settings before you start, in case you want to revert back to the original ASUS firmware. Just know that the settings backup and firmware are a matched set. Make sure you have a copy of the original ASUS firmware running on your router before you start. Do not restore your original ASUS firmware settings within Merlin.

WHEW!!!!.....So I have this story.....So I was a little impatient and decided to try before you responded. Needless to say I didn't do any of that you listed, and uploaded the latest zip all over wifi, it told me to manually restart router after it completed. After restart the second light from the left (I'm about blind not sure what it is but is normally lit up on RT-AX88U router) never came back on like was previous. And thus no internet connection anymore, also my laptop no longer showed my 5G SSID, so in a panic I turned on my cell phone hotspot to download the factory firmware, then noticed my 2.4 SSID was I uploaded back to the factory firmware.....I think I'll wait until I have hub issues before I attempt "fixing" something before it's as this area isn't my strong after an hour later I'm finally back up and going

But thanks for the explanation, If I give it another go I will definitely use it

Ok thank you. Thats half the story.
What do I point my devices to?(PC, DVR, HE, etc?)

I run Merlin FW 384.10.2 on my Asus RT-AC87U router. I do not have that setting. Only allow me to input a time server.

You have to upgrade to Merlin 384.11_2 to have this new feature. Doing so, all NTP traffic will be intercepted by your router and will be handled locally (assuming you enable both settings as shown in my screenshot.) No changes to your devices will be necessary. That's the really cool part, IMHO.

Well then I will upgrade then. That is way cool. Thanks

I'm going to try and get this installed on my Asus RT-AX88U router Thursday following your instructions. From the above post what would be your recommendations be for the process to revert back (if needed) to the original ASUS firmware so that it is NOT within Merlin?

Think of ASUS Router firmware in the same way as Hubitat Platform firmware. Likewise, ASUS router “settings backups” and similar to Hubitat “database backups”. They are matched sets.

Backup your ASUS router settings and store them along with your ASUS firmware. This will allow you to revert back if desired.

There is a ton of information regarding Merlin firmware on Asuswrt-Merlin | SmallNetBuilder Forums

The important thing is to perform a factory settings reset after switching between stock ASUS firmware and Merlin’s firmware. The two firmware version store data differently in NVRAM.

Make sure you have the exact version of ASUS official firmware downloaded + the router settings backup before you start. You’ll need both of these if you want to revert back.


Thanks I'll give it a shot Thursday.

So I believe I'm up and running on the newest beta merlin firmware, everything looks fine except I don't seem to show my 5ghz SSID on any devices even though it shows it's clearly enabled? Do you know what this might be? I can only see the 5ghz with the "smart connect" turned on?

I don't own an Asus router (Netgear) but smart connect sounds similar to a feature on my router. On my router if it's ENABLED, then both the 2.4 and 5ghz bands are merged into one SSID and the devices will connect to whatever band is appropriate...based on what they support and what the router feels is best for that device. For instance if a device supports both bands but is far from the router, there is a good chance it would connect the device on 2.4 to maximize range. Devices could flip back and forth between bands as appropriate because there is one SSID and 1 password.

With it DISABLED, you would see 2 separate SSID's where you would have to manually select the band you want....2 SSID's and possibly 2 passwords.

Yes I'm aware of this. and that is how it worked before the new firmware.

I always use two separate SSID’s, one for 2.4GHz and another for 5GHz.

Yes that is how I have mine as well like the previous screen shot shows, there are 2 separate SSID's but yet when I click on "tools" it shows 5ghz is "disabled" but under the 5ghz settings there is nothing disabling it. And if I click on "smart connect" that previous screen shot only lists one SSID, in which I then have 5ghz but I lose all my connected 2.4 ghz devices?

Did you perform a factory reset on the settings after flashing the new firmware? Also, you can not restore your saved settings from the original ASUS firmware, as the nvram settings are not compatible. You have to set up the router from from scratch, manually entering everything.

I performed the factory reset immediately before the firmware, I can't remember if I did after.....I guess I will try again...

Ok, I just factory reset it again, (with the clear everything checked) and it's still showing disabled on the 5ghz.

Figured before I reenter everything we'll see if we can figure this out?

Found it, The new firmware and factory restore, changes the wifi channel and bandwith frequency.

Thank god I printed those out before I wiped everything!