Hubitat device list never populates in IFTTT


#1

I had all of my devices set up to be consumed by IFTTT in Hubitat. The device list in IFTTT would never populate. It just keeps saying "loading". I tried removing all devices except on virtual device to see if that would work. Same issue.


Anyone have an idea why the device list will not ever finish loading?

YF


#2

I don't know the "why" part, but I can confirm the bug.

I just tried to build an applet, and it fails in the same place as you. I cannot get the action to load in the IFTTT interface. I used Vivaldi browser on my Win10 desktop to attempt this, but I am not sure if that makes any difference.


#3

I tried it again today with Microsoft Edge browser. It now says Options Unavailable.

image


#4

Just a reminder, Microsoft Edge is not an officially supported browser.

Unfortunately, I cannot replicate this issue using Chrome, do you mind trying to see if it makes a difference?


#5

@bobbyD,
I normally ONLY use the latest version of Chrome. I just tried Edge once to see if it made a difference. The "loading" issue was discovered using Chrome. :grin:
image


#6

@bobbyD,
This is interesting. I added two WEMO devices to the integration. Now I have one virtual device, two WEMO devices. IFTTT now shows only the two WEMO devices, but does not show the virtual device. It looks like the request from IFTTT to Hubitat is not requesting virtual devices or Hubitat is not responding and sending virtual devices.


YF


#7

Which driver did you use for the virtual device? I will try to replicate. Meanwhile, IFTTT is reporting "partial outage" with no further details, so I am wondering if that has something to do with populating their pulldown menus.


#8

@bobbyD,
I set it up as a virtual presence type.
I am trying to set IFTTT to turn it on when FINGBOX detects my wife's mobile phone joining the network.

YF


#9

It has got to be the "Partial Outage" :frowning:

image


#10

I am not sure if IFTTT can "turn on" a Virtual Presence Device. Try using my Virtual Presence/Switch Driver instead, as it supports both the Switch Capability and Presence Capability. As such, IFTTT will see this device as a "switch" which it can turn on and off. Within Hubitat, it will show as both a switch and as a presence sensor.

https://raw.githubusercontent.com/ogiewon/Hubitat/master/Drivers/virtual-presence-switch.src/virtual-presence-switch.groovy

Add this custom driver, and then simply change the driver type of your virtual presence device.

You may also need to remove it and re-add it to the Hubitat IFTTT App so IFTTT will pick up the change. Afterwards, IFTTT should be able to turn this device ON and OFF. And you will get both Switch and Presence Events with Hubitat. Just ignore the switch events, and use the presence events for your automations.


#11

You might try again, or maybe if you haven't tried already, sign out of your IFTTT account and sign back in again. If that doesn't resolve the issue, try disconnecting your HE hub from your IFTTT account and reconnect.

This is a common IFTTT issue I've experienced with various services. Most frequently Logitech Harmony, but I know from experience that no manufacturer is immune to the issue. Typically disconnect and reconnect resolves the issue.

Having said that, as @ogiewon mentioned, you will only see devices that are valid for a particular action or trigger.

Currently, I'm not experiencing an issue. So while it could be due to a partial outage as @bobbyD was saying, it could also be an isolated incident within your IFTTT account.


#12

@ogiewon,

Thanks. I did as you suggested and it shows up in the list just fine. For some reason, the presence virtual device would never show up and would lock up the IFTTT drop down during the loading.

I am glad there are folks like you in the community to help us newbies get the most out of Hubitat.

Thanks, ogiewon.

YF