Hubitat C7 Stuck on WiFi Screen

I have recently upgraded on of my C7 hubs to the latest version and I am presented with this screen when I connect to the internal IP:

Welcome to Hubitat Elevation
First, let's connect to a Wi-Fi network.

This unit does not have wifi not a USB wifi connected.

I can still access the hub via my remote access subscription, but it seems that local connections from other apps using the Maker API are not working.

Tagging @gopher.ny

Try going to another page directly with the url, such as the logs page


Same result. I can get to the diagnostics so I rolled back to Working now as well as the maker api. I'll upgrade when I have more time to troubleshoot.

Another thing to try would be a network reset. Hold the button hidden under the hub for 7 seconds and let go. LED will blink then the hub reboots. It clears any networking settings.

I get this same issue with my iphone and iPad when I try to CONNECT TO HUB. I can only access the hub via remote access when using my mobile devices. This doesn’t happen on my macOS desktop via browser. There seems to be a mobile setting that is defaulting to this “ connect to a Wi-Fi network” screen when trying to get to the hub backend.

My hub is wired Ethernet connected with a static IP set so ¯_(ツ)_/¯

I also ran into this issue and spent a lot of effort trying to figure it out. But persistence paid off.
The way to resolve this is to Reset Network Settings on your iPhone.
Once you do that this screen will disappear.

1 Like

Is there any resolution to this? I am also experiencing this from several device types and browsers. The problem is occurring on the following devices:
Android tablet: Chrome and Fully browsers, all URL's directed at main IP
Windows 11 laptop: Chrome and Brave browsers, all URL's

Not occurring:
2 separate Windows 10 computers from any browser
iPhone 14, any browser

It seems to be the devices that I had connected with prior to upgrade (Win 10 and iPhone) still connect without Wifi prompt. Devices I hadn't connected from seem to go to 'connect wifi' prompt. The hubitat must be remembering and saving devices by MAC or IP address.

Try going directly to the settings page. Can change hubitat.local to your hub IP if needed.

-- http://hubitat.local/hub/edit


Tried hubIP/hub/edit as well. Same outcome.

@bobbyD ever heard of this one?

Only other thing I can think to try would be a network reset, instructions: Network Setup | Hubitat Documentation

Or maybe doing a reboot with the database rebuild selected (using 2.3.7 platform).

No, I've never seen this one before, but if it was the hub, all browsers over all operating systems would behave the same way. I wouldn't try to troubleshoot this problem from the hub side, instead from the browser side. Clearing history and/or trying incognito mode to see if that makes a difference would be my first thing to do.

@evan.durgin mind trying accessing the hub from an incognito/private window?

I have tried everything mentioned in this thread and more including:
Network reset
incognito mode
multiple browsers
clearing browser cache
rebooting hub

The issue actually happens to both of my hubs (one is C5, other C7)

This issue is preventing me from using my tablet based dashboard in the home and I am putting the house on the market with the smart home included.
Was hoping to give the wow factor for potential buyers seeing what a fully custom smart home can look like, but this is killing it..

Ok I have found a solution.
I had my Hubitats on an isolated VLAN, separate from my client devices. I had already verified that the firewalls were not blocking any traffic between client and hubitats. Also, the working devices were also on the same client VLAN as the non-working clients, so it did not make sense that was the issue.
Other than my comment about the Hubitat somehow saving remote IP/MAC addresses. It appears this wifi setup page is some sort of captive portal.
So, I went ahead and moved the Hubitats to a new subnet on the same vlan as the necessary clients. Boom, works.
So it definitely has to do with whatever captive portal type of config Hubitat rolled out in latest release. My situation probably uncommon having clients on separate VLAN, so not many people will run into that. But should be fixed, nonetheless.

1 Like

This has been driving me mad. I have a separate 2.6 IOT network for all my devices and this is has been the default for over a year now. It’s enough to make me want to switch to HA.

I'm about as far as you can get from a VLAN expert, but I have a separate VLAN for all my IoT devices, all hubs (HE, Lutron, Hue, Bond, etc.) and all of my IoT Wi-Fi devices are on it. Firewall rules block devices on IoT VLAN from initiating connections to main VLAN, and devices on main VLAN have full rights to initiate connections/access VLAN devices. VLAN is setup on a Ubiquiti EdgeRouter12.

Never had a single issue w/this on two C7s and C8, and C8-Pro, everything works normally. Others here have similar VLAN setups and are not running into this issue. Seems like this could be a VLAN/Firewall configuration issue. Others here may be able to help.

I was never able to solve this. I just haven’t updated the hub since. It is definitely a bug in a specific firmware. You can’t navigate to any pages directly except the recovery/reset page. I’ve done it multiple times and everytime the only fix is to roll back to the firmware I’m left on.