Hubitat C5 - updated firmware and now getting Wifi setup captive portal

Press the network reset button on the bottom of the hub for 7 seconds with a toothpic or paperclip. (It will be the only round hole out of all the square ones). Can you also post an image of the portal coming up?

Resetting now.

Definitely weird...

@gopher.ny or @support_team

It's still prompting for wifi after resetting :frowning:

I tagged gopher so hopefully will hear something

1 Like

Do you have a complex network with VLANs? This came up once before recently, and here is the solution the user found:

I saw that, I do not. No VLANs at all other than guest network and none of my devices are on that network. I probably SHOULD have an IoT VLAN for security purposes, but I've never gotten around to setting one up.

What firmware did you update FROM? You can use the diagnostic tool to roll back the firmware to one that is saved on the hub from a prior update. Use "Restore Previous Version" button.

If you came from a really old version there is a way to download the last 2.3.5 or 2.3.6 version if you want to install one of those. Let me know and I can post the endpoint URL if needed.

1 Like

Off the top of my head I have no idea, but it was probably a couple of years old. I'm not even sure what I upgraded TO, nevermind from :). I figured if there was an issue where a stepped upgrade was required, the UI upgrade would have handled this gracefully. Let me take a look at the diagnostic tool and see what I can figure out. I appreciate the help.

Yeah I don't think the upgrade path would have botched it up. But I would not go way back to a 2+ year old version unless you have to. See if this endpoint will work to download 2.3.5 while the hub is stuck on that Wifi portal. Version 2.3.6 had some memory issues for many people so I would not recommend going to that version, 2.3.5 should be much safer.


If not you may not have any other choice but to revert back to whatever is in the diagnostics tool, or wait for a fix from staff. You could always use the endpoint to grab 2.3.5 AFTER rolling way back, then update from the diagnostic tool to 2.3.5. That would at least get you semi-current.

So I jumped in and rolled back before reading your latest post and the wifi stuff is gone. I rolled back from to I have been having issues with my connection to my Hue lights failing every day, so have had the Hubitat on a timer to kill power and reboot 2x a day. I was hoping newer firmware might help with that. But it could also be an issue with the 3rd party code that I haven't updated since I initially installed it. I will try an upgrade to 2.3.5 as well as see if there is new Hue code available. Thanks for the help, much appreciated.

If you are using the system Hue Integration I do not think that has changed in a long time. I would actually recommend one of the Community integrations that can use the newer API. Personally I use CoCoHue but I only have 2 devices (I think new API is optional and has to be enabled in the CoCoHue app). I think Advanced Hue Bridge also uses the new API.

Unfortunately if you change integrations, it will create all new devices and you will have to fix all your apps to point to the new devices before you remove the old integration.


I am using CoCoHue as well. I take it back, it's my Lutron Pico switches (the ones connected to Hue lights) that stop working.

So as far as the URL for 2.3.5, it didn't look like anything was happening but I just finally got a response that said "success". Do I perform a manual reboot at this point? The C5 didn't reboot on its own.

You have to use the diagnostic tool and 2.3.5 should now be in the "Previous" versions to install, You can also upgrade from that button despite the name of it.

@bobbyD / @gopher.ny I got this person going again but this is something to check out, something happened in 2.3.6 or 2.3.7 (or 2.3.5 apparently) making this Wifi portal pop up for a few people.

1 Like

2.3.5 returned the wifi portal issue. Back to 2.3.4 we go :D.

Yep, so @gopher.ny C5 + 2.3.5 = no bueno. Rollback to 2.3.4 resolves the wifi captive portal issue.

Ok good to know, if you want to make sure you are on the final 2.3.4 version you can use that same endpoint above and change it to 234 to download the final 2.3.4 version.

1 Like

TY, I will do that now.

Oh wow. I just went from > and even THAT has the wifi portal issue! I am astounded that this appears to be a newly discovered problem, given it exists that far back. Lucky me! I do very much appreciate the expertise here that's gotten me out of this jam.

Have you tried from other devices / browsers? I think in the other thread the user said some devices it worked fine and others he got the Wifi portal page.

It must be effecting a very low percent of people, since it has only come up twice on here. We are probably talking less than 0.1% of users