Hubitat and Apple HomeKit Not executing

I installed the hub and I have a zooz ZWave switch installed and tried to setup a dummy switch to connect to HomeKit

It worked for a few button clicks but now nothing happening. Hubitat shows the devices properly there. HomeKit shows the devices. But when I click buttons on switch nothing happens.

Tried to restore from scratch and all. Nothing working. Please help.

To give more feedback and description on what is happening I think im having a disconnect between apple HomeKit and the hub. While it is recognizing devices in HomeKit as well as the hub, the automations I set up for the switch and button presses on the zooz switch aren't executing at all.

Here are steps I took:

  1. plugged in hub and went through setup. completed nicely.
  2. added the zooz z-wave switch device and set that up. works. the led colors that I edited all work right so its definitely connected to hubitat hub and working with zwave.
  3. I then added the HomeKit hub integration and activated it.
  4. I then check marked per some troubleshooting I read on here enable "Relaxed home hub pairing security".
  5. I then parted everything into HomeKit no issue, saw it all and read it all.
  6. I programmed 1 automation for the physical installed switch to play music in bathroom when pressed
  7. I then programmed 1 automation for a dummy switch to activate some shades when turned on.
  8. tested the first automation twice and worked.
  9. tested dummy switch and didnt work then went back to the physical switch again and didnt work.

now nothing works. something seems disconnected in communication with HomeKit and the hub??

First why are you making a virtual (I assume that's what you mean by dummy) switch? The zooz switch if exposed in the hubitat homekit integration should just show up in Homekit as a switch.

When you say nothing works, is it showing "no response" in home kit?

Make sure relaxed security is turned on in home kit integration. If it isn't, turn it on and then restart the integration. Are you on the latest version of the platform?

1 Like

Yes I am on latest platform. Sorry if was confusing. I created a virtual switch to give apple HomeKit a dummy switch to activate a scene in HomeKit separate from the physical zooz switch.

Nothing is actually triggering. Shows connected in apple, shows connected on the hub UI. But when I press the switch or in HomeKit click on turn on the virtual switch nothing is executing that should.

And yes I also made sure relaxed security was checked. To be even more specific:

  1. the zooz switch I purchased is the one with a main larger button on top that are for the load, then 4 more squares below that when clicked should activate a scene in HomeKit. When I press the physical switches the programming isn't executing.

  2. the virtual switch I programmed an automation that when I turn on that switch in the apple home app, that it will trigger a scene and that isn't executing when turned on.

It seems that one should be exported as a button controller. @gopher.ny any input?

Im confused what do you mean by this? forget the virtual switch for minute, the zooz gen32 switch should be working and its not executing the commands that I set up in HomeKit once it was recognized. The point of the virtual switch is completely separate from the physical one. even after deleting the virtual one the zooz isn't executing the scene assigned in HomeKit.

No I get that but based on the description of the switch I'm wondering if it should be exported as a button controller instead.

I deleted the virtual switch... to me the zooz switch is more important for now. The whole reason I went down this road with zooz and now hubitat is to be able to have physical buttons on my switch to execute some HomeKit scenes I have programmed for the bathroom. The zooz switch is z-wave and this hubitat hub is the only way I found to connect zwave to HomeKit.

Really frustrated as to why it isn't working for me like it should here.

Like I said, try exporting it to homekit as a button controller (this is done on the he side of the integration)

Oh, im not sure how to do that...what is HE side?

Hubitat Elevation. Does the zooz switch have a button attribute? have it export as that.


How does one edit to add button?

You don't. I was asking if it was on there. If you are using the zooz drivers, you could probably add that attribute to the driver (I don't program in groovy so I'm not sure what lines would have to go in). I run all Lutron Caseta so it all just works,.

Yea this is so weird - The HE is showing all the button presses I am making. The Home App is showing the devices and that is where I program what each button press should do.

There appears just no communication from the hub through z-wave to HomeKit to execute the command.

I have tried to restart HomeKit integration too and even the nuclear option and re-added the hub all together from scratch. just nothing seems to solve this mystery. It worked two times and nothing since.

Iv been messing around with all this stuff the last few days. I’m getting lost in your responses. Can we back up just a touch…

1 Are all of your devices Z Wave and/or Zigbee?

  1. When looking inside the HomeKit integration in Hubitat, are your devices listed under “button”, or “switch”, or “dimmer?”

  2. You mention Zooz scene controller button performing actions. Is your intent to have Hubitat control those actions and only have HomeKit act as another way to push the button? Or, are you expecting HomeKit to handle the action between the Zooz button and the end device?

  3. Are you using a home-pod or Apple TV as your HomeKit hub?

1 Like
  1. I only have 1 z wave device at moment. This zooz switch I installed in bathroom.

  2. It’s listed as a button under HomeKit integration.

  3. Yes. My intent is for the buttons on the zooz scene controller to trigger scenes that are set up in HomeKit. So the automations are configured inside home app.

4, I currently have it set as a HomePod mini. I have several hubs both HomePod and appletv, but Apple decides which one it wants to use as hub. Currently it’s picking HomePod mini.

1 Like

There's a bug in current button implementation, to be fixed in the next 2.3.4 release. Sorry about that...


Tom And Jerry Reaction GIF