Hub stop working everyday for few minutes

The screenshot needed is from Settings > Z Wave Details (not the Device list) as that shows the route information we need to see that would indicate a mesh issue. You're looking for devices that don't show a route in the end column as that may indicate a failed pairing/ghost.


Also please have the hub running with devices in use for at least 12 hours since some of the stats reset when you reboot. Please indicate how long hub was running when you took the screenshots.

Thanks for the direction. The hub has been running for 22 hours. The following are the first part of the details screen shot.

This is the 2nd part of the screen shot.

I'll leave it to someone more experienced but I'm guessing that you may have as many as 8 ghost devices there (all of the entries that have no route in the last column and no 'Device'). These are usually the result of failed inclusions and will wreak havoc on the Z Wave network until removed.

1 Like

Yes try to remove some of those dead nodes with no device listed. There are some instructions in here How To: Remove Ghosts using hub tools or a UZB Stick

Also your master bath dimmer seems to be having a hard time with 71 route changes. Does it have any sort of metal in the way that might be causing interference? Or do you have any rules that do the long fade with multiple commands? You might be overwhelming it in that case.


Thanks for the instructions. I will look into removing ghost devices. The light switch is next to 2 other switches (Master Bath Fan and Master Bath Light). There isn't any rule I am using for this switch. However, I am using Motion and Mode Lighting App to turn it on and off with a zigbee motion sensor. I notice it is now 241 routes change. Is there anyway to fix it? Is it better to remove and add it to the hub again?

Can you post your Motion app setup? I think there might an option in there that does the slow fade with multiple level commands.

Usually removing and adding again wont do much good.

Do you know what Jasco switch it is? Is it possibly old and not Z-wave plus, and being polled?

Also, a certain time range of manufacturing of the Jasco stuff I think had capacitor issues. I believe I have seen some reports of them spamming and taking down the mesh when they were on their way down the path to total failure. Do you have any spare replacements?

I experienced this with an Enbrighten dimmer that was a month old. Had to cut power to the circuit since it was overwhelming the hub as well.

1 Like

The following is the setup for my motion sensor routine. I have shut off power to the dimmer switch (GE Z-Wave plus Smart Dimmer). It seems to help because now the route changes have dropped down to 4.

I am able to remove 5 out of the 8 ghost nodes. I am having problem with the remaining 3. The log keep saying "Failed node 61 remove status: 0 SDK failure node is no longer in failed node list."
I plan to get a z-wave stick to see if I can remove them.
Also, I notice 2 of the nodes have blank under device name but the route is not blank. Do I need to remove those?

They could possibly be attached to powered devices, but if they are, you dont have them linked to a device on the hub so you cannot do anything with them. Sometimes the old routes just get stuck in there and never go away even on dead devices/nodes. Best to get rid of the nodes and if you figure out what device it was you can re-include it.

Using the Z-Wave stick, I am able to remove all the ghost devices and dead nodes. The light switches seem to response faster. The max. route changes so far is 10. Thanks for all the help.
The issue with the delay or no response from the motion sensor is still there. It has improved from all devices to only a few light switches not turning on when motion sensor is trigger. Checking the event log, it still shows command is issued but switch is not there to response. The following is when the motion routine is working correctly.

When the routine is not working, this is the event log I get.

The command is there but the switch is not on the next line to execute. It will fix itself in a few minutes if I keep making motion at the motion sensor. It doesn't limit to 1 switch but all the switches that I have a motion sensor link to it. I can't find a pattern since it happen on different switches at different time. Will a Z-Wave repair help in this case?

If you just got rid of the dead nodes recently a repair might help, otherwise it should sort itself out within a few days anyway.

Can you confirm your z-wave firmware does not need an update? If there is an update the z-wave details page would have an "Update Firmware" button. If button is not there it should be updated already.

How many lights are you trying to turn on at once with this motion sensor?
Possibly putting them in a group with command metering enabled may help, then the motion rule would just turn the group on/off.

I am not sure what version of the firmware I am on. There is a button for update firmware but when I try to update, I got the following message "Z-Wave Updater: ERROR. This firmware target is not upgradable". I use the "yourHubIP*/hub/advanced/installZipgateway718" to update to 7.18 but I still have the update firmware button.
I have 13 motion sensors which control 13 different switches. Each motion sensor only control 1 light (switch). When the problem arise, some or all of the switches that activate by the motion sensor will stop working. Every switch event log will show a command was issued (motion detected) but the switch didn't response. It will turn on after a few minutes if I keep activating the motion sensor.
Since each of the motion sensor control only 1 light, I don't think grouping will help. However, I did try to group all the lights from downstairs and see what happen. I have turn off optimization and enable metering (set the delay to 50 milliseconds). I notice not all the light will turn on (23 switches and 7 dimmers). I have to hit the on button 2-3 times to have all the lights on. The same goes with the turn off button. I am not sure if 30 switches are too many for grouping.

I asked about the Z-wave firmware because your issues are exactly what happens on the old firmware, Z-Wave is very unreliable. I think your problems will mostly go away once you get updated.

Follow these instructions to get the firmware updated. Basically you have to downgrade the gateway first so the firmware can update, then update the gateway back to 7.18

Thanks for the information. I am able to update the firmware. After the update, the hub seems to work faster. However, I still have problem with 2 of the motion sensor routine still not turning on occasionally which is huge improvement . The event log show command being send and switch not execute. Furthermore, when I turn on/off group of light (about 30), I need to hit the button twice to have it all on or off. I already turn off optimization and set delay to 300 milliseconds.
I notice the speed of 5 devices is at 9kbps and 12 devices is at 40kbps. The total number of devices on the Z-Waves detail page is 53. Could that be the cause of the switches not responding?

If you turn ON optimization that will only send commands to devices that need to change. With that off it sends commands to all devices even if it is already in the desired state.

The mesh may take a little time to heal. You could try running a full repair from the z-wave details (once) to help speed it up.

The 9kbps devices is a concern, if you do a repair check back a few hours later and see if those device have improved.

Also, if you have not done this since the firmware update you might want to do a shut down from settings and unplug the hub for 30 seconds. This will fully power down the z-wave radio and restart it.

I spend the last weekend try to fix the motion sensor and all lights on/off problem. I have tried the following and the result are mixed.

  1. I start the Z-Wave repair. I get an error during the repair.
  2. I look at each node that has 9.6kbps and repair those nodes. Some of them repair successfully but 2 of them get the following errors.
  3. I decide to move the hub to different part of the house to see if I can fix the issue. After many attempts and shut down and power off. This is the best I get. Is it true that the closer the hub in the middle is the better for the signal?

    This location only have 3 9.6kbps nodes. I am not sure what else I can do to improve the speed.
  4. With group light on/off, I notice that once I hit the on/off button, all the devices status have been updated even the physical switch doesn't reflect the actual state. For example, if I hit all on but only 80% lights are on but the rest of the 20% will show on status while the lights are still off. The dashboard will also show those lights are on and hitting the button on the dashboard doesn't provide any result. I have to turn it on at the device page.
    I have to turn off optimization in order to get all light off to work by hitting it the 2nd time to get the rest of the lights on. Motion sensor not turning on the light problem still remain but the problem now is more random on different sensor at different time. It could be working on day and all the sudden stop working for a few minutes and then back to normal again.
    Is there anything else I can do to improve the group lighting or motion sensor problem?

This should not be happening, that is poor driver coding. What drivers are those devices using, custom or system? Normally a Zwave or Zigbee driver should only update the switch state once the device has responded back with a state change.

Add more repeaters in the paths of those devices. We would need to see your entire Z-wave details screen to understand it more.

I add the Z-wave devices and let the system assign whatever driver it chose. Most of the z-wave switches are GE Enbrighten Smart Switches. Some of the switch will show genetic z-wave smart switch while other show GE Enbrighten Z-Wave smart switch even they are the same switches. They are all z-wave plus switches, from what I understand they all act as a repeater. The following is the latest Z-wave detail screen.