Hub Registration

Since I have had my C-7 hub for 3 months now, I haven’t been able to see it as registered. Even though my account is set up with my email address, it appears the hub is not locally associated with it.

A few examples:
-bought remote admin but unable to connect because my account shows no hubs registered
-had setup secure login but forgot password, the hub never emailed me a reset link (even though it said it did) the several times I tried to reset it. I guess this is because of the registration issue. I could reset the Hubitat online account access just fine, but not the hub itself.
-reset hub completely (lost all my work) because I was unable to login and had no other option. Started with fresh DB and new firmware. When I set it up it showed my email address but the Hubitat online account still shows no registered hubs. I tried a method to register the hub via the App but it showed the hub as registered. Ugh

Background info
-hub is static IP locally
-router has DHCP reservation

This is really frustrating espcallly since there is no phone number or email for customer support. The only response I got was to email them details for a replacement under warranty. Clearly the hardware isn’t the issue here. Maybe operator error?

Any advice or info you may have to help resolve this would be greatly appreciated.

Thank you!

Sounds like we could use @bobbyD 's insight here, but guessing your DNS service is not set correctly with the static IP - should read:,,,,

I'd start by only using the router DHCP reservation (change the hub back to DHCP), and see if that resolves it for you.


To identify what email account your hub is associated with locally, please connect to the hub and select Settings on the left menu. Then click on Hub Details and scroll down.

The missing hub/registration on is indicative of a hub that has not been able to connect to the cloud for an extended period of time. In fact, I checked your hub based on the email provided (by the way, you should remove the above picture revealing your email address) and it appears that it has not been connected to the cloud since 11/25/22. Please check below thread for a similar incident that occurred yesterday:


I will check that for sure! Thanks.

@bobbyD Thank you so much for the info!

1 Like


Hub details shows the correct email address as admin. shows “there are no hubs associated with email address…”

So my next step would be either change DNS or
I will try DHCP on the hub while keeping the reservation on the router.

Best way.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.