Hub recovery - Moving to UPS - oh the irony

In the process of moving to ups to ensure I can gracefully shutdown, the hub database is now corrupt.

I see a similar post here: Irony is

Unfortunately, my recovery is not going so well. The soft reset appears to do nothing.

When I open the diags tool it would seem I'm already logged in. I've tried logging out and back in. Logs straight in without asking for MAC. I've tried clearing the browser cache; which didn't work. A reboot just takes me back to the corrupt database page.

I'm in the middle of trying to downgrade to see if earlier versions are any more successful.

Update: downgraded to v2.2.9.146. Login behaviour still the same. I'm definitely not authenticated properly as commands are returning a 401.

At this stage any suggestions are very welcome.

Ouch that sounds "fun"... :cry:

What are your issues? - it wasn't clear in your post. Can you get to the UI?

For basic corruption in my experience a soft reset usually works great so if you've done that then there is something else. For Z-Wave table corruption that's a whole different thing - usually requires a reset EXCEPT now with the upgraded firmware this is a lot more manageable.

Have you tried rebooting your switch/router/firewall - maybe it's a network thing? Also temporarily use a different browser like Firefox (or whatever).. that way you know the cache is "clean". (see @thebearmay's more relevant comment below)

1 Like

Doesn’t ask for the MAC until you select the Soft Reset now.

1 Like

Hello, thanks.

Yes, I'd tried a different browser. On boot I get this:

I select the diagnostics tool:

Get the soft-reset page:

This is new. It doesn't seem to like the soft-reset input. I've also tried clicking soft-reset while logged out to see if I get asked for the mac. It never asks.

Normally would have asked you for the MAC before getting to that screen. @bobbyD we may need some expert assistance over here.

1 Like

Nothing changed, it still asks you for the MAC address before you get to the Soft Reset.

@pswogan you have a typo. please enter soft reset



Ah, yes. Been coding this morning and got distracted :slight_smile:

Ok, back to what was happening previously:

As you can see a 401. When I hit the diags tool I'm logged in. Even if Iogout, it takes me straight to the soft reset page.

For your privacy protection, the login is set to time out periodically. If you see Error 401 displayed, please Log Out of the Diagnostic Tool, then close all your browser's windows and log back in using the hub's MAC address. You can find you hub MAC address on the bottom of your hub, or go to Hub Details for information on how to find your hub MAC address from the Hubitat Web Interface.

1 Like

Funny, I was just doing that.

  • Logged out of the tool

  • cleared browser cache

  • loaded hub web page

  • appeared as logged out so went to soft reset page

  • did not ask for mac and still 401

Can you try doing this from a private/anonymous browser window?

1 Like

Can you try incognito/private mode window? What browser are you using?

1 Like

I always forget you can use incognito these days :slight_smile:

Firefox is my default browser so initially that.
I've switched to chrome to try have a clean a session as possible

Both have the same behaviour and I have now tried with an incognito window

I just tried a hard reboot inbetween clearing the browser cache and browsing. Same result. I don't get asked for a mac and then see 401 from the soft reset page.

Just tried to look up the hard reset documentation. The page is empty :slight_smile:

and for good measure I've tried a fresh browser from a clean machine.

If I'm shown as logged out and hit soft reset I'm not asked for mac. If I click cancel I'm shown as logged in again.

Just tried upgrading to latest again and same behaviour.

I cannot replicate the problem in Chrome, but we are further investigating.

1 Like

I cannot reproduce this issue using Safari on either a C-5 or a C-7. I did use a private/incognito window.

@gopher.ny @bobbyD

I can reproduce the issue if I use a local FQDN to access my hub, and not an IP address.


Are you using a FQDN or an IP address to access your hub?

Edit: Also happens if I use mDNS (Bonjour, i.e. http://hubitat.local:8081)

All of the above was done using a Private Safari window


Try this:

  • Open Diagnostics tool.
  • Press F12 to open Chrome developer tools.
  • Go to cookies and delete whatever is there:

yep, seems this was it. I'm now being asked for a mac. Thanks for that.


well, not quite as I'm pretty sure I don't have a backup but that's my own fault... :wink:

There should still be backups saved on the hub that you can use.