Hub rebooting randomly for 3 weeks

Hi there,

It's been two months that my hub is rebooting by itself randomly, and for three weeks now it's several times a day.
Sometimes during the reboot, the hub reboots using one of the previous backup files, which causes me to loose my changes, and to wreck my devices status that may not be in accordance to their actual ones.

I am posting this on the forum because I contacted support 2 months ago, and had a reply last week saying that maybe my hub hardware is faulty. For one week however, still no news. @bobbyD

If someone can help me, I would be grateful as it is getting more and more difficult to live with automations that stops, or fire at the wrong time due to the devices' status being not in accordance with what they should be.

I tested everything I could : I measured the power supply to the hub, I changed it to another power socket, I removed devices I installed just before these 3 weeks, I uninstalled any none in-built apps, I soft reset my hub... Everything is normal, except the rebooting and loss of information.

Thanks to all in advance.

And it's happening no matter the firmware version...

probably already done, but have you put your hand on it to see it its hot?

Yes, but it's not...

Is the hub well ventilated? Nothing sitting on top? Also what is it sitting on?

It's sitting on a wooden plane TV furniture, nothing on top, and no hot machine next to it.

How about your logs, are you seeing errors. If so please post them.

Unfortunately no errors from the logs before the reboots, and I have been very thorough with the logs for 3 weeks now. (I have some errors since yesterday but it's related to the power measuring plug I installed and which was not there before). I detected no pattern in the logs. When it rebooted once per day, which is now not the case anymore, it seemed to be rebooting around 22h to 24h after the previous occurrence.

have you tried do create any rules involving rebooting?
how much have you invested (eg rules simple lighting, connected devices), might be easy to factory reset and see what happens for a day on a complete clean setup?

Tagging @bobbyD.

That being said, my #1 suspicion is your power supply is going bad. Can you try a different power supply?


does support have a service level agreement detailed anywhere?
its not a support bashing just a question as sometimes communcations are quick, others take time. Peaks and troughs ?

I used two different emails when I contacted them, so it may be why. But still...

It seems to be worse the more events I have happening frequently. So I would rather think of wrong precessor or ram, but I will try a different power supply tonight, if I have an equivalent in voltage and power at home.

have you another usb power supply you can try? say one which came with a mobile phone?

I did once a week ago in order to see if I still had the issue when forcing the hub to reboot once a day at a time it was on for me, with no luck. I have no other rule for rebooting, and this one is now paused. I invested a lot of devices and rules. It would take me two days to start over scratch, and I cannot do that if it still does not work after that...

No, I did not change the power supply. I will try this tonight if I have something equivalent.

there is an app called device watchdog (search on hear) which might be able indicate if its an overload, you could set it up with a virtual device

edit, i would also detlet the reboot rule, it might restart using a previous version when the rule was still active!

Will do both, thanks for the suggestions.

I also want to add that when the hub randomly reboots, I always find a new backup file corresponding to this reboot. Would this backup file be created if this was caused by a bad power supply ?

currupt databse because on it not shutting down properly?