Hub not responding to web interface - several times now

Platform Version

Hardware Version


Having a hard time lately with not being able to connect to HB using local IP or Phone app.
Seems HB is "locking up" and will not respond when trying to connect to it from a web browser.
It also will not show my dashboards because web interface is down.
Whats weird is it seems to be working still .. light switches etc.. still work. or seem to anyway.
Only way to get connected to it is to reboot it. then it will work for 1-4 days.
Am getting this in the logs .. " status 408 on H2 Request" Any Suggestions ?

After reboot I see this ..

What is "HB"? Hubitat?

In any case, the first thing I'd try is a soft reset and restore. Platform 2.3.7 actually makes this pretty easy: Settings > Reboot, and select the Rebuild database on reboot option. (Or you can take a backup, do a soft reset, then restore that backup -- but this does that all for you.) This could help with database corruption, which might be the H2 errors in your logs.

I'm not sure what the second set of logs is supposed to show (doesn't appear to be anything inherently problematic), but if you are concerned about something there, sharing more information about the devices and drivers in use may be helpful.

I would also suggest updating to since you are a build behind, though I'm not saying there are any specific fixes for your problem there.

I'm assuming you've also ruled out easy problems like your IP address changing?

1 Like

Thank you for your response ..
Yes, I did check my IP Settings and I have the HB on a static IP ..

I did go ahead and update to : and did a backup and restore the Data Base.
Hopefully this will help IF there is database corruption.

Every time I can not assess the HUB with a web browser I see : status 408 on H2 Request Error.
Sure would like bobbyD or one of the techs.
take a look at this error, and see what they think about this error and why you can not get to the web page.

The 408 is saying that the hub is timing out on the request to provide data from the hub2/hubData endpoint - another way of looking at it is that this is a confirmation that the hub is not responding.


Sure that make sense ...
Guess I am more concerned WHY its doing this :frowning:
And How We can Fix it.

Couple of questions that may help to narrow this down.

  1. Is the hub using a wired or WiFi connection?
    a) If wired is the WiFi also defined/active (this is a known probem)
  2. Any jumbo frames (MTU > 1500) being transmitted on the network?
1 Like

Hardwired static IP .. WIFI off jumbo frames ..

H2 408 is a timeout on the endpoint hub2/hubData, the NPE on line 1285 is a request to check the existence of the template file for generating the HTML attribute. Both are handled in the code so that processing continues correctly (except for the generation of the HTML). Both are symptoms of the hub not responding to HTTP GET requests.

Well I updated to : on my C8
And did a restore using the backup restore in settings.
and did a reboot or two, then i tried the Reboot in settings ..
and saw this: Rebuild database on reboot < so I did it. and sofar this seemed to help!
Thanks everyone for the suggestions and responses. :slight_smile:
I will try and update to see how many days this lasts.

One thing you may consider doing is shutting down from the settings menu, unplug power for 2 mins to the hubitat then bring it back up. That would ensure the radio is cleared which a simple reboot does not do.

As i said it working for now ..
Think I will let it ride for a wile and see what happens. Thanks !

Welp .. Just did it again .. Could not login from phone or local web browser.
Was able to connect using http://IP:8081 Diagnostic tool.
Tring a soft reset and restore from Diagnostic tool. :frowning: See if that helps.

Im thinking its some new bug not neeccesarily in the app but in the hub firmware.
. As its not just me.

I hope @bobbyD or some of the big wigs see this and see what they think ..

Can you post your z-wave details page in it's entirety? What is your network speed set on your hubitat? Auto or 100?

Are you running an eero mesh?

Currently, it's set to auto, but I've tried both Auto and 100. Doesn't seem to matter.
Just did a soft reset and restore from Diagnostic tool < Little bit of a nuclear option..

No mesh network. just a router. And the router is Set to give HB. a static IP

Only 2 zwave devices on the oroblem hub. 6 zigbee. When it hapoens i can still ping the hub.

Just the web interface gone or sometimes the page comes up 3 minutes later. Only errors in the logs are the h2 hub info app.

Note: That's a reservation. A static ip would be directly on the device itself. It's never a good idea to use both for a device. And if you do a static ip, make sure it's outside of the DHCP pool. That said things look fine in general. There is no reason why your rule(s) shouldn't work. I assume the devices respond properly when activated on the device(s) page?

Sorry .. Yes a IP reservation ,.
Everything works great. until it stops working.
As in I can't get to the hub Using my phone or web browser locally.
Can NOT get to the dashboard or any part of the Web pages that control hub
Seems to happen anywhere from one to six days.
Then I have to reboot the hub. to get access again.

This really does sound like classic jumbo frames syndrome...I also wonder if it's a low memory issue. Can you install @thebearmay 's Hubitat Information driver and webcore's graphs and track memory usage over the course of a week? I'm wondering if something is killing the memory in your hub... You can track it like this