Hub Mesh...not so much

Trying to build a hub mesh with two C7's. Following the instructions everything looks good. However, after enabling hub mesh on both hubs, this screen is what I have on both hubs. I would expect to see the other hub's IP listed, but this is all I get. And I see no way to share devices on either, and I am assuming that is because they don't see each other. I've reconnected and rebooted both hubs a couple of times, and this is as far as I get. I'm wondering if I have a network issue. Although when I added the 2nd hub, during the connecting process, both hubs at similiar ip's. It looked correct. Any guidance appreciated.

The message in the Active Hubs section seems to indicate that this hub it trying to find other hubs to connect to.

Did you try reloading the hub mesh page or clicking the refresh button next to the "Active Hubs" heading?

Yes, I've tried refreshing, rebooting, reconnecting both hubs. I end up at this point. The ip's were both in the same subnet when I connected to new hub. I have a few different routers set up, and that causes me issues sometimes. But when I connected the new hub, they both had an IP of 192.168.0.11# so it looked good to me. Could I need to go the TCP route? I just tried UDP on both, and nothing changed.

Sounds like you have a more complex network configuration, so...

From what I recall, the hub mesh connections use multicast communications, so the network has to be able to route multicast (and unicast, I believe) traffic between the hubs. (This usually is not a problem for simple configurations when they are on the same switch, but this may require special configurations in more complex cases).

They both need to be setup the same in order to communicate. If UDP isn't working, it won't hurt to try with TCP.

1 Like

Any chance you have security turned on the hubs?

I don't think I have security turned on. How would I check that?

The hub login security section of settings.

I'd start with the basics. If you go to Settings -> Network Setup -> Network Test...see if you can ping the other hub.

what are the 2 IP's of the hubs? Did you set a DHCP reservation on the router for the hubs?
What is your wifi? mesh?

1 Like

@user2303 Switch both to tcp instead of udp

1 Like

If both hubs are not on the same VLAN, then TCP v/s UDP won't make a lick of difference.

3 Likes

True

1 Like

@user2303 have you enabled hub mesh on the device you want to mesh? At the bottom of the device page is a toggle.

Hit the regenerate token on the right of your page and go the the other hub and try and connect.

Then the devices you have shared should be there ready to add.

1 Like

I've tested the ping. it's below. The IP address of each hub looks coreect. 192.168,0.113 and 192.168.0.115 . I did enable mesh on both, per instructions. Everything seemed to go perfect. When I go to findmyhub.habitat.com, both hubs are shown. But when I go to share devices from one to the other, I get screen I started this thread with. Does that screen look right? It looks like the ip of the other hub should be shown on this screen. Also, I can't seem to share any devices. I'm stuck.

Here is the ping results:
Here are the ping results;

PING 192.168.0.115 (192.168.0.115) 1250(1278) bytes of data.
1258 bytes from 192.168.0.115: icmp_seq=1 ttl=64 time=9.24 ms
1258 bytes from 192.168.0.115: icmp_seq=2 ttl=64 time=5.59 ms
1258 bytes from 192.168.0.115: icmp_seq=3 ttl=64 time=5.80 ms

--- 192.168.0.115 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 5.587/6.877/9.243/1.674 ms

Those ping times seem kind of long for two devices on the same LAN segment. Here are what the ping times look like when I ping either one of my Hubitat hubs from the other ....

Both of these hubs are on the same switch.

One HE is plugged directly into my router, that is connected to fiber optic internet access. The other hub is connected to a hub, that is then connected to the same router as the other HE. However, I use...MOAC I think it's called. It's been a while.
Ethernet over coax cable, to get Gb speed to my detached garage where my server sits. on that end is another MOAC, with ether plugged into a switch, and then into the system. Yes, I see the difference in your pings. maybe something to do with the ethernet over coax.

That's most definitely extra latency from the MOCA transceivers. I wonder if it is packet loss. I would definitely try the suggestion of flipping to TCP on both hubs.

5 Likes

@user2303 I would agree with @FriedCheese2006 it is most likely the MOCA (I hate those things). If you can I would run a new line between switches. Also make sure within both hubs that network speed is set to Auto and not 100 Full. That said did you give setting both hubs to use TCP instead of UDP a try?

I do all things network over MOCA. It gives me the Gbps speeds I need to my plex server in my detached garage and game room. Plex server, sonarr, radarr, sab, tut, and all my users access plex over the Moca. I've not had any network issues with the MOCA in the 3 or 4 years of using it. It's been a blessing. Getting rid of MOCA is not an option. I'll have to return the HE's if for some reason it don't play well with it. Although I'm not convinced if slower pings would cause them not to see each other, when findmyhub sees both of them. I did try TCP on both, and it didn't change anything.

So here's the thing. You're right, it is unlikely to be a slow ping issue. However, if my memory serves me correctly, hub discovery is dependent on multicast. And I am unsure if multicast is working over the various segments of your home network, especially on segments that rely on MoCA.

If this is a multicast issue, then Hub Mesh is not the right solution for your needs. You should use HubConnect instead.

I'm tagging @csteele - if you go the HubConnect route, he is the best person to guide you.

Edit: FWIW, I used HubConnect for two years before Hub Mesh became available. HubConnect is very easy to setup (not as easy as Hub Mesh), but it is just as responsive and supports the same plethora of device types as Hub Mesh.

update: To simply things a bit, I brought HE two inside, to remove the MOCA issue. HE 1 is plugged into my primary router, that is connected directly to the fiber. HE 2 is plugged into a 2nd switch, which is plugged into the primary router. Everything looks the same as it did in the garage. findmyhub still finds them both and allows me to connect, but then I get stuck moving forward. I think there must be something I'm missing, or not doing. Can someone show me what this screen should look like, with a properly established hub mesh? Because it is exactly the same for me now:

Download the Hubitat app