Hub Mesh Child Devices

I have just installed the latest 2.2.4 firmware update on both my C7 hubs. I was disappointed to discover that the new hub mesh function doesn't currently support child devices. Is this likely to get added as a future update?
Apart from that the update seemed to go without hitch but not really had time to test fully yet. Hopefully the new Aeotec Siren 6 driver has resolved the issues I was having with it.

Hub Mesh does "sync" child devices--they come along as part of the parent. The whole device, including all child devices, come along when you do that.

It won't let you select a child device individually, which I'm assuming is what you're commenting on. Usually the question that people ask is something of the reverse, but if you do want just that option, you'll have to stick with something like HubConnect or Hub Link.

4 Likes

Right, you can't pick and choose parent/child devices granularly. You get parent + all child devices, or nothing.

2 Likes

Thanks, yes I've just discovered that when I tried sharing the parent. Seems excellent so far.
Very impressed with the update so far. Many thanks to everyone that made this possible.

4 Likes

I am trying to share a device with children and it does share, but the children are all listed as offline. Is that normal?

My guess is "no," but more importantly, I don't know a solution. :slight_smile: I'd give it a few minutes in case something just got messed up in the initial sync or whatnot, but if it keeps happening, then I'm not sure...

2 Likes

I have exactly the same experience. Child Devises dont appear in the list of things I can add to Hub Mesh.

I have 2 hubs called Master and Slave. I have 15 dual relays to Install on my slave and I need to control them individually from the master. along with a 3 phase HEM and several quad temperature sensors! All of which looks to be a problem.

I have tried creating child devices on my master from the Hub meshed devices but, as above they simply say offline.

Is this something that going to be addressed soon!
If not, what are my workaround options. I drive everything through Webcore!

Thanks.

Update - Waited 20 Minutes and my Hub threw an Error 500 when I tried to use the switches (Whatever that is).

After a reboot everything is now working fine . It says both Generic Component Switches are linked and its working fine in Webcore running on my master Hub. So I have no idea what the error was about but its all solved.

Download the Hubitat app