Hub Mesh does not appear to expose Child Devices?

I have another thread active about some odd issues with an Outdoor, two-outlet switched plug from Eva Logik (ZW97). For now, I have the ZW97 paired as a Zooz Dual Outlet device and it seems to be working.

The ZW97 is on one hub (C-7, and it has two lighting devices plugged in - my flag light, and a string up LEDs under my porch railing. Most of my outdoor automations are still running on an old (C-4, hub. I found when I tried to share this device from the C7 to the C4, the base device appeared in the Device List but the Child Devices did not. Did I do something wrong or is that not (yet) a supported feature?

1 Like

I'm guessing the latter. I'd never tried meshing a child device, but just looked and sure enough, none of my child devices appear for choosing.

Inovelli dual outlet
Zooz dual outlet
Zooz powerstrip

Edit: Found this thread with explanation

I tried sharing the parent, hoping the children would be exposed on the hub that was linking to the remote devices but I never saw the children show up on the device page. Maybe I needed to be more patient. I don't do that well.

This is the way it's supposed to work: you can't share child devices individually, but you can share parent devices, and then the child devices come along with it. But it sounds like you're doing that and it still isn't working... :thinking: (but at least you're not doing anything wrong!)

I will give it another try and be more patient this time.


In theory it's able to work. I have an Aeotec Water sensor (which has two child devices) on my C7, and use hub mesh to share it to my C4. I just double-checked and it's still working.

Do you have the drivers for the parent and child devices installed on both hubs? (I honestly don't know if that's necessary, or if hub mesh virtualizes the drivers.)

I asked about this when Hub Mesh was new and was told this doesn't matter, so that shouldn't be a problem, either.

The device and the child drivers are both built-in so they should be there.

Once you select the parent device on both ends the child devices will come over. You can't select the parent on the main one then only select the child on the secondary. Is a all or nothing thing.


I thought that was what I did. I will try it again . . . at some point.

I realized my screen shot had the child devices. They just seem to take a while to appear sometimes. Prior to my post, I was having the same issue, and then I captured images to post (post withdrawn) without paying attention to the image, only to realize they appeared. Sorry if anyone was confused by that past post.

1 Like

Child devices are (re)created at the time of full refresh, so yeah, the process is not instant.
It can be sped up by going to Settings - Hub Mesh - Sync Now (at the bottom). That may still take a few seconds to go through all devices, but it's as fast as it gets.

Download the Hubitat app