Hub locking up and requires a reboot

I have looked at all the suggestions from the forum about the C8 hub not working after a couple of days. I have tried static ip, etherent ip and wifi connections and the problem still exist.

I have looked at all the logs with nothing out of bounds. I never had this issue with the C5 hub and beleive this is an internal overload of memory of the hub

Does anyone have a good solution of how to fix other than rebooting twice a week?

Have you tried to substantiate this claim by looking at statistics? The best data for this is probably:


(substitute hubitat.local with your hub's IP address, though that should also work if the mDNS name is the default)

That being said, it's not clear what all you've tried. Was it just networking configuration? Sharing what else may be helpful, as that's all I see mentioned. I'd also try a soft reset/restore, looking at app and device stats, past logs, and other general troubleshooting, too.

1 Like

Can't access the url when it freezes. After I reboot the freeOSMemory is always around 1-2%. After reading other messages on the forum that is why I tried switching cables, newtwork switches, Static IP, Ethernet IP or DHCP connections to see if their were any changes to keep hub up
When the hub freezes it also will not accept any commands from Alexa

That is not a memory statistic this endpoint provides. (Maybe you're looking at the wrong "column"? You want the middle. It's CSV.)

What about the other suggestions?

Check this post: ‼ READ FIRST - Before Posting in Get Help

Especially this I would try, it has been shown to solve a memory problem that would cause the symptoms you have.


Thanks for all the directions as I never knew this existed...

1 Like

Just reply back here with more info based on the questions in that READ FIRST post if you continue to have issues after the backup/restore. I have it watched so I will get an alert for any replies.

Ok, I beleive I found the issue with hub memory. After completing a backup and restore I had the same issue 2 days later.
So since the problem was only happening at night I turned off the daily backup at 2AM. Now the hub has been operating correctly for 10 days without an issue

Was that cloud backups (only an option if you have Hub Protect) or just regular backups?
The regular backups should not be causing so much of an issue.

Check your file manager, do you possibly have a lot of (or large) files in there? That's the only thing I could think that might cause issues with the backups.

Also, make sure you are on latest firmware.

1 Like

This is a local backup and for the record my hub information
Hub Type: C-8
Ethernet Connection: Static IP
Backup Size: 755KB
Number of builting apps: 8
Number of apps: 41
Number of devices: 100
-- 42 Zigbee
-- 58 Zwave

That's very odd, do you mind sending me a private message along with your hub id? I would like to further investigate why the backup process may be causing issues.