Hub (C-5) stopped working after last update to 2.2.7; no longer boots

I'm not sure this is related to the last update I did - I've done several updates to the various 2.2.7 versions. But, my hub stopped working after the last one I did and now won't boot at all.

It's a C-5 hub. I've had it for maybe a year and a half. I did read the the USB power supply and/or cable aren't great but I've tried several others with no luck. Basically, I never see the blue light after plugging it in. I do hear a faint clicking noise from the hub.. no idea what that means although it can't be good!

Any ideas? I don't see any way to do a hard-reset.. I can open it up but not sure that's going to help me much if I don't know what to look for.


Did you submit a support Ticket?

With no LED light at all, the Hub may be dead and Support will be able to make that call. No LED, no Diagnostic Menu either... which is where the reset options are found.

Clicking noise?? I've taken mine apart and there's nothing inside that you (or I) could fix without specialized Surface Mount tools. So I wouldn't suggest going down that path :smiley: About all you could gain was to measure voltage and validate your power supply was working, but everything is very tiny and a slip with a metal probe is sure to make things worse. :slight_smile:

I opened one of my C-5's so you won't have to.. :slight_smile:

Ok, no light probably means no power. The clicking may be arcing from the micro USB connector to the printed circuit board because the solder joints have broken, as they are known to do on Hubitat’s power connector.

Too late to tell you this, but it’s unwise to disconnect power at the hub’s USB connector, which is known to break. I replaced all of my Hubitat power cords with ones having an in-line power switch.

If you are past the 90-day warranty (probably so, if it’s a C-5), the only hope might be to open the case and re-solder the connector.

EDIT: Or, perhaps you were lucky enough to purchase Hub Protect before it died.

This would probably be a fail for me as I don't have a lot of experience soldering such tiny connections.. but, knowing how much of a pain it'll be re-pairing all of my devices - it might be worth a shot anyway.

I took a picture of the USB connection.. I even plugged it in thinking maybe I'd see something when it was making that clicking noise but nope. The connector doesn't seem loose in any way. Not even sure where the issue might be




It happened to me last week, I had to downgrade to the previous firmware version. Looks like C-5 is not compatible with the new upgrade... of course, there's no an official announcement about it..

What happened to your hub last week? If it died of hardware failure, then how were you able to:

It is.


I don’t believe that’s correct. works on my C-5 (development hub) and both of my C-7 hubs (production and spare).


Well, my hub is a C-5, no hardware, nor network issues. Did the upgrade as usual, but this time just stop working after the hub reset itself after the upgrade. I look into different forums about similar issues and I was not alone.... finally, someone had step by step instructions of how reverse the upgrade to the previous one. Everything is back to normal afterwards....

@andreyherrera - first, Welcome to the Hubitat Community! works fine on every hub that Hubitat has ever sold. I have it running on my C-3 and C-4 very early production hubs.

From time to time, during a platform upgrade, things can sometimes go a little sideways. Usually, reverting back to a previous platform version will get things running again. Afterwards, it is always a good idea to make a fresh backup, and store that on a PC. Then, you can perform a Soft Reset (follow Hubitat's official documentation for this), restore the backup, and then attempt the platform upgrade again. This usually takes care of these rare cases.

Another tip that I have found useful is to always reboot the hub via the Setting Menu, BEFORE attempting a platform upgrade. This ensures the hub has plenty of free resources during the upgrade.


I've retired my C-3 for the time being... but I agree.. my C-4, C-5's and C-7's are all running normally on v2.2.7.126 with no boot issues.

I also 100% agree that a reboot and re-upgrade generally works... so much so that I can't remember ever hearing of a Hub that wasn't able to get the upgrade and work normally. There are plenty of identical "The upgrade didn't finish..", "got to 20%", "got to 50%" reports, but as far as I know, they were upgraded successfully. It's one on the difficult elements of the Community.. not everyone comes back and says "that worked". :slight_smile:


Just to make sure, you did try another power supply and/or cable?
I have a C-5 on the latest working fine, but did have a power supply issue some time back.

1 Like

Just from an official support perspective, based on tickets received, 2.2.7 was the update with least amount of problems across all models. There are some rare incidents where the hub's connection may be briefly interrupted during the update and the hub may end up with a blue light (meaning that platform doesn't start). But 2.2.7 has seen the least amount of these kind of incidents.

@jpage4500 it sounds like you are dealing with an unfortunate hardware malfunction. If you didn't send us an email, please do so, along with your hub's purchase order details and MAC address so we can explore replacement options.


C-5 hub. v2.2.7.126. The update went fine it upgraded and worked for about a few minutes, then in a few minutes all devices would just stop responding.

I will have to add that I did try to enable "hub mesh" mode after the update on both a C-5 hub and a C-7 hub, so I am not sure if this contributed to the problem. The C-7 hub mesh enabled just fine the C-5 hub had a lot of problems trying to get this setting enabled. I had to reboot a few times to finish the setup. I did not have issues enabling on the C-7.

After the update and enabling "hub mesh mode" on the C-5 hub the interface seemed to be working with the exception of devices. I could click on the devices link and see all my devices, as soon as I tried to click on a device it would just keep spinning and was unable to open anything in the devices section.

On my C-5 hub, I tried a reboot and immediately opened up the log files and watched for any issues. Unfortunately, this did not show me anything that would help me resolve the issue with the update.

I had to downgrade to a previous version and restore a backup on my C-5 hub to get everything back up and running correctly. I decided to not use "Hub Mesh" on my C-5 and instead use the "hub link" application so both hubs could work as one.

Unfortunately, I am really not sure if enabling "Hub Mesh" or doing the update caused this issue on the C-5. I should have approached this a bit differently so I could have narrowed the problem down.