HSM not detecting intrusion

I've set up HSM as below, though when armed, you can trigger a sensor (open a door for example) and HSM does not respond at all. There's no siren, notification, or even log entry. Hubitat shows the contact open, though HSM does not respond. Has anybody got suggestions as to what I can check?

Thank you all for being a part of this great community. I've found answers to many of my previous questions here because of your involvement.

I barely got HSM set up myself so I'm no expert. How do you tell HSM that it should go to away mode. There should be log entries for that before HSM goes to armed-away.

Thanks for the reply. I use a dashboard on the iPhone app to arm and disarm. When you click the tile, it displays arming and disarming options along with a status log. The log is showing "armed" when I perform the test and it fails to trigger.

Do you have a disarming delay?

1 Like

Are there clues in the first page of the HSM screen? Like the Cancel conditions? Is it possible that HSM is disabled? I know, it usually says so. I'm just guessing.


I do not.

I wonder if allowing the security system keypad to arm and disarm is the problem. We don't use it to arm, but as a backup to disarm if the network were down. I'll remove it and give it a test.

You figured it out. Turning off the keypad arm/disarm fixed it. Ideally, I'd like to be able to use the keypad to disarm without a network if needed, but if it prevents the system from truly arming, I'll just leave it out for now. Much appreciation to both you and @jason5 for the input.

1 Like

@KevsKitchen in the last pic it's armed as home, but the section you showed above with the contacts setup was for armed-away. Try putting the system into armed-away and see if it works.

1 Like

Apologies for the confusion I created by sharing screenshots from different tests. I tested in all armed modes with the same result. As soon as I turn on "Use keypad(s) to arm/disarm" the problem occurs. When keypad arm/disarm is enabled, you can arm via the web interface or iOS dashboard and the system will show as armed, though will not react when a contact or other selected sensor is triggered. Disabling the keypad arm/disarm option allows everything to work correctly.

I only added the keypad to disarm the system in the event of a network outage, though have since added battery backup to the HE and all network devices. I may come back to this and try to figure it out at some point, though it's not a priority right now.

Thanks for the input.

What keypad is it you were using? I have 2 Iris v2 keypads and 1 v3 keypad setup to arm/disarm, mainly just use them for disarming if we return home and the internet is out so geofencing didn't disarm as expected.

Exactly the same thing I was looking to do with a keypad. I've got the Xfinity XHK1-UE.

Ok so I have no experience with the Xfinity keypad but i can tell you for sure that the Iris V2 Iris V3 and if using the C-7 hub the ring keypads work perfectly before I switched my my hubs from C-4 to C-7 I was using 3 iris V2 and 2 Iris V3s in my house with HSM without issue.

Now to the helpful parts I often ran into arm disarm issues when I had the keypads set to partial arming for night and that was only the case because of a HE firmware update. Maybe reach out to support and see if there maybe a firmware compatibility problem with that keypad.

Can you show the configure page for the keypad? and do you have it set to disarm all?

If you're looking for the configuration from the device list, here it is. I don't see that option. I could just pick up an Iris or Ring keypad as well. Thanks for the input.

I have that keypad ( XHK1-UE) on a C5 hub using the Nyckelharpa app with the centralirex driver. It has worked perfectly for 6 months now.

First time I've heard of the app. I'll have to check it out. Thanks for letting me know about it!

1 Like