HPM update/Repair of webCoRE Failing

@csteele @nh.schottfam

I've tagged both of you because I am unsure of where my issue lies. I'm posting this under HPM because that's where the error is being shown. I am not using the built-in webCore because the add-on version continues to work fine - other than this issue.

Whenever I try to update or repair webCoRE via HPM, I get the following errors
From HPM:

From my Logs:

I've tried the following without success:

  • Shutdown and restart the hub, let it settle for a few minutes (for all attempts)
  • Suspend all pistons (for all attempts)
  • Run an HPM update
  • Run an HPM repair
  • Manually, copy, paste, and save webCore, Piston, and Storage updated code. Functionally, this works but leaves HPM out of sync. Running a repair to try and force a sync with HPM ends with the same failure and rollback.

So, I'm running webCoRE fine after installing the code manually, but without HPM being synchronized. I used to be able to run a second HPM update or update then repair and it would work. Now multiple attempts continue to fail.

The obvious answer (looking at the logs) might be a communication error on my end, but I honestly do not have any communication errors for anything else. The time-out error could also be that the webCoRE Piston code is so large that it's taking longer than some internal HPM setting (that's more of a question than a statement).

TIA. Any assistance will be appreciated.

I'm wondering if this:

applies and your error is just another symptom of the order of upgrade.

Can you look in Apps Code for any duplicates, please?

To solve the "sync" problem, use the Un-Match feature against the package followed by a Match Up. When it finds the match, you have a choice to mark it as up-to-date or not.

Good point! I had the duplicate Apps code entries issue previously, but was able to update HPM and then clean up my duplicates when I saw that posting back then. To be sure, I just checked my current Apps Code and I do not have any dupes.

Thanks for the tip for syncing HPM with the manually installed webCoRE code. It worked and everything is now in sync.

You mentioned the order of installation/upgrade for my existing issue. Can you expand? and who is able to fix that?

I meant in regards to platform v2.3.6 and HPM v1.9.0. It's quite rare for Hubitat to have breaking changes. I understand that Home Assistant has a higher incidence and reading release notes in advance is 'baked in' to that community. We tried our best, but the written word was our only mechanism.

1 Like