How to remove dead zwave device from device list?

I got C8 pro hub. I deleted the device from devices list

But i still see the dead device in Zwave Details list. See below.

I tried Refresh and Repair, still the Remove button does not appear. I restarted hub few times too. Still does not. How do i get the remove button?

Start by removing power to the device, then shut down the hub and remove power for about 30 seconds. When you power the hub back on (leave the power to the device off) try the refresh again.

1 Like

did that. Still the same.

shouldn't be this hard to remove devices fully.

Its not, you should have excluded it, then it would be gone.

Is the device still functional? Have you factory reset it?
If it still works and has not been reset, you might be able to do an exclusion still to remove it.

The troubles with forcibly removing it lies within the Silicone Labs z-wave firmware which seems to refuse to remove nodes having any neighbors other than the hub.

ya i should have.

its removed from wall. I'll have to wire it back up to exclude it.

Follow the "Remove devices from a previous hub connection" for how to get the hub into exclusion mode, since the device entry is already removed you cannot do it that way.

If you have any old appliances or extension cords, just use a cut off cord so you can get power and plug it right into the wall. Just be careful obviously. I have a couple of extra plastic junction boxes I use to wire up test stuff in my office. Cords cut off from old vacuums work great.

This is true, but sometimes devices die and you can't power them up and exclude. I had that happen recently and it was a pain to get the device removed. I had to break out the Z-stick and run simplicity studio. I have to agree with @anitesh.a.kumar it seems there should be a way to force remove a device when this happens. I guess it's an issue with the Z-wave protocol and not really something HE can change, but it can be a pain.


While I have 60 or so Z-wave devices, and they generally work well (especially since the C8 hub) - this Z-stick dance around dead device removal (which I've fairly well versed at doing now) - is one of the main reasons I'm shifting new device adds, and any device replacements for HW failures to Matter. Toss in numerous and messy Z-wave security levels, and Matter multi-admin - IMHO, it's just easier to deal with and troubleshoot Matter (at least over Wifi, I'm still in progress of installing my first Thread device)

Zigbee has spoiled us, in regards to device adds/removals (not to say there are a different set of issues with various Zigbee implementations). I'm not blaming Hubitat for SiLabs firmware restrictions, but the net result is that Z-Wave is generally a pain to deal with for device add/deletes/replacements and Z-wave security is generally a mess (for locks, etc.)

In regards to the OP, rather that "hot-wiring" your old device - just break out the Z-stick (or buy one if you don't have it) & Simplicity Studio - This isn't the last time your going to need this. - And after doing this process every 6-12 months, it becomes somewhat of a painful routine.


1 Like

which reliable Z-stick do you guys recommend?

one more question, i moved one of the zwave aeotec device (it's a repeater also) to another location. And just waited 1-2 days to sort itself out.

It auto changed it's route so now HE directly talks to it, but it's showing up as a end device (grey) and not a repeater (blue). Will it resolve itself into a repeater later on?

or do i need to do something?

If it doesn't change to repeater, i'll do just exlude, factory reset, exclude, and then include.


Its only not showing as a repeater because nothing sees it a a neighbor. You can try running a full repair to see if anything will pick it up.

The Zooz USB sticks are usually easy to get and work, any model will work.

To be fair it's not always possible to use the device's exclude - for instance if it's not working any more.

Yup, that's why I followed directly below what you quoted by asking if the device was still functional...

single repair of the "pooja" device didn't work

tried full repair and this the results


why does it say so many failed nodes? i dont haves any issues with all the nodes. Just the 0F (pooja).

Z-Wave chip might be jammed up. Try doing a shut down and unplug for 30 seconds to reboot the z-wave radio. Try doing just an individual repair. If you over do it with repairing you will just bog everything down and need to do another shut down.

yea nothing i did worked. I think have to just factory reset and do exclude include again.

I guess once a device is at a location, it shouldn't be moved.

I have moved devices around before no problem.

My suggestion was to fix the issue with every node failing, that should not be happening.

yea i dont know why it's failing. It use to pass before i added the fibaro button (security S0). So that might be it.

factory reset, exclude, include the pooja device, it still gets added as a end device. Not repeater.

Maybe do a reboot with a database rebuild? I have never seen it where all the repairs fail but yet the devices are still working.

Are you still having any issues or just that one device without neighbors is bothering you?

did that just now.

yea not sure why.


The pooj device still failing.

no issues overall. Just that device becoming a End device and not a repeater is bothering me. haha.

i pulled both end devices away from the mesh to show that fibaro button has so many neighbours.

Yet the pooj device has none. Maybe hubitat just decided to connect to it directly like laundry and treat it as end device?