How do you control the dimmer load on a RadioRA2 hybrid keypad?

Bit stuck here I have a ton of RA2 keypads which are hybrid, so the one in my front foyer controls the outdoor porch lights. The ID is 18, so I add it to Hubitat as k,18,Front Porch Keypad. That works, but how do you then control the dimmer load connected to it?

I'm trying to use a motion sensor to turn on the light but when I search dimmers it doesn't come up. I tried doing instead "Push Button" as the action and picked Button 1 which is the Porch Light but that never works or does anything. The motion lighting app seems to only work with a dimmer not pressing buttons.

How do I have Hubitat set the load to 50% for example on the keypad?

So if this is a button, which I think it is, you probably won't be able to have a motion sensor operate a keypad, at least not directly.

What does your keypad look like in the Device tab for these devices? What model number is this?

If this really is a button, you will want to use something like Button Controller or (more complex method) Rule Machine to translate these button presses into an action.

Far as Motion Lighting, I guess I would have to know what these act like in Hubitat, a button or a switch.

Maybe @bravenel can assist, I think he has one of these systems.

No, you should add the dimmer portion of the hybrid as a Lutron Dimmer. I think, but am not sure, that these may have two Integration IDs, one for the dimmer and one for the keypad. Even if not, you would add two devices to Hubitat, one for the dimmer and a keypad for the buttons.

1 Like

It's a RadioRA2 Hybrid Keypad, so it has 6 buttons and then also controls a load. The load may or may not be assigned to a button on it (since it doesn't have to be as you can still control the load via the Lutron app or scenes). In this case I have the load controlled by Button 4 I believe, but it's not required to set it up like this.

There's no two devices in the integration report, it's just the keypad with device ID 18. I tried adding it as a dimmer and keypad with ID 18 but the dimmer device doesn't work. Just checked again, there's definitely no dimmer or device for the load. I know there isn't 2 IDs because in HomeSeer you just add it as device 18 and HomeSeer adds it as the load plus the keypad on it.

Have you tried the dimmer directly from the Lutron Dimmer device?

If that doesn't work, it would be helpful to troubleshoot this if you could open a telnet session on a computer to the RA2 main repeater. User is lutron, pw is integration.

Type in this command to turn on the dimmer:


And this command to turn it off:


See if that works or not.

It is possible that there is a bug in the Lutron Integration that affects these. Could you try removing the keypad device for 18, and see if the dimmer works then. In the meantime, I will look into this further.

Also, one more thing: Please post a screenshot of Lutron Integration (app) App Status (gear icon) -- need to see the Application State.

1 Like

There should be 2 integration IDs, one for the keypad and the other for the controlled load. The load should be in the section with the rest of the dimmers. (The section with the headers: "Zone Room", "Zone Name", "ID")

See the photo, I have integration IDs for both the "Dining Room Keypad" and the "Kitchen" "Recessed Lights"