How do you change device parameters I Hubitat

How do I change device parameters that is not shown in device driver settings? for example Fibaro dimmer 2

1 Like

Note that there are two versions floating around. The code linked above is for 2.2.3 and later. Earlier platform versions need this:

I have 2.2.3 , installed driver and changed on the device.... But nothing happens when I press the bottons after filling in parameters . Im I doing something wrong?

I'm not sure what that means. Keep the logs screen open in another window and see if anything shows up in the log when you change the parameter using that driver.

EDIT: You don't really see anything on the screen where you are changing the parameter, you would only see the result in the log file. I hope that make sense.

1 Like

I've updated the code again, no need to figure out which version to use, the new version should work on any platform version and security setting


You need to hit “configure” after changing & saving driver. It should then just work. Change back to original driver you had, save, configure, see if you have desired new parameter operation. It’s not a chatty driver, just a parameter setter.

1 Like

Got it working!!! thanx!!

1 Like

Did you get your Dimmer 2 working OK?

I think they work ok now just need som meshing time.

devices not working
Fibaro :
Universal sensor, dont report motion
Double switch, no working s1,s2
RGBW no childs are made

Aeotech multisensor ,no motion sensor is there...

Edit; Dimmer 2 don't always report back right state

From your list I only have the 222 & 223 double relay switches.
As I'm only using one switch in these devices, at the moment, I'm using the 'in built' Fibaro Switch to control them.
While this is working OK at turning them on and off, I have to put a refresh in my rules to update the status of the device.

1 Like

I'm using the HE Fibaro Dimmer driver and mine is reporting state changes OK.
Are you using the same?

Yes the native one... But maybe its a mesh thing its only been up a couple of hours

1 Like

HI All, looking for some help. New user to Hubitat and just go the C-7 hub. I've added a Fibaro Wall Plug easily enough and just installed a Fibaro Dimmer 2. It's wired as per the diagram and control the light no problem, however my toggle switches won't work. I've read here that I need to change the parameter 20 to 1, however I'm stuggling to find out how to do this. My hub has the option in device preferences to select Toggle/Momentry/3-way. so was hoping this was the parameter 20, however when set to toggle my switches still don't work. Look
ing for help as never used the driver section before and don't know how to use the driver to set this parameter. thanks, Neale

Use Mike Maxwell’s Z-Wave Tool.

Change driver to this tool, save driver, hit configure, set parameters & save, change driver back, save driver, hit configure.

Hi Mike, thanks for the quick response. Where do I do this, in Drivers Code and Add a new driver? if you have a step by step guide for dummies - I probably need it - cheers

I’m Russ, not Mike. Mike Maxwell is on Hubitat staff. The link to his driver code is in the link I posted.

To add a custom driver, use these instructions:

Thanks and Apologies Russ...So I got the device using that driver and can see the Parameter options, but when selecting the reports nothing shows and not sure when i set the parameter if it's updating or not

It should show up in the logs. I like to have two windows open side by side, with the device page in one and the logs in the other.


Thanks - managed to get that working with one switvh, however I cant get Fibaro dimmer to work with 2 way switches. i've connected as per the wiring diagram and configured for 3-way but doesnt work with Toggle switches