HousePanel Dashboard App for Hubitat

Only reference to location in that file is TimeZone, and yes I changed it.
define('TIMEZONE', 'America/Boston');

Is there a line I need to add?

No my bad confused the clock with weather tile. For the weather tile I believe you need to modify housepanel. Php. And create a widget from that site for your location.

Find the link for the widget I. The housepanel.php file. That link needs to be updated with the li k to the widget for your local.

Well, you got me on the right track. After searching through the housepanel.php file and not finding it. I started looking at the other files and found a one called forecast.html. Bingo! Went to the link that was in there and then searched for my town. Replaced the link and the data labels and now I have weather for my area. :smile:

Good glad you got it working. Sorry I couldn't be exact. Am at work and going off the top of my head.

No problem at all. Glad you got me looking in the right place. I too should be working but this has gotten me off track for today! The benefits of working from home.

Playing with Alexa, HP and Hubitat. I currently have a pretty good report setup through Alexa. Figured I would share. This was just seeing if I could make it work. I hope to be able to make her ask for information and respond appropriately for specific devices. We shall see.

1 Like

Very cool. Now that's a smart home!

I updated my Pi with the latest version and it works well. I cannot figure out how to change the silhouette on the presence sensor tile? I hit edit and in the box that opens I select the female silhouette then click ’Okay’. When I refresh the page it reverts to the default male silhouette. What am I doing wrong? Is this the right way to change that? Maybe I have a permissions issue on the config file so I am try to validate the proper process first.


After you click on the new icon you want, click image again to bring up the other state. Pick icon for that. Then hit ok. Then select Operate mode. This is what saves your pick. If you refresh first it won't be saved.

I click Edit radio button, then the Edit in the upper left hand corner of the presence tile I want to change. In the edit box with the icons I select the female silhouette and I see the icon change to. I do not understand the "click image again to bring up the other state" comment? I tried clicking the original icon (with the edit button in the upper left corner, and then the Icon in the edit dialog box) Neither does anything when I click on them? I do not see anywhere that it is indicating "the other state." How do I see it switch to 'the other state?"

Thanks for the help.

I the edit window click the icon that just changed.

Did that. When I click the icon in the edit window that I just changed there is no indication of any change (no indication that the icon has change the the other state). I then click the 'away' silhouette icon and then click 'okay' to close the edit window. I then click 'operate' radio button and the icon reverts back to it's original state of the male silhouette.

Okay - sounds like might be a bug. Unfortunately I won’t be home to look into this until Saturday. Sorry about that.

Do the other icons work for you? If not then that means your customicons.css file needs to have permissions set to 777 just to be sure.

Do any of your tile edits stick? I was having issue with tile edits not saving. I had a permission problem on the options file.

Actually just tried. Seems you can not click for the second state on the presence tile

Okay. Multiple issues:

First is operator error (my error). I did not have permissions set correctly on customtiles.css (I do not have a customicons.css file that you referenced??). Once I did that I can change icons on most tiles and those changes do 'stick' after I click 'operate'

Second appears to be a bug. I cannot click on the presence icon and have it change to the other state (either present, or not present).

Thanks for looking into this. I mostly wanted to know if I was doing something wrong on my end (which I was on the permissions).

The presence tile should toggle between present and absent. It used to not but I fixed it recently so make sure you have the latest version. I might have forgot to upload it. I will check just to be sure.

[EDIT] I checked and the presence fix is included in the latest version.
And... I checked my install and the presence toggle works

Yup just updated all my files. Is working as expected. LOL I don't know how you slip these updates by me...

That did it. Thank you.

Yea... you are such an awesome loyal user ... I really appreciate it. This bug fix was so obscure I even forgot I did it. I didn’t think anyone would even notice or care. I stumbled upon it when I was fixing other edittile bugs. As more people are now using HP I am thinking about a more structured update process like what @MichaelS does with Ask Alexa. By the way, I think what he has done with that app is the gold standard of community contributed code with impact. Yea, and @ady624 WebCore is up there too. Those guys inspire me.

1 Like

Thanks for the kind words!!!